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Introduction 

This document is designed to accompany formal training for OrCAD Capture’s CIS and 
EMA Design Automation’s Component Information Portal (CIP). Usage methodology and 
best practices are covered. Concepts and skills taught during this course are based on an 
“explain,” “show,” and “hands-on” method. 

 

Each lesson begins with an explanation of application features and associated dialog 
boxes. Lab exercises follow that provide guided hands-on experience. 

Course Agenda 

Lesson 1: Component Information Portal (CIP) Overview 
Lesson 2: OrCAD Capture CIS Fundamentals 
Lesson 3: OrCAD Capture CIS Part Manager 
Lesson 4: Finalizing and Documenting the Design 
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Related EMA Courses  

All classes offered by EMA can be viewed at: 

https://www.ema-eda.com/learning/classes 

You will see a list of courses that are offered in a variety of delivery modes – Classroom-
based, Live-Online, and E-Learning. Custom classes, tailored to your specific company 
needs, can also be requested.  

Formatting Conventions 

The following formatting conventions are used throughout this training manual: 

• When lab procedures instruct you to click a dialog box button, tab, option, or toolbar 
icon, the item is formatted in bold, italic text. 

• When lab procedures instruct you to select a file name, folder, or schematic page in 
either the OrCAD Capture Project Manager window or a directory tree, the name of 
the file, folder, or page is formatted in courier text. 

• When lab procedures instruct you to access a directory path, the path is formatted 
in courier text. When you are instructed to select a menu option, the option is 

formatted in bold, italic text. 

• When you are instructed to select a series of menu options, the primary and 
secondary menu options are separated by the ( > ) symbol. 

• When lab procedures instruct you to press a key on your PC keyboard, the name of 
the key is enclosed in brackets. For example: <key>. 

• When lab procedures instruct you to use <LMB> you are expected to press and hold 
the <Ctrl> key on your keyboard while you click design objects using your left mouse 
button. This technique if often used to select multiple design objects. 

• Throughout this manual (LMB) refers to your “Left-Mouse- Button”. The instructor 
may also refer to this as the “Control, Select” method of choosing objects. 

• Throughout this manual (RMB) refers to your “Right-Mouse- Button”.  

• When lab procedures instruct you to select a design name or object, the name or 
object is formatted in courier text.  

•  

https://www.ema-eda.com/learning/classes
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Lesson 1: CIP Overview 

Objectives 

By the time you are finished with this lesson you will be able to: 

• Log into CIP 

• Perform CIS database searches within CIP 

• Use the Distributor Search tab to search for distributor parts 

• Use CIP to add new parts to the database 

• Track part history 

• Add mechanical parts and associate them with existing database parts 

CIP provides a powerful interface for entering, deleting, or modifying data. Users can 
search for parts within CIP as well as generate temporary parts. CIP facilitates the 
process of converting, or promoting, temporary parts to formal parts. 

 

Logging in to CIP 

Component Information Portal (CIP) can be accessed in two ways – either from an 
external web browser or from within the OrCAD Capture environment. In this class, CIP 
will be accessed from within the OrCAD environment. The CIP install program enables 
this capability during installation and is accessible after downloading the CIP client. This 
information is covered during the installation process. 

To access CIP from within the OrCAD environment, select CIP > Open CIP. 
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The login you use will determine the privileges you have while working in CIP. This is 
defined by an Administrator. If you are granted administrator privileges, you will see the 
Admin menu across the top of the CIP menu bar, which contains features that grant 
logins and roles, and defines CIP preferences.  

 

For this training course you will be logging in as a user, and you will be able to add parts, 
edit parts, and delete TMP parts. You will not see the Admin menu across the top menu 
bar. The login is: 

Username:   emacip 
Password:    Emacip_01 
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Using Help 

Once you login, the main Help link will be located at the top right area of the CIP 
window. Here you also see the login name, as well as links to log off and change 
password. 

 

When the Help Doc opens you will be able to browse or search through the help 
documents.  
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Using CIS DB Search 

Part searches in the local database can be performed in the CIS DB Search. Simple 
searches can be performed, or searches can be customized to look for parts with 
specific parametrics (PART_NUMBER, VALUE, TOLERANCE, etc.).  

 

Performing a CIS DB Search 

If more refinement is needed, parts can be searched using parametric data. In a more 
refined search, you can choose the table, parametric fields, operator, parameter, and 
condition. Additional fields can be added to the search results. For example, a search 
can be created that will return specific results but will always show the requested 
additional fields in the results.  
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Reviewing Database Search Results 

Symbols can be previewed and/or placed directly from the search. 

 

Clicking on a column header will order the search results. These results can be exported 
into Excel using the Export button. 
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Using Quick Search 

A quick search can be run by entering search data in the Search box on the Menu bar, 
then clicking the GO button to initiate the search. Quick search queries the 
PART_NUMBER, Part Type, Description, Value, PCB Footprint, and Schematic Part fields 
to match the search string entered. 

 

Using the Part Type Search 

The Part Type specifies where a part resides in the database. Users with administrator 
privileges can create Part Types. The Part Type tab allows you to search by expanding 
tables and subcategories. 
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Using the Distributor Search Tab 

The Distributor Search tab provides a way to directly search for parts that are available 
from Newark, Arrow, Future, Mouser, and Digi-Key. Options are available to search for 
parts that are In Stock, RoHS Compliant, and Lead Free. 

 

Distributor parts can be searched by Keyword or Manufacturer Part Number. Results 
that match the entered text will be returned. 

Search results contain a list of relevant parts with distributor part numbers, 
manufacturer part numbers, part descriptions, category, and quantity on hand. 
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When a part is selected from the list, part details will be displayed in the Part Detail tab. 

 

 

Distributor Links 

When a TMP part is created, links are generated for the datasheet and part image. 
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Creating New Parts in CIP 

There are several ways to generate new parts in CIP:  

• Generate a blank part and fill in the appropriate fields.  

• Copy an existing part, then update the fields that differ in the new part. This 
method automatically generates the part with a TMP part number.  

• Use the Distributor Search to locate the part from a distributor, then add it to 
the database. When it is added, the parametric data will be auto populated into 
the corresponding fields and the part will receive a TMP part number. 

New Blank Part 

To create a new part from an existing part, select the New button. 

 

This opens an editing page where all fields are blank. Data can be entered for the new 
part, including a new part number. 

Part numbers can be added using one of the methods below: 

• Enter a preferred part number in the PART_NUMBER field: 
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• Add the part with a TMP part number. Clicking the Add part with next 
temporary PART_NUMBER button will assign the next available TMP part 
number in the database. 

 

Copy an Existing Part 

To create a new part by copying an existing part, select the Copy Part button. 

 

This opens an editing page where all fields are blank. Data can be entered for the new 
part, including a new part number. 
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Part numbers can be added using one of the methods below: 

• Enter a preferred part number in the PART_NUMBER field: 

 

• Add the part with a TMP part number. Clicking the Add part with next 
temporary PART_NUMBER button will assign the next available TMP part 
number in the database. 

 

Create a TMP Part from a Distributor Search Part 

There are a few steps involved in generating a temporary part from a distributor. Once a 
part is selected, it will need to be assigned to one of the categories in the database. 
From the Component View dropdown, select the CIS database table where the part will 
be stored. 
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Once a table is selected, the part can be associated with a schematic symbol and a PCB 
footprint. The dropdown lists allow the selection of schematic symbols and PCB 
footprints that are already associated with other parts in the same table. Select the 
preferred schematic symbol and PCB footprint from the dropdown lists.  

 

Alternately, these can be left unassigned and can be assigned later. 

To change the property mapping from the suggested default mapping, or if a distributor 
property needs to be mapped to more than one CIP property, change the mapping 
configuration before creating the TMP part. After selecting a mapping option, click the 
Add Mapping (+) button to add the property mapping. 
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Click Add to create the new TMP part with the specified part data. This TMP part is 
added to the CIS database and is available for placement in the schematic. 

 
 

Preview the Schematic Symbol 

The schematic symbol can be previewed and placed on a schematic page directly from 
CIP in the Schematic Part section of the Part Information tab. There are two options, 
one for placing the part in the schematic, and the other for previewing the part prior to 
placement.  
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Preview the PCB Footprint 

If the footprint symbol can be found in the defined library path, the PCB footprint can be 
viewed from the Part Information tab. 

 

This path is defined in 
%HOME%\cdssetup\OrCAD_Capture\<version>\Capture.ini: 

[Allegro Footprints] 

dir0=<path to directory with Allegro footprints> 
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If a STEP Model has been generated and associated with the PCB Footprint, it can be 
viewed in the 3D Canvas. 

Using the Temp Parts Tab 

The Temp Parts tab contains a list of temporary parts that have been added to the 
database. These parts do not have formal part numbers assigned to them. The list can 
be sorted in ascending or descending order by clicking on the column title. Additionally, 
the schematic symbol can be previewed and placed from the Search results. 
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Configuring the TMP Parts Display 

The properties that are displayed for the TMP parts can be configured in the Configure 
Display tab. This is useful when only specific field data needs to be shown. 

Temporary parts can be deleted, although it is best to verify that it is not currently being 
used.  

 

Once a Temp Part has been created, the temporary part number should be replaced by 
a formal part number. 
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Assigning the Next Part Number 

As an option, CIP can generate part numbers using the Assign Next PN    button. 
Incremental part numbers can be enabled and assigned in the Admin > Configuration > 
Incremental Part Number menu. Once a part number has been assigned to the part, the 
librarian would then notify the engineer that the part has been updated so the engineer 
can use the Link Database Part command in CIS to update the part. Part process will be 
discussed in greater detail later in this training.  

 

Assign to Part 

If a temporary part is found to be a duplicate of an existing part, it can be assigned to 
the existing part number by using the Assign to Part feature. 
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Uploading BOMs into CIP 

When searching for a part, it may be necessary to determine whether parts have been 
used in other designs. Parts lists/Bill of Materials (BOMs) can be uploaded into CIP to 
allow for searching. Any number of BOMs can be imported. 

Each imported BOM is assigned a unique part number, and a parts list file is selected to 
import the list of parts into CIP. After import, when the detail information on the part is 
viewed, the Where Used tab will identify the list(s) where the part appears. 

 

Steps for uploading BOMs into CIP: 

• Select BOMs > View/Import 
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• Select the plus sign to assign a new BOM number and BOM revision.  
 

 
 
 

• Under BOM Items, select the Import Children button. 
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• Browse to locate and Upload a CSV file. NOTE:  If a design has variants, a variant 
BOM can be chosen for upload. 

• Add Headers and validate the file 

NOTE: In an upcoming lab you will step through uploading a BOM into CIP. 

Determining Where Parts are Used 

Once you have several BOMs uploaded into CIP you can begin tracking part usage with 
the Where Used function. With a BOM part number selected, the list of parts it contains 
will be displayed. 
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By selecting a part number from the list of parts, the Part Information page will open, 
showing the information associated with the part. The Where Used tab will display 
other BOMs where this part has been used. 

 

The results will open with a list showing where the part has been used. 

 

Adding Mechanical Parts 

Mechanical parts, such as screws and washers, may now be added to existing parts in 
the database. These parts can be included when BOMs are generated in Capture. 
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Selecting the New button will open the editor to add a new mechanical part. 

 

Once new mechanical parts have been added, they can be associated to other parts. For 
example, a connector may also need mechanical parts to secure it to the printed circuit 
board. 
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Each time the part is placed on a schematic, the mechanical parts that have been 
associated to the original part will automatically become part of the design. Once 
mechanical parts have been associated with other parts, they can be exported to a 
BOM. 
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Lab 1-1: Logging in to CIP 

For this training all the tools you will be using are located on the remote machines that 
have been assigned to you.  

1. Open OrCAD Capture CIS on your remote desktop. Select CIP > Open CIP. 
 

 
 
 
2. Once CIP opens enter the Username and Password.  
 

• Username:  emacip      

• Password:   Emacip_01 
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Lab 1-2: Performing a CIS DB Search 

1. Once you are logged in, the CIS DB Search Tab will be shown as the default. In the 
Component View dropdown, select Capacitors.  

 

Change the Default Search Data 

Note that the default property in the Parametric Field is PART_NUMBER, but you can 
change this along with the order of the search parameters. 
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2. In the Parametric Field, use the dropdown to select Package Size. Change the 

Operator to Contains. In the Parameter block enter 0603. 
3. Click the + button in the Add/Remove area to add another row. 
4. In the Condition area use the dropdown to select OR. 
5. Use the dropdown to change the Parametric Field in the newly added row to 

Temperature Coefficient. 
6. Use the dropdown to change the Operator in the newly added row to Contains.  
7. Enter X7R n the Parameter field of the new row. Do not start the search yet. 

Include Additional Fields 

Additional fields can be included to further refine the search. 

1. Enable Include Additional Fields in Search Results. 
2. Click on the Add Field + button twice to add 2 more rows. 
3. Click in the dropdown boxes to select the following fields: PCB Footprint, 

Manufacturer (you will have to scroll down in the dropdown list in the 
***Manufacturer*** fields to find this), and Manufacturer PN (you will have to 
scroll down in the dropdown list in the ***Manufacturer*** fields to find this).  
 
Do not start the search yet. You will save it so you can retrieve it later. 
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Save the Search 

 

1. In the Save a Search area, enter the name 0603_X7R. Click the Save button to save 
the search. 

2. Click on the Search button to start the search. The included fields will be reflected in 
the results. 
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Lab 1-3: Reviewing Search Results 

Search results will be displayed below the criteria and can be exported to an Excel file. 

1. Scroll down to review the search results. When you hover the mouse over an item in 
the results list, it becomes highlighted. Click on one of the items to review the part 
data.  

 

 

2. Click on the Preview button to review the schematic symbol. Do not place it. 
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Lab 1-4: Retrieving Saved Searches 

Once a search is generated, it can be saved for later use. Globally defined searches are 
available to all CIP users. Personal searches are only accessible to the user who has 
generated them. In this exercise, you will retrieve a saved search.  

1. Select the CIS DB Search menu to go back to the Search criteria page. 
2. In the Select a Search area (towards the bottom of the search page), use the Saved 

Search dropdown to select the previously saved search 0603_X7R. The parametric 
fields repopulate with the data from the 0603_X7R search. 

3. Searches can also be deleted. Select the Delete button to remove the saved search. 
 

 

Using Alternate Searching 

An alternate Quick Search is available in CIP for finding parts by typing a string into the 
search block. 

 

2. In the search block, enter 130V22. 
3. Click the GO button to start the search. Review the results. The string entered is in 

the part number. 
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Lab 1-5: Performing a Distributor Search 

1. Click on the Distributor Search menu. 
2. Select Digi-Key. 
3. Select the Keyword option and enter the value 10uF. 
4. Check the options for In Stock, RoHS Compliant, and Lead Free. 
5. Click Search and review the results. 

 

Reviewing Part Details 

1. Click on a part in the search results.  
 
Note: The part you select may differ from the following picture. 
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Do not close the part detail page. You will use this part for the next exercise. 
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Lab 1-6: Creating a TMP Part Using the 

Distributor Search Portal 

The Category, or Table, is the primary location where a part resides in the database. The 
Part Type field defines the subcategories. You can define this in the CIP editor. The 
following image shows how the Part Type appears in CIP. 

 

1. The part detail from the previous exercise should be open. Towards the top of the 
Part Detail page, use the dropdown in the Component View area to select 
Capacitors. This is the category table where the part will reside in the database. 
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2. Make sure the Action is set to Create TMP Part. 
 

 
 
3. In the Schematic Part area, select Current and use the dropdown to select 

CAPACITORS\CAP.  
 

 
 

A PCB Footprint may exist for the part and can be selected in the PCB Footprint area. 
For this exercise, because you chose to search for a part that is an 0603, the EMA library 
contains PCB footprints that will work for this part. Typically, you would check the 
package size provided in the part detail and look for the footprint that matches this part 
in the PCB Footprint dropdown. In general, you can check the Package/Case in the 
Attributes to find the package size: 
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NOTE: When you use the dropdown to see the footprints that are available for this cap, 
you will see the EMA parts that have been installed. These parts have been built based 
on IPC criteria; therefore, the naming convention for these parts is based on IPC naming 
conventions. For example, the PCB Footprint you will choose from the list is named 
CAPC3216X180N. 

IPC naming convention defines this as:  CAPC (CAP CHIP); 3216 (metric package size); 
X180N (by height; all measurements are NOMINAL).  

4. In the PCB Footprint area, select Current and use the dropdown to select 
CAPC3216X180N. 

5. Click Add. 
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When you map a schematic symbol and PCB footprint at this stage that they do NOT 
come from the distributor or vendor. These are symbols and footprints that already 
exist in the database. CIP offers you a choice to map to an existing part. 
 

To supply customer demand for content, EMA has implemented Ultra Librarian. Ultra 
Librarian™ for OrCAD provides a comprehensive, cloud-based library of over sixteen 
million components, eliminating the need for manual building and maintenance. Ultra 
Librarian for OrCAD offers engineers the option to search, preview, and place 
components quickly without leaving the native CAD design environment, saving time 
and eliminating errors. More information can be found at https://www.ema-
eda.com/products/orcad/ultra-librarian-for-orcad.  

The part has automatically been created and assigned a TMP part number. This means 
the part has been added to the database. The part data, along with parametric data, is 
transferred from the Distributor to the local CIS database. 

 

https://www.ema-eda.com/products/orcad/ultra-librarian-for-orcad
https://www.ema-eda.com/products/orcad/ultra-librarian-for-orcad
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Note: Your TMP part number may be different than in the image above. This is due to 
the different databases on each remote training machine. Most important to note is 
that CIP automatically tracks new temporary parts and their part numbers. 

Previewing the Schematic Symbol 

In CIP, you can preview and place the schematic symbol on the schematic page. You will 
be placing a part from CIP in a later exercise. In the following exercise you will preview 
the part. 

1. In the Schematic Part field of the Part Information tab, there are options for placing 
the part in the schematic and for previewing the part prior to placement. Select the 
Preview button to view the symbol. Close the Preview window. 

 

Previewing the PCB Footprint 

If you mapped a PCB Footprint symbol to the part that was previously created, you can 
choose to preview it. 

1. In the PCB Footprint field, click the Preview button. 



 

November 2021 EMA Design Automation, Inc. ®   © 2020 All rights reserved  53 

 

Checking the Temp Parts Tab 

When you check the Temp Parts menu, you can see all the temporary parts that have 
been generated, the creation time, and the user who generated them. 

 

1. Click on the Temp. Parts menu to view the list of temporary parts that have been 
generated. 

2. Click on a part to select it and view the part details. 
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November 2021 EMA Design Automation, Inc. ®   © 2020 All rights reserved  55 

Lab 1-7: Adding a New (Blank) Part 

There are several ways to generate new parts within CIP, such as copying from an 
existing part to create a new part, starting with a blank form and manually entering the 
data, or adding a part using the Distributor Search menu. In the following exercise, you 
will generate a new capacitor by using the NEW option. 

1. In the Components menu, use the dropdown to select Capacitors. The part detail 
will appear for the first capacitor part number in the Capacitors table. You can use 
this part as the template to copy to a new part. 

 

 

2. Once the part detail appears, click on the New button   . 
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3. In the PART_NUMBER field, click on the Next PN button to populate the next 

available CIP part number for Capacitors. If your company does not already have a 
part numbering system, you could use the one provided in CIP. This applies to all 
categories of parts. 

 

 
 
4. Populate the remaining fields as shown: 

DESCRIPTION  =  CAP, Ceramic, 2700 pF, 20%, 16V, 2012 
VALUE  =  2700 pF 
TOLERANCE  =   20% 
RATED VOLTAGE  =  16V 
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5. Click the Add Part with Given Part Number button      to generate the new 
part. 

Next you will add manufacturing data for the new part.  

6. Scroll down to the Add Manufacturer Part area. Enter MFR-NAME-01 in the 
Manufacture field. 

7. Enter MFR-PN-01b in the Manufacturer PN field. 
8. Click the Add button to update the manufacturing data. 

When you add a “real” part to your database you will most likely spend more time 
adding actual manufacturing information and other relevant data. The sample we used 
in the previous exercise was to demonstrate how to input the data. 
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Lab 1-8: Copying an Existing Part 

Use the Copy feature to copy an existing part that meets most of the criteria for a new 
part you want to generate. In the next exercise, you will generate a new resistor from an 
existing one. 

1. Select Components > Resistors. The Part Data for the first resistor in the Resistors 
table will appear. 

 

 
2. Click on the Copy button. You will alter several field parameters. 

 

 
 
3. The part is now in edit mode. In the Description field, change the Tolerance to 5%. 
4. In the Tolerance field, add 5%. 
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There are a couple of ways you could add this part in its new, updated state. Selecting 
the PART_NUMBER > Next PN button would auto-generate a new part number. This 
would be determined by Administrative settings that can be set to use CIP’s internal 
part numbering scheme. (NOTE: You will not be using this option for this part). 

 

Another way to add the part is to assign it a TMP number. This will allow the part to be 
validated prior to assigning it a formal part number. This is recommended when copying 
a part from an existing part. 

 

5. Click the TMP button to generate the new part with a TMP number. 

NOTE: Because you copied this part from an existing part it assumes the Part Type of the 
original part. 
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Lab 1-9: Tracking Part History 

Changes to parts can be tracked using the History feature. History can be checked for 
both Part Information and the Manufacturing Parts. 

1. Using the part you just generated, select Edit to make a change to the part. 
 

 
 

2. In the Company Part Status field, enter Unreleased. 

 

3. Click the Save button to save the change. 
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4. Select the History tab. 
 

 

Checking Manufacturing History 

Manufacturing history can be tracked for changes. The Manufacturer Association 
History tab displays this information. 
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Lab 1-10: BOM Import 

In this lab you will learn how to import Bills of Materials into CIP. BOMs must be in a CSV 
format in order to be imported.  

1. Select BOMs > View/Import. 

 

In the next steps you will be importing a sample BOM. The BOM has already been 
exported from OrCAD Capture CIS using the Reports > CIS Bill of Materials > Standard 
command and saved as CSV files. 

2. Click on the Plus + sign to start a new BOM import. 

 

3. In the PART_NUMBER field, click the Next_PN button to add a BOM part number. 
Note: The BOM number that is assigned may be different from the one showing in 
the image below. 
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In a typical setting the BOM part number will already be established and can be 
retrieved for upload. In this exercise, you will use the auto-part numbering system to 
identify the BOM part number prior to uploading. 

Additionally, there are other fields you can edit, such as description, cost, and build, to 
help identify what the BOM represents. 

4. In the Revision area type A. When finished, click the Plus + sign to enter the BOM. 

 

5. Click on the Import Children button to import that BOM. 
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6. Browse to and select 
C:\EMA_Training\CIS_CIP_Usage_174\Board2_BOM.CSV. 

7. Select Upload.  
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Adding Headers to the BOM 

Next you will add the headers and complete the import. 

1. In the PART_NUMBER column, click the dropdown to select PART_NUMBER. 
2. In the Part Reference column, click the dropdown and select RefDes. 

 

3. Once the headers have been added, click Check to validate prior to importing. 

 

4. Click Import to import the BOM into CIP. The BOM will upload as shown below. 
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Lab 1-11: Where Used 

Now that a BOM has been uploaded into CIP you will be able to see it in a dropdown 
area in the upper right area of CIP. Note that the number of BOMs you see in the list on 
your training machine may differ than what appears in the following image. 

 

1. From the BOM dropdown, select the BOM you just uploaded. 
2. Click on the first part number in the list. 

 

 

3. When the Part Detail appears, click on the Where Used tab. 
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The BOM you previously uploaded should appear in the list of Where Used items.  
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Lab 1-12: Adding Mechanical Parts 

Just as you can create new parts using the distributor portal you can also copy existing 
parts to generate new ones. For this lab you will use the distributor portal to generate 
new mechanical parts. 

1. Select the Distributor Search tab and select Digi-Key. 
2. Leave the Search Type set to Keyword. 
3. In the Search Text area type washer flat. 
4. In the Options area, check In Stock, then click the Search button to begin the search. 

 

5. Select any #4 washer from the search results. 

 

6. In the Part Detail tab, use the dropdown to select Mechanical. 
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7. Leave the Action set to Create TMP Part and Add the part. Note: If you had a 
graphical representation of mechanical parts available in the libraries you could 
associate the part with the schematic part graphic. In this instance we will leave it 
UNASSIGNED. 

 

Associating a Mechanical  Part with a Component 

Once a mechanical part has been added to the database it can be associated to a 
component so that each time that component is added to a schematic, the associated 
mechanical part will travel with it. 

1. From the Components tab, use the dropdown to select Connectors. 
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2. Using the pat number dropdown, scroll down to locate and select part number EMA-
00006060V22. 

 

3. Once the part information opens, select the Mechanical Parts tab. Use the Part 
Number dropdown to select the washer you just added. Note: It will probably have a 
TMP part number. 
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4. Click the New button in the Description area. 

 

Notice the part is now added to the original component. 

 

Each time you place the part on a schematic, the mechanical parts that have been 
associated to the original part will automatically become part of the design. Once 
mechanical parts have been associated with other parts, they can be exported to a 
BOM. 
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Lesson 2: OrCAD Capture CIS 

Fundamentals 

OrCAD Capture’s Component Information System, or CIS, is a part management tool 
that organizes and coordinates the part placement process. CIS provides access to a 
local centralized database containing all the relevant information for parts used within a 
schematic design. Primary input for part definition typically comes from the Engineering 
department. However, other groups, such as Manufacturing and Purchasing, also need 
to provide and/or edit part information.  

 

CIS provides a core solution in overall library management and facilitates a streamlined 
flow for product design from schematic, to simulation, to PC board. 

Benefits of CIS 

The primary benefit of using CIS is its ability to organize engineering data into a 
centralized, usable database. Additional benefits to consider are: 

• Automatically consolidates part definition input from various departments 

• Automatically enter new parts into the approval process 

• Updates schematics to reflect changes made to approved parts 

• Ensures production designs only contain approved parts 

• Ensures Bill of Materials contains the latest data 

• Maintains a link between the schematic part and its database record 

• Promotes data consistency and use of preferred parts 

• Transfers selected data from the database to the schematic 

• Ensures a unified and compact library 
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• Ensures part selection from the approved centralized library 

• Promotes sharing and reuse of centralized parts information 

• Eliminates duplication and separate part libraries 

CIS Interface and Functionality 

CIS streamlines the front-end design process into two graphical user interfaces, the CIS 
Explorer window and the Part Manager window. 

CIS Explorer Window 

The CIS Explorer window provides access to the parts that have been approved and 
reside in the centralized database. Parts can be searched, parametrics can be reviewed, 
schematic symbols and PCB footprints can be viewed, and parts can be placed in the 
schematic. 

Part Manager Window 

The Part Manager window keeps an accurate status of every part in a design. It provides 
a graphical interface where the status of each part will be indicated by a specific color. 
Parts can be linked to updated database parts and verified of their current status before 
going out for Bill of Materials. Variants can also be defined and maintained using the 
Part Manager window. 

Accessing CIS Explorer 

The CIS Explorer window can be accessed in several ways: 

• Select Place > Database Part 

• Right click on any location in the schematic and select Database Part  

• From any location in the schematic, press the Z shortcut key 
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CIS Explorer Window 

 

Explore Database and Query Window 

There are two tabs in the database window, the Explore tab and the Query tab. The 
Explore tab allows browsing through the database hierarchy to find parts in their 
relevant part categories. The Query tab can be used to perform a refined search based 
on parametric data. 
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Explore Window Query Tab 

The Query tab provides an efficient way to find parts and returns a list based on the 
search criteria. Three fields can be used to refine a search – Property, Compare, and 
Value. Once each field entry is filled, another row will be added enable refinement of 
the search. Queries can be saved for later use. 
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Parts Window 

The Parts window displays the schematic part associated with a selected part. The Parts 
window can show the Normal graphic or the Convert Part (the DeMorgan Equivalent) as 
well as the specified part in a multiple part package. 

 

PCB Footprint Window 

The PCB Footprint window displays the footprint for the currently selected part. The 
window can display only Allegro footprints or OrCAD Layout based footprints. 
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Visibility Window and Settings 

The Visibility window displays the default settings for the visibility of part properties on 
the schematic page. This window can be used to override the default settings. Custom 
visibility settings can also be set for the current part. 

 

There are four possible visibility settings. 
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Database Parts Window 

The Database Parts window displays results in spreadsheet format. In the table, the 
columns can be sorted by clicking on the field header, column widths can be adjusted, 
the order of the columns can be changed by dragging their position, and columns can be 
hidden or unhidden. 

 

Placing a Database Part 

Within the CIS Explorer window, when a desired part has been found, select the part in 
the part table. When it turns green it is ready for placement on the schematic. Double 
clicking on the part will attach the part to the cursor, allowing it to be placed it in the 
schematic. 

 

Browsing Part Properties 

Browsable properties are set within the CIS configuration file. The property is generally 
used to open datasheets associated with parts in the database. 
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Relational Database Support 

The relational support provided allows users to see a one-to-many relationship between 
the vendor table and the part table. The primary key is the PART_NUMBER. This allows 
for one corporate part number to be associated with multiple vendor part numbers. 
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Lab 2-1: Creating a New Design in CIS 

1. On your desktop, locate and double click the OrCAD Capture CIS icon 
2. If the Product Choice window appears, select OrCAD Capture CIS and click OK. 
3. Click on File > New > Design. 

 

4. A new design will be created. Right click on the design and select Save As. 
5. Save the new design as 

C:\EMA_Training\CIS_CIP_Usage_174\CIS_Training.dsn. This 

design will be used in future exercises. 
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Lab 2-2: Configuring CIS Explorer 

1. Click on the PAGE1 tab of the schematic.  

 

2. Select Place > Database Part. The CIS Explorer window opens.  
3. Click View > Footprint. When the Footprint option in this menu is unchecked the 

footprint window will not appear in CIS Explorer. 
4. Click View > Footprint again to have the footprint window reappear. 
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Lab 2-3: Using CIS Explorer to Search and 

Place Parts 

1. The upper left window of CIS Explorer is the database window. Click on the plus sign 
to expand the top-level database. When expanded, you will see part folders (or part 
tables) where parts are located. 

 

2. Expand the folders by clicking the Plus (+) sign next to each one. 
3. Expand the Capacitors table first. This will display all associated CIS Part Types for 

Capacitors. 
4. Expand the hierarchy for Capacitors > EMA > Ceramic > SMD > 0603. 
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If a new part is generated, unless the Part Type is defined in CIP, the part will be added 
to a new folder named Unassigned Part Type. If a part is copied from another part that 
already has the Part Type defined, it will assume that Part Type. 

 

 
5. Go to the Database Parts window and review the results of the 0603 category you 

just chose. 
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Lab 2-4: Rearranging CIS Columns 

You can rearrange CIS columns to suit your preferences for each table. This information 
will be stored in the Capture.ini file and will be restored the next time you open the 
altered CIS table.  

1. In the parts table, select the Schematic Part field header and drag it to the left. You’ 
will notice a red line as you drag that indicates where to drop the column. 

 

2. Drop the column to the right of the Part Type column. 
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November 2021 EMA Design Automation, Inc. ®   © 2020 All rights reserved  96 

Lab 2-5: Placing a Database Part 

1. Click on one of the parts in the parts table – the part turns green. This indicates that 
the part can be placed on the schematic. 

2. Double click on the part that you have selected. 

 

 
3. The part becomes attached to the cursor and the schematic page opens to enable 

placement. 

 

 
4. Click to place the part on the schematic. 
5. Hit the <Esc> key twice to exit part placement. 
6. Right click in the schematic and select Place Database Part to return to CIS Explorer. 
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Lab 2-6: Using Query to Search 

1. In the CIS Explorer window, click on the Query tab. 

 

2. Click in the Property box and select Description. 

 
 

3. Click in the Compare box and select Contains. 
4. Click in the Value box and enter ceramic. Hit the <Enter> key. 
5. Save this search by entering the name capcer in the Select a Query field, then click 

Save Query. This will enable you to retrieve the search for future use. 



 

November 2021 EMA Design Automation, Inc. ®   © 2020 All rights reserved  99 

 

6. Review the search results. 

Sorting Search Results 

1. Double clicking on any column header in the parts table will sort the results based 
on that field. Double click on the Value column to sort based on value. 

 

Placing Parts 

1. Click on one of the capacitors in the search results. 
2. When it turns green, double click to place it in the schematic. 
3. When the schematic page appears, click 3 times on the schematic page to place 3 

capacitors. 
4. Save the design. Do not close CIS. 
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Lab 2-7: Add Parts to the Schematic from 

CIP 

The schematic named CIS_Training.dsn should be open. In Lab 2-6, you learned 

how to place a part on the schematic from the CIS Explorer window. 

Next, you will place the part from within the CIP window. 

Placing a Schematic Part from CIP 

1. Select the CIP tab and open the Resistors table.  

 

2. The first part number in the table will show in the Part Detail. In the Schematic Part 
field, select the Preview icon to preview the part before placement. 
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When the Preview window opens you can examine the part before placing it.  

 

3. From the Preview window, select the Place button. The schematic page will open, 
and the part will be attached to the cursor, allowing you to place it on the 
schematic.  
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Optionally, if you do not need to preview the symbol before placing, you could have 
chosen the Place button from the Schematic Part field in CIP. 
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Lesson 3: CIS Part Manager 

The Part Manager’s role provides a constant checking of the status of each part residing 
in a design as well as providing functionality to update part status and create and 
manage variants of the schematic. 

Accessing Part Manager 

Part Manager can be accessed in a couple of ways. The first way is to select the design 
(.dsn) in the Project Manager, then select Tools > Part Manager > Open. 

 

The second method is to right click on the design (.dsn) in the Project Manager. And 
select Part Manager.  
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Part Manager Window 

The Part Manager window contains two panes. The left pane is the Tree View and is 
used for creating groups and subgroups used for BOM variants. The List View, in the 
right pane, displays all parts used in the schematic design and shows the status of each 
part. 
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Sorting the Part Manager Window 

Data in the Part Manager can be sorted by clicking on the column headers.  

 

Configuring the Part Property Display 

In addition to the order, the display of part properties can be configured in the Part 
Manager window by selecting View > Configure Part Properties Display. Choose an 
Available Part Property from the list on the left, click Add -> to add it to the Selected 
Part Properties on the right, then click OK. The part property will be displayed in the 
Part Manager. 
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Placed Part Status 

There are several states, or part status indicators, associated with each part in a design. 
The part status for each part can be viewed in the Part Manager.  
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Part Manager Options 

There are several options you can apply to parts within Part Manager. They are: 

Link Database Part – associates a component on the schematic page with a part you 
choose from the CIS database 

View Database Part – displays CIS Explorer and the selected part and its database 
properties are displayed 

Update Selected Part Status – ensures that the selected part exists in the CIS 
database. Any differences between the schematic parts and its database 
properties are displayed. 

Update All Part Status – ensures all parts exist in the CIS database. Any differences 
between the schematic parts and its database properties are displayed. 

Goto Part On Schematic – displays the schematic page and highlights the part 
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Linking Database Parts 

The Link Database Part operation provides a way to link one or more part(s) in a design 
to a part in the database. This feature may be necessary when bringing older, legacy 
schematics with parts that may not reside in the database into sync with the CIS 
database.  

To link a part, while Part Manager is open, right click on the desired part and select Link 
Database Part.  

 

This will open CIS Explorer. The table view will populate with similar parts based on 
value. Scroll through the list to find a suitable part, making sure the PCB footprint is 
compatible. Double click on the database part to link it to the part in Part Manager. The 
Part Manager will reappear, showing the newly linked part. At this point, select the 
newly linked part, right click, and select Update Selected Part. This operation will run a 
check of the new part against the database. If everything matches, the part status will 
be Approved: Current. 
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While linking a part, if the database part is an alias, the schematic part property of the 
database part will not be transferred to the placed part on the schematic. CIS does not 
differentiate between a package and its alias. 

Updating All Part Status 

CIS checks each placed part against the database part to which it is linked. The part 
database is searched for the Part Number property that matches the placed part, and 
transferred properties that are configured to be updated are compared.  

For each placed part that is not current, you are prompted with the Update Part dialog 
box. This dialog box lets you decide whether you want to update the placed part 
properties with the transferred properties from the database part.  

The part status is based only on the part properties have been specified to be 
transferred from the part database. Other properties that may reside in the part are not 
checked. 
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Lab 3-1: Opening Part Manager 

Part Manager provides an ongoing check of the status of each part residing in the 
design. In this exercise, you will explore the various features and options within Part 
Manager.  

1. In CIS, select File > Open and open part_manager_training.dsn.  
2. In the Project Manager, right click on the design and select Part Manager. 
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Lab 3-2: Configuring Part Manager 

You can add properties that are shown in the Part Manager, adjust their column 
locations, and sort parts based on preferred fields in ascending or descending order. 

1. In Part Manager, select View > Configure Part Properties Display. 
2. The Configure Part Property Display dialog will appear. In the left column select 

Description, then click the Add button to push it to the Selected Part Properties that 
will be displayed in Part Manager. 

 

Do not close Part Manager. 
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Lab 3-3: Sorting Data within Part Manager 

Often, data is sorted based on field preference. This can be especially helpful if you plan 
to link, for example, all capacitors of one value to another value. Sorting by Value can 
allow you to easily select multiple parts at a time for this type of operation. 

1. Click on the Value header to sort the parts based on value. This will sort by value in 
ascending order. 

 

 
2. Click again on the Value field to sort in descending order based on Value. 
3. Do not close Part Manager. 
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Lab 3-4: Go to Part on Schematic 

While in Part Manager, you can go to any one of the parts to see its symbol and 
placement within the schematic. 

1. Right click on any part in the Part Manager list and choose Goto Part on Schematic. 

 

The schematic will appear showing the highlighted part. Below is a sample of a part 
appearing highlighted on the schematic after choosing Goto Part on Schematic in Part 
Manager. 

 

 

Go back to the Part Manager window. 
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Lab 3-5: Update All Part Status 

When you opened Part Manager on this design, all the parts have an Approved: Defined 
(Yellow) Part Status. This is because the parts have not yet been checked against the 
database to see if any changes have occurred either with the parts or within the 
database. 

1. Right click on a part in the list and select Update All Part Status. 
2. Click Yes to the Undo/Redo message. The parts in this design will now have an 

Approved: Current status (Green). 
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Lab 3-6: Viewing the Session Log 

At any time while you are working within OrCAD Capture CIS you can check the session 
log for any messages. 

1. If the session log is not displayed, select Window > Session Log. 
2. The session window will appear at the bottom of the window. Review the results. 
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Lab 3-7: Editing Properties 

Capture schematic entry can update properties on parts while in the schematic. 
However, when this occurs, the Part Status indicator changes after running Update Part 
Status, indicating that there are differences between the schematic part and the 
database part. 

As a best practice, when moving to a database methodology that OrCAD Capture CIS 
provides, it is recommended that no edits to part properties be made at the schematic 
level, because that would diverge from the master part record that is stored in the 
database. Instead, make changes to existing part properties in the database itself. 
Symbol changes should be made in the master library. If symbol graphics have changed, 
you should update your Design Cache to reflect the updated symbol in the schematic. 

1. Locate C3 on the schematic (upper left area), select the part, right click, and select 
Edit Properties. 

 

 
2. The Property Editor window will appear. If the properties appear in one horizontal 

row you can pivot the view so it will be easier to read. To pivot the view, select the 
Pivot button. 
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3. Change the Value from 0.1uF to 33uF. 
4. Click Apply. 

 

 
5. Go back to Part Manager.  
6. Select C3. Notice the value has changed to 33uF. 
7. Right click on C3 and select Update Selected Part Status. This will run a check to see 

if there are differences between the schematic part and the database part.  
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8. Click Yes to the Undo/Redo message. The Update Part Instance window will appear. 
In the next lab you will work with this window. Do not close it yet. 
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Lab 3-8: Update Part Instance 

The Update Part Instance window will appear showing the Value highlighted in red, 
indicating the discrepancy between the schematic value and the database value.  

Selecting No means you do not want Part Manager to update the part to be current 
with the database. It is important to note that if this choice is made, this part will be out 
of sync with the database. The changed part will contain the part number of the 
database part, which could cause a conflict in the Bill of Materials. 

If you need the change the value on a part, you should first search the database for the 
part you need. If it does not exist, consider creating a new TMP part in CIP, or deriving a 
database part in CIS, so there are no conflicts with corporate part numbers. 

 

 
1. Click No to keep the changed part’s value at 33uF. 
2. Do not close Part Manager. 
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Lab 3-9: Part Status Notification 

Part Manager will now show an Approved: Not Current status for this part. Notice the 
Part Number is the same as other capacitors, but the values are different. 

 

 
1. Right click on C3 in Part Manager and select Update Selected Part Status. Click Yes 

to continue. 
2. Select Yes to update the part value back to the database value of 0.1uF. Part 

Manager now shows an Approved: Current status for this part. 
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Lab 3-10: Linking a Database Part 

There are several situations where you may want to “link” a part to a different database 
part. For example, you may find that all 10K resistors need to be 100K instead. The 
linking feature in Part Manager allows you to accomplish this. In the next exercise, you 
will link a capacitor to one with a different tolerance. 

1. In Part Manager, sort the component list based on Value by clicking on the Value 
header. 

2. Hold down the <Shift> key and select C1 and C2. 
3. Right click and select Link Database Part. 

 

 
4. Click Yes to continue. CIS Explorer will appear with a list of capacitors matching the 

value of C1 and C2 (linking will search based on Value). Select the first capacitor in 
the list (Part Number EMA-00000445V22). 

5. Double click on the selected part. Click OK to continue. The Part Manager will 
reappear. Notice that C1 and C2 are now linked to a different part number.  

 

 
6. Right click on C1 and select Goto Part on Schematic. 
7. Double click on C1 to view its properties.  
8. Save the design. 
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Lab 3-11: Using Link Database Part to 

Update a Legacy Design 

In this exercise you will be updating a schematic design whose parts may be undefined 
or do not exist in the database. For some parts you will link to existing parts in the 
database, and for other parts you will have to add new part entries in the database.  

These are all common tasks used when updating older schematics and aligning them 
with the CIS/CIP database. After this exercise you will be able to: 

• Link undefined parts to existing database parts 

• Add new parts to the database 

• Swap schematic parts for parts that exist in the database 

• Ensure that all parts in a schematic are Approved: Current 

Reviewing the Design and Updating All Part Status 

1. Open the design C:\EMA_Training\CIP_CIP_Usage_174\legacy.dsn. 

2. Open schematic page 1 and review the schematic. 
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5. Right click on the design in the Project Manager and select Part Manager. Note that 
many of the Part Status indicators are Undefined (RED) status. You will be updating 
these parts. 

 

6. Begin by checking the part properties for every part in the list. Right click on any 
component and select Update All Part Status. Click Yes to the message to continue. 

Some of the parts are now Approved: Current (GREEN). This is the ideal status and what 
you will be targeting for the rest of the parts in this schematic. 

 

7. Sort the parts in the list by clicking on the Value header. An efficient way to replace 
multiple parts is to select them as a group and use Link Database Part. 
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Linking the Capacitors 

1. Once the parts are sorted by value, <Shift>-select all components with the value 
CAP. Right click and select Link Database Part. Click Yes to continue. 

 

This will open CIS Explorer. When CIS Explorer opens, observe that there is no like value 
for CAP. To replace this part, you will need to search for a capacitor with a value of 
.01uF. 

2. In the Query tab, set the Property field to Value and the Compare field to Contains. 
Enter .01uf in the Value field, then hit <Enter> to begin the search. Parts will appear 
in the Parts list.  

3. Select the part with the part number EMA-0000374V22.  

 

4. Double click on the part. A message will appear indicating the graphical 
representation is different and you will need to check for connectivity. 
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5. Click OK. Part Manager will reappear. Notice the CAP value has been updated to 
.01uF with the Part Number EMA-0000374V22, but is still marked as Undefined.  

 

6. Right click on C15 and select Update All Part Status. Click Yes to the message. This 
will recheck the parts status and will now indicate the newly replaced parts have an 
Approved: Current (GREEN) status. 

 

7. Right click on one of the newly updated parts and select Goto Part on Schematic to 
double check the connectivity. Make sure the connectivity has remained intact. If it 
is not, fix any wires so they are correctly connected. 

Linking the Resistors 

Next, you will repeat the steps just used to replace the undefined resistors. 

1. In Part Manager, <Shift>-select all components with the value RESISTOR. Right click 
and select Link Database Part. Click Yes to continue. 
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Note there is no component in CIS Explorer that has the value of RESISTOR. 

2. In the Query tab, set the Property field to Value and the Compare field to =. Enter 
1k in the Value field, then hit <Enter> to begin the search. 

3. In the Parts List, select the component with the Part Number EMA-00007504V42. 
Notice the part turns yellow. This is because the graphical representation of the part 
is different than the current schematic symbol. 

4. Double click on the part to replace the schematic part with this part. 
5. Click OK to the message that the parts differ from the database part. The newly 

updated part is shown in Part Manager. 
6. Right click on any part and select Update All Part Status to recheck all parts against 

the database. Click Yes to continue.  

Note that the RESISTORS are now updated to the Part Number EMA-00007504V42 and 
have an Approved: Current (GREEN) status. 

7. Select one of the updated resistors in Part Manager, right click, and select Goto Part 
on Schematic. 
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It is always important to check the connectivity when you replace parts using Link 
Database Part. As you can see, the connectivity may be intact, but you may want to 
adjust the reference designator and value text placement. 

Tip: If you are adjusting the placement of text on the schematic, you can turn off Snap 
to Grid so the text can be placed closer to the component. 

 

Updating the Regulator 

In the next step, you will update the regulator (U6) located in the upper left area of the 
schematic.  
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1. In Part Manager, sort by Part Status so that the remaining undefined parts are at the 
top of the list.  

There are two components left to be updated – U6 (value is LT581/TO), and U7 (value is 
25AA010_SN). 

2. Right click on U6 and select Link Database Part. Click Yes to continue. There are no 
parts with this value in CIS Explorer.  

The regulator part in the database is shown below (the schematic has been rewired to 
connect the new part). The pinouts are different, so you will need to make sure the 
connectivity is updated when you update the part. 
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3. In the Query tab of CIS Explorer, search for a part with the value of LT1763. There 
are several components that show up in the parts list. 

4. Select the component with the Part Number EMA-00006787V22. Double click on the 
part. Click OK to continue. 

5. Part Manager now shows U6 as an LT1763. Right click on U6 and select Update All 
Part Status. Click Yes to Continue. U6 is now updated. 

6. Right click on U6 and select Goto Part on Schematic. Edit the connectivity to match 
the following graphic (be sure to turn on Snap To Grid if it was turned off in the 
previous exercise). 

 

Adding the New PROM 

The final component you will update is the PROM, located in the lower left side of the 
schematic page. 
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This part does not exist in the database so you will create a new part entry using a 
different part. You will do this from Component Information Portal. 

1. Open CIP and log in. 
2. Select the Distributor Search tab.  
3. Select the Digi-Key, Future, Mouser, and Newark distributors. 
4. Set the Search Type to Keyword and enter the keyword EPCS4. 
5. Click the Search button to start the search. 

 

6. When the Search Results return, select the Intel component with the manufacturing 
PN of EPCS4S18N and the Digi-Key Distributor PN 544-1379-5-ND. 

7. Scroll down to view the Part Detail. 
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8. Select ICs in the Component View dropdown. 
9. Leave the Action set to Create TMP Part. 
10. Map the Schematic Part to INTEGRATED_CIRCUITS\EPCSXXXX_8P. 
11. Leave the PCB Footprint set to UNASSIGNED. 

 

12. Click Add to add the part to the database. 

Assigning Properties and Part Number to the PROM 

Next, you will add and edit properties, such as Part Number and Part Type. 

1. Click the Edit button      to go into edit mode. 
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2. In the PART_NUMBER field, change the part number to EMA-NEWPART-01. 
3. Change the Package Size to SOIC-8. 
4. Change the Package Type to SMD. 
5. Change the Company Part Status to Preliminary. 
6. Change the Device Type to Programmable Devices. 
7. Change the Number of Pins to 8. 
8. In the Part Type field enter EMA\SMD\Programmable Devices\Config Device. 
9. Click on the Update button to enter the changes. 

Now that you have entered the part, you will go back to Part Manager and use Link 
Database Part to swap the old PROM with the newly created part. 

Replacing the PROM in Part Manager 

1. Reopen Part Manager if it is not already open. 
2. Right click on U7 and select Link Database Part. Click Yes to continue. 

 

CIS Explorer opens – there is no part that matches this value. You will replace this part 
with the one you created. 

3. Using the Explore tab, expand the categories for ICs\EMA\SMD\Programmable 
Devices\Config Device. 

4. In the Part List, select the part you just generated in CIP, EMA-NEWPART-01. 

Alternately, you could use the Query tab to search for the value EPCS4S18N. Notice the 
part turns yellow since the schematic symbol is a different representation from the part 
being replaced. Also notice some of the properties in the properties window are 
highlighted in red, indicating the differences between this part and the part on the 
schematic. 

5. Double click on the part to replace it in the schematic. There is a message indicating 
the part currently on the schematic differs graphically from the part replacing it. You 
will need to check the connectivity of this part on the schematic. Click OK to 
continue. 
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6. In Part Manager, U7 is replaced with EMA-NEWPART-01. Right click on U7 and select 
Update All Part Status. 

All part status indicators in Part Manager should now reflect Approved: Current status. 
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7. In Part Manager, right click on U7 and select Goto Part on Schematic. 

 

Checking the Connectivity 

You will need to adjust the connectivity on this part. Using the illustration below, change 
the connectivity on U7 to match the following: 

1. U7 pin 6 connects to J1 pin 3. 
2. U7 pins 1, 3, 7, and 8 connects to VCC. 
3. U7 pin 4 connects to GND. 

4. U7 pins 2 and 5 are No Connects  . 

The newly replaced component should look like: 
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It is not necessary to finish the schematic page. This exercise is now complete. Close and 
save the design. 
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Lesson 4: Finalizing and 

Documenting the Design 

This section will deal with creating Bills of Materials and using CIS to create and manage 
design variants. Variations on a design are common in cases where you may have the 
same schematic for differing products where the value of components may be different 
depending on product requirements.  

Standard Bill of Materials 

You can use the standard CIS Bill of Materials feature to create multiple named report 
templates so that you can generate separate bills of materials for the different 
requirements. This is useful when preparing BOMs for purchasing and manufacturing. 
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In the Report Properties section, you can select any property in the Select Properties list 
and click Add to add it to the Output Format of the final Bill of Materials. In the Output 
Format section, the properties acan be ordered by selecting the property and clicking 
the UP or DOWN arrows located on the right. 
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The following table identifies the property icons and their descriptions. 

 

These property icons appear in the Report Properties area. 

 

Keyed Option 

The Keyed option allows you to check to key the selected property in the Output 
Format list. Keyed properties are grouped as a single item in the report. At least one 
property must be keyed. Typically, the Part Number property would be keyed. 

Allow Saving Title Block Properties 

Check this if you want to save the title block property information along with the BOM 
information when you save the BOM report as a BOM; .CSV; or .FWC file. 
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Part Reference Options 

Several options in this area will help you control how the BOM out appears. 

 

Standard 

Groups parts with matching keyed properties on a single line. 

Standard-separate line per part 

Lists each part on its own line. 

Compressed 

Presents a group of the same parts on a single line and compresses the part references 
into a range whenever possible. 

List Separator 

Choose either a space or a comma to separate the part references. 

Exclude Prefixes 

Allows you to enter in the prefixes you want to exclude from the report. To exclude 
more than one prefix, enter the prefixes separated by spaces. 

Output Mechanical Data 

This area deals with mechanical parts and assemblies. 
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Mechanical Parts Only 

Displays the quantity of all the mechanical parts, including the ones that are in the 
assemblies. 

Both Mechanical Parts and Assemblies 

Displays only those mechanical parts and assemblies that are available at the root level 
of your design. In this case, mechanical parts within the assemblies will not be 
displayed. 

Export BOM Report to Excel 

Select this option to export a report in spreadsheet format. It will open automatically in 
Excel when you generate a Bill of Materials. 

 

Merge BOM Reports 

If this option is selected, and you select more than one variant in the Variant List box, 
the Bill of Materials report contains all BOM variant data separated by variant, in the 
same report. You cannot sort the report when you merge BOM reports into one report. 

Variants 

Select either the core design or one or more of the design variants for which you want 
to generate the Bill of Materials.  
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Standard BOM Output 

Below is a sample of the “Standard” Bill of Materials output. 

 

Design Variants 

A design variant refers to variations of components in a core design, resulting in 
different product assemblies or functions. For each design variation, some components 
may change, and some may not be present. 

Design variants are needed to support different models of the product (for example, 
memory, capacity, speed, or additional functionality), and to support different 
requirements, depending on where the product is sold. Having a single PCB board 
reduces cost by allowing a single board design to represent multiple products. 

Design variants are also needed based on the manufacturing requirements in different 
countries. 

 

To view the variant parts, click in the variant folder(s). Parts can either be identified as a 
different part value (with a different part number), or as Do Not Stuff. 
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Terminology 

Groups – Describes multiple components generally used to support a particular function 
or module (for example, a power or memory module). These components are 
defined as a group and have varying version numbers. 

Subgroups – Each subgroup represents a version or assembly of the parent group. For 
example, if your power module has different assemblies for Europe and Asia, then 
the Power group would have two subgroups. The set of components in each 
subgroup is the same as the parent group. 

Core Design – The core design is the base schematic and PCB from which design variants 
can be created. 

Common – All components that are not part of a group but are still part of the core 
design. These modules or functions remain unchanged in all assemblies 

Variant View Mode 

OrCAD Capture CIS allows you to view variant information for all design variants defined 
in your project. The variant information includes different property values for common 
components or different or not present components for identical footprints on a 
schematic page. You can use the Variant View Mode command to display the variant 
information on a schematic page. 
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Variant BOM Reports 

The following image shows a sample of a variant BOM report. 
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Lab 4-1: Creating a Standard CIS BOM 

1. In the Project Manager, select part_manager_training.dsn, then select 
Reports > CIS Bill of Materials > Standard. 

 

BOM Templates 

BOM templates can be created and used for future reports. The desired properties can 
be added and arranged in the template, then the template is named.  
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2. Scroll through the Select Properties list and select Device Type, then click Add to add 

it to the Output Format. 
3. In the Template Name area enter the name New Template, then hit <Tab>. 
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Lab 4-2: Creating the Report 

1. In the Part Reference Options section, leave the default as Standard output. 
2. Leave the list separator as Space (‘ ‘). 
3. Check the Export BOM report to Excel option. 
4. Click OK to generate the BOM. 

Reviewing the Results 

If there are multiple manufacturing part numbers associated with a single corporate 
part number, you can export this information to the BOM by selecting List Relational 
Data Fields in the BOM form. Additionally, select Relational Data Displayed, and set the 
max rows to 5. Typically, the Output Format would include the Manufacturer PN and 
Manufacturer fields. 
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Lab 4-3: (OPTIONAL) Steps to Generate a 

Variant Design 

In the earlier releases of OrCAD Capture CIS, the recommended method for creating and 
managing variants was slightly different in that you would create each variant in and of 
itself, then create the next one, and so on. Today – the recommended method shown 
below is better able to handle any ambiguity that may arise when you have a more 
complex set of variants. At the end of this section is a video link that will demonstrate 
the preferred way to generate variants in CIS. 

Overview of Variant Generation 

There are several steps to follow to generate variants in a design. Variants are created 
and managed in CIS Part Manager. The basic steps to create a variant are: 

• Create the group(s) 
o Create the sub-groups (if any)  
o Add selected parts to the top level group folder(s) 
o Modify the parts of the sub-group(s) 

• Create the BOM Variant folder(s) 
o Add the modified group(s) to the BOM Variant folder(s) 

 

The following exercise will demonstrate how to create two variants using two different 
groups and sub-groups resulting in two BOM variants.  
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Some designs may require multiple variants, and these can be further refined by 
including sub-groups. Sub-groups represent a version or assembly of the parent group. 
Regardless of how many variants need to be created for any design, the basic steps will 
be the same. 

Create the Groups 

1. Open C:\EMA_Training\CIS_CIP_Usage_174\new_variants.dsn. 

2. In the Project Manager, right click on the design and select Part Manager. 

When Part Manager opens all parts in the design appear in the list on the right. On the 
left are folders identifying any groups that may exist, common parts, and BOM Variants. 

3. In the left window pane, right-click on all the Common folder and choose to Update 
All Part Status 

 

4. Right click on the folder named Groups and select New Group. 
5. Name the new group Group1. 

 

The new folder is created but does not yet contain any parts. Clicking on the Common 
folder will show the parts that are common to both the core design and any variants 
that may be created. 
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6. Create another group and name it Group2. 

Create the Sub-groups 

Next you will create sub-groups for each parent group.  

1. Right click on Group1 and create a sub-group named Assembly1. 
2. Do the same and create another sub-group named Assembly2. 

 

3. Right click on Group2 and create 2 more sub-groups named Assembly3 and 
Assembly4. 
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Adding Parts to the Groups 

Now that you have the groups and sub-groups created you can begin adding the parts 
which will make up the potential combination for Assemblies 1 through 4. 

1. Click on the Common folder under Groups. 
2. In the list of parts, select R1, R2, R3, and R4 from the list and drag them to the 

Group1 folder. 

 

3. Next, from the parts list select components J1 and P1, and drag them to the Group2 
folder. 

 

 

Modifying the Parts in Group1 

The parts in the Assembly1 folder under Group1 will remain as is (42.2kOhm). You will 
only be changing the parts in Assembly2. 

1. Select the Assembly2 folder under Group1. 
2. Select R2 and R3 from the list, right click and choose Set Part As Not Present 
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Notice they now show an ‘X’ and their Value has changed to ‘Do Not Stuff’ 

 

 
3. Select R4 and R1 from the same list, then right click and choose Link Database Part 

 

This will launch CIS Explorer where you will search for a 10K resistor to replace R1 and 
R4. In CIS Explorer you can either use the Query tab to search for a 10K resistor or you 
can expand the database tree.  

4. Locate a 10K resistor in CIS Explorer and select it from the parts list. It should turn 
green. 

5. Once selected you can review the attributes. Double click on it to complete the 
replacement of the parts. 
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Notice the Values for R1 and R4 show 10kOhm and also show a check mark indicating a 
differing value from the original core set of  parts. 

Modifying the Parts in Group2 

The parts showing in the Group2 Assembly 3 folder will remain as is. You will only make 
a change to the parts in the Assembly 4 folder. 

1. Select the Assembly4 folder 
2. Right click on the P1 part and choose Set Part As Not Present 

 

This completes creating the Groups, and sub-groups and modifying the parts within the 
sub-groups. Next, you will create the BOM Variants. 

Create the BOM Variants 

Now you can create a few variants from the sub-groups. In this step you will create two 
BOM Variants. 

Create BOM Variants 

1. Right click on the BOM Variants folder to create a new BOM variant. Name the BOM 
variant Variant1. 
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2. Right click on the BOM Variants folder again and create a new BOM variant named 
Variant2. 

 

Assemble the Variants 

Next you will need to add the Common folder to the BOM Variants folder so that each 
variant has the Common set of components represented.  

1. Select and drag the Common folder to each of the Variant1 and Variant2 folders. 

 

Create Variant1 and Variant2 

Now that the common set of parts are representing both variants you can select from 
the sub-groups to complete the variant. 

1. Click and drag the Assembly2 and Assembly3 folders into the Variant1 folder. 
2. Click and drag the Assembly1 and Assembly4 folders into the Variant2 folder. 
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3. Now examine each of the Variants.  

 

Viewing the Variants in the Schematic 

Now that you have created the BOM Variants they can be viewed in the schematic. 

1. Open the schematic page. 
2. Select View > Variant View Mode. 
3. Select Variant1 from the Select a Design Variant window. 
4. Click OK to save the design. 

R2 and R3 are identified as Do Not Stuff components, while R4 and R1 are 10KOhm 
parts. Also, P1 is present in Variant1.  

 

The colors for the variant parts are different than the other parts. You can choose how 
these parts will appear in the schematic. 
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5. Choose Options > Preferences. 
6. In the Colors/Print tab, change the Variant Part color to bright green.  
7. Change the Part Not Present color to orange.  
8. Click OK. 

 

 
9. Select View > View Variant Mode and select the Core design to go back to the core 

schematic view. 

Creating a Variant Bill of Materials 

1. Select the Project Manager. 
2. Select Reports > Variant Report. 
3. Remove the Description property from the Output Format section. 
4. Select Variant1 in the Variants area and click OK to run the report. 

 

Optionally you could choose Reports > CIS Bill of Materials > Standard and select the 
settings along with the preferred variant, and export to an Excel file. 
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This completes OrCAD CIS/CIP Usage Training. 

 

Optional Videos on Variant Generation: 

Schematic Capture Design Variants - Try OrCAD (vidyard.com) 

https://resources.ema-eda.com/all-videos-2/variant-management 

 

https://share.vidyard.com/watch/ky7c1jFnd9qdCs1hVtXMpk?
https://resources.ema-eda.com/all-videos-2/variant-management

