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Overview / Using This Manual 

Course Agenda 

Lesson 1: Getting Started with OrCAD Capture 
Lesson 2: Setting up Your Environment 
Lesson 3: Creating Part Libraries 
Lesson 4: Creating Homogeneous Parts 
Lesson 5: Creating Heterogeneous Parts 
Lesson 6: Building a Simple Schematic 
Lesson 7: Processing a Schematic Design 
Lesson 8: Building a Multi-Sheet Schematic 
Lesson 9: Working with the Property Editor 
Lesson 10: Using Search/Find, Edit Find and Browse 
Lesson 11: Processing a Design for Cadence OrCAD and Allegro® PCB Editor 

Related EMA Courses 

All classes offered by EMA may be viewed at our website: 

https://www.ema-eda.com/learning   

Here you’ll see a list of courses that are offered in a variety of delivery modes: 
Classroom based; Live-Online; e-Learning. Custom classes, tailored to your specific 
company needs, may also be requested. 

Formatting Conventions 

The following formatting conventions are used throughout this training manual: 

When lab procedures instruct you to click a dialog box button, tab, option, or toolbar 
icon, the item is formatted in bold, italic text. 

When lab procedures instruct you to select a file name, folder, or schematic page in 
either the OrCAD Capture Project Manager window or a directory tree, the name of the 
file, folder, or page is formatted in courier text. 

https://www.ema-eda.com/learning
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When lab procedures instruct you to access a directory path, the path is formatted in 
courier text. When you are instructed to select a menu option, the option is formatted 
in bold, italic text. 

When you are instructed to select a series of menu options, the primary and secondary 
menu options are separated by the ( > ) symbol. 

When lab procedures instruct you to press a key on your PC keyboard, the name of the 
key is enclosed in brackets. For example: <key>. 

When lab procedures instruct you to use <LMB> you are expected to press and hold the 
<Ctrl> key on your keyboard while you click design objects using your left mouse button. 
This technique if often used to select multiple design objects. 

Throughout this manual (LMB) refers to your “Left-Mouse- Button”. The instructor may 
also refer to this as the “Control, Select” method of choosing objects. 

Throughout this manual (RMB) refers to your “Right-Mouse- Button”.  

When lab procedures instruct you to select a design name or object, the name or object 
is formatted in courier text.  
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Lesson 1: Getting Started  

Lesson Objectives 

• Discuss design flow using OrCAD Capture 

• Learn how to start OrCAD Capture 

• The OrCAD Capture “Start Page” 

• Open an existing Project 

• Explore the user interface 

• Describe project structure 

• Select and edit objects 
 

Cadence Solutions Overview  

 

Successful PCB Data Management requires that several areas to be available within the 
design environment. OrCAD Capture schematic entry is the central starting point of the 
overall solution to data flow.  
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Project & Data Management 

OrCAD EDM (Engineering Data Management):  Having native PCB support puts a 
management solution directly into the CAD environment. EDM is a collaborative 
environment that enables project managers and users to track work in progress, check 
in and check out designs, track changes and manage entire projects from a 
comprehensive dashboard. 

OrCAD Capture CIS (Component Information System) enables full database control 
over schematic symbols, PCB footprints, and all associated part parametrics and 
manufacturing information. Engineers can confidently choose parts for their designs 
from the validated, approved database, ensuring that their parts are accurate and 
available. 

OrCAD CIP (Component Information Portal) enables users to completely manage the 
parts database. It provides access through assigned privileges, enabling teams to acquire 
new database parts directly from distributors like Digikey, Newark, Mouser, Premier-
Farnell, Arrow, and RS Components. It also provides capabilities for viewing the 
schematic symbol for placement, as well as the PCB footprint, and the pcb step model. 
Additionally, there is a direct link to launch OrCAD Library Builder within CIP. 

CIP Compliance Module 

The OrCAD CIP Compliance module enables you to start part selection in the earliest 
stage of design. You’ll no longer have to spend wasted time after the fact in part 
substitution because of obsolescence or because a part is found to be non-compliant, or 
due to sourcing issues.  

Part Acquisition 

Ultra Librarian for OrCAD (UL) provides a comprehensive, cloud-based library of millions 
of components eliminating the need for manual building and maintenance. Ultra 
Librarian for OrCAD offers engineers the option to search, preview and place 
components quickly without leaving the native CAD design environment saving time and 
eliminating errors. 

OrCAD Library Builder (OLB) is the most advanced PDF data extraction tool available for 
quickly generating schematic symbols, PCB footprints, and PCB step models. It is easily 
accessible within the OrCAD environment. 
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OrCAD Capture Highlights 

• Extensive schematic entry capabilities and productivity features ensure easy, fast, 
intuitive design capture 

• Hierarchical, reuse, and variant design capabilities streamline the creation of 
complex designs 

• OrCAD CIS accelerates the design process and lowers project costs by promoting 
preferred parts and optimizing part selection while OrCAD CIP further streamlines 
the process by providing a ready-made database with the ability to portal direct to 
the distributor to retrieve parts. 

• Integrated signal integrity, analog/mixed-signal design, and simulation support 
enable circuit exploration, constraint development, and verification to help achieve 
first-pass success 

• Bi-directional integration with the OrCAD PCB SI and the OrCAD PCB design 
products 

• CAD vendor netlist interfaces for most PCB packages extends OrCAD Capture into 
multivendor flows  

Schematic Entry Features 

Schematic Editor 

The OrCAD Capture schematic editor builds on the legacy of OrCAD providing fast and 
easy schematic editing for the simplest to the most complex designs. It combines an 
intuitive interface with all the features and functionality you need to speed through 
design tasks and circuit creation. 

Productivity and Ease of Use 

The schematic editor provides numerous features and functionality that enhance 
usability and speed for accomplishing design tasks and publishing design data. Context-
sensitive menus, OLE support, custom colorization of wires, nets, and parts, and a 
tabbed and dock-able interface all provide a better user experience. 

For larger, more complex designs, OrCAD Capture supports circuit reuse and hierarchical 
circuit blocks. Such designs are easy to traverse with navigation aids and OrCAD Capture 
ensures that all connections are maintained accurately throughout the design. 
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Intelligent PDF 

The Intelligent PDF export in OrCAD Capture enables you to create content-aware PDFs 
of your schematic design. More than just a .pdf file with searchable text, the content-
aware PDF retains intelligent design information, allowing you to query signals, display 
properties, navigate hierarchical blocks, and more. These PDFs eliminate the need for 
other team members to have additional software licenses or specialized viewers for 
design reviews, increasing the ease of collaboration and communication. 

FPGA Co-design 

OrCAD Capture, together with the OrCAD FPGA System Planner product, addresses the 
challenges you encounter when designing large-pin-count FPGAs for the PCB: creating 
the initial pin assignment, integration with the schematic, and ensuring that the device 
is routable on your PCB. By replacing manual, error-prone processes with automatic pin-
assignment synthesis, this unique placement-aware solution helps eliminate 
unnecessary physical design iterations that shorten design time. 

PSpice simulation 

The OrCAD PSpice analog/mixed-signal circuit simulator solution is seamlessly 
integrated within OrCAD Capture to boost productivity and allow you to use the same 
schematic for both simulation exploration and PCB layout, reducing rework and errors. 
Even if you’re not creating a circuit for use in the PCB flow, the integration allows for 
easy setup, model placement, circuit creation, and simulation, as well as cross-probing 
of simulation results. 

Signal integrity 

Tightly integrated to provide a bi-directional schematic entry and signal integrity flow, 
OrCAD Capture and the OrCAD PCB SI product allow you to perform circuit topology 
exploration, constraint development, and signal integrity analysis from the schematic 
during design entry. The associated Electrical Constraint set (Electrical CSet) as well as 
the complete topology file is embedded in the schematic database. 
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PCB Design 

Seamless bi-directional integration with OrCAD PCB Editor in the OrCAD PCB Designer 
products enables synchronization and cross-probing/placing between the schematic and 
the board. 

The interface makes synchronizing connectivity and design rules easy and 
straightforward and automates back-annotation of engineering change orders (ECOs) 
including layout changes, gate/pin swaps, and changes to component names or values. 

The OrCAD Capture Design Flow 

 

This diagram shows the basic steps in the OrCAD Capture design flow. Steps for FPGA 
design, analog or digital simulation, and OrCAD and Allegro PCB Editor are not shown, 
and are not covered in this class. 

Starting OrCAD Capture 

There are a couple of ways you can open the OrCAD Capture application: 

• Select Start > Cadence PCB 17.4-2019 > Capture CIS 17.4 

• You may see a list of licenses appear where you can select OrCAD Capture 

• Double click the OrCAD Capture shortcut icon located on your desktop 
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The OrCAD Capture menu paths displayed from the Start button are automatically 
defined during software installation. The OrCAD Capture desktop icons are manually 
created. 

The OrCAD Capture “Start Page” 

When you start the OrCAD Capture software, the main session window appears with the 
“Start Page” as shown in the following graphic.  

 

The “Start Page” tab appears in the open Session Window. If you leave this active, it is 
from here you can start a New Project (or Design), Open an existing Project (or Design), 
open the Capture Tutorial, or open Capture’s Documentation. You can also access these 
commands from the toolbars at the top. 

In the upper, right corner, the current version you are running will be displayed. 

Below that cadence shows articles about interesting topics or ways to better use your 
Cadence tools. 
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In the lower, right hand corner you can select your current Vendor or Channel Partner 
and “Home” page will now appear giving you access to Support information, Upcoming 
Events, and Design Solutions. 

 

 

Use the File menu to create new projects and libraries, open existing ones, save design 
edits and print schematics. 

Use the Options menu to set user preferences or to create a design template. User 
preferences and design templates are covered later in this lesson. 

The Session Log is a window that displays messages and errors. You can save the 
contents of the Session Log window to a file. This window does not create a log file that 
can be replayed. It will be displayed in a tab below the schematic window. It can also be 
accessed from View in the main menu. 

Click on session log and all the seven menus: File, View, Tools, Edit, Options, Window 
and Help should be available. 
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OrCAD Capture Help 

The Help button  located on the far right of the main session window toolbar allows 
access to the online Help system and an online tutorial. Many of the topics included are 
similar to topics covered in the OrCAD Capture training class. 

Demo Designs 

The Cadence installed hierarchy contains more than 150 demo designs to help you 
understand Capture, Capture CIS, and the Capture -> Pspice flow. With this release 
these designs can be accessed via the File > Open > Demo Designs menu command as 
shown in the following graphic. 

 

 

EMA Customer Support 

The EMA Resource Center gives you access to downloads, FAQ’s, Application Notes, and 
more. Access the EMA Resource page using the following link.  



OrCAD Capture Essentials Version 17.4       

June 2020 EMA Design Automation, Inc. ®   © 2020 All rights reserved                     21 

http://support.ema-eda.com/  

 
 

Opening an Existing Project 

Use the Open Project window to navigate to and select an existing project .opj file. 
OrCAD Capture reads the project file and opens the Project Manager window. Projects 
can also be accessed from the Start Page. 

http://support.ema-eda.com/
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The Project Manager 

The Project Manager is a window that displays a directory tree of all files related to your 
design or project. 

 

The project name and project type are shown at the top of the Project Manager 
window. (Project types will be covered in Lesson 8.) 
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You can use the Project Manager to open schematic pages and view reports, schematic 
pages, or other project files which open when you double click a page or file name. You 
can also use the Project Manager with the right mouse pop-up menu to add, delete, or 
rename schematic pages. 

You can open multiple projects at the same time, and copy designs or schematic pages 
between Project Manager Windows. You can also use the Project Manager to add 
libraries to your project setup. 

When you open a project, the setting preferences last used become active in the open 
project. For example, if a schematic page was open when you saved and exited the 
project, that schematic page will automatically display when you reopen the project. 

A Simulation Resources folder (not shown in the previous graphic) may also be present 
for use with PSpice A/D. 

The OrCAD Capture User Interface 

 

OrCAD Capture is a menu driven application. There is no command line entry. All OrCAD 
Capture commands are contained in pull-down menus, icon toolbars, right mouse pop-
up menus, and keyboard shortcuts (or Hot-Keys). 

OrCAD Capture commands are context sensitive (see the graphic below). Accesses to 
commands vary with different active windows such as the Project Manager or schematic 
page. When either window is selected, buttons and menu commands not relevant to 
the active window are greyed out or missing. Tasks you perform must always be 
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relevant to the current or active window. You can apply a process to a specific page of a 
design by pre-selecting it before you perform the task. Menu choices are also affected 
by project type. 

 

The toolbars default to the top and right side of the OrCAD Capture session window, but 
you can move them to any edge of the session window, make them float free of the 
session window, and change their shapes. 

The Main Toolbar 

The main toolbar appears at the top of the session window. If you place the cursor over 
a button in the toolbar (without clicking), a brief description appears. 
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The Schematic Toolbar 

The schematic toolbar provides a quick way to execute schematic editing tasks. This 
toolbar appears, by default, on the right edge of the design window. It can be moved to 
any convenient viewing location. The Toolbar is active only when a schematic page 
window is selected. 

Tools to place parts and connect with wires 

 

 

Tools to place symbols 

 

 

Non-electrical Tools to draw shapes 

 

Complete command descriptions for the Schematic Toolbar can be found on page 86. 
Key board shortcuts are also available and can be found on page 45of this document. 
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Cross Hair Mode 

 

When placing a part on a very dense design, it is not always easy to find your way 
around the design. To make the task more manageable, you can turn on the Cross Hair 
Mode (full cursor). This will place a Cross hair at the edge of the mouse pointer. As you 
move your cursor across the page the cross hair will make it easier to locate object like 
pin and nets or very small parts in your design. 

Use the F6 key to toggle this mode on or off. 
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Lab 1-1: Opening Existing Project  

NOTE: Please observe the appropriate mode of training you are completing at this time 
(Classroom, Live-Online, or e-Learning) and follow the corresponding steps to ensure 
access of the training lab material.  

Classroom 

This training generally provides laptop computers which have been pre-set with the 
Capture directories where the training files are stored. If you find that your training 
material is not in the directory indicated, consult your training instructor, and you may 
also create the proper directory to house the training files for the duration of the 
course. The directory where your class files are stored will be:  
C:\EMA_Training\Capture_Essentials_17.4 

Live-Online 

This training uses the AWS (Amazon Work Space) environment. In this scenario EMA 
generates an AWS for each student. You are informed prior to the course how to 
connect to your AWS machine, which is already pre-loaded with necessary software and 
training designs. Each AWS machine has been pre-set with the Capture directories 
where the training files are stored. If you find that your training material is not in the 
directory indicated, consult your training instructor, and you may also create the proper 
directory to house the training files for the duration of the course. The directory where 
your class files are stored will be:  C:\EMA_Training\Capture_Essentials_17.4 

e-Learning 

This training is self-paced, not instructor led. It is dependent on having the software 
installed on a machine you can access in order to complete the training labs that are 
part of this material. On the machine you will be using to complete the labs, you will 
want to create a directory named:   C:\EMA_Training\Capture_Essentials_17.4 and 
then download the training materials from the E-Learning portal for the Capture class to 
this directory. Refer to your E-Learning Welcome Email to review the steps for this task. 

Lab Objectives 

After you complete this lab you will be able to: 
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• Start OrCAD Capture 

• Open a project 

• Zoom and pan 

• Close a project 

Start OrCAD Capture and Open a Project 

1. Select Start > Cadence PCB 17.4-2019 > Capture CIS 17.4 
2. You may see the Product Choices Window appear where you can select OrCAD Capture.  

Optionally you can double-click the Capture icon located on the desktop.  

The OrCAD Capture session window appears.  

The startup path and directory name may vary with different versions of the application 
installation CD.  

3. Select File > Open > Project.  
4. The Open Project window appears.  
5. Navigate to the C:\EMA_Training\Capture_Essentials\Designs directory. This 

directory is your lab database. All your lab files are stored under this folder. Please 
refer to the TRAINING FILES NOTE above that describes the training format you are 
taking and how to create the EMA_Training…  directory, if it is not already created. 

6. Select and open the Sample directory and choose sample.opj and click Open. 

The Project Manager window opens. Observe that the name of the project file is 
displayed at the top of the Project Manager window. 

Opening a Schematic 

If the schematic is not already open: 

1. In the Project Manager window, double click .\sample.dsn. 
 
2. Double click SCHEMATIC1, then double click PAGE1. 
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3. Page one of the SAMPLE design opens. 

4. Enlarge the schematic window and click the Zoom to all icon.  
The page size changes to fit the schematic window. 

Zooming 

 

1. In the main toolbar, click the Zoom In icon. 

 

2. The image has been magnified by a factor of 2 to 1. 
3. In the main toolbar, click the Zoom Out icon. 
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4. The image has been reduced by a factor of 2 to 1. The zoom scale factor is a user 
preference. We will show you how to set user preferences in lesson 2. 

5. Press the <I> key to zoom in and the <O> key to zoom out. When zooming in or out, 
observe that the cursor remains at the center of the view. These commands are 
“cursor location dependent”. 

6. Place your cursor in a different area and press the <I> and <O> keys again. 
7. With your view zoomed in, place your cursor to the right or left side of your view. 

Press the <C> key to center the view. 
8. Hold the <C> key down (do not touch the mouse buttons) and move the mouse. 

Notice the “auto scroll” feature. 
9. In the main toolbar, click the Zoom to Region icon. 

 

Observe that the cursor shape turns into a magnifying glass. 

a. Click and drag to define the area into which you want to zoom. 

b. Right-click and select End Mode from the pop-up menu. You can also use the 
<Esc> key to exit a command. 

Zoom commands are also available in the View pull-down menu. 

Panning 

1. Click the Zoom to All icon, followed by the Zoom In icon. 
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2. Place your cursor on a part (do not click the mouse). 
3. Press the <C> key on your keyboard. 
4. The location of your cursor becomes the new center-point of the view. Try this on 

another part. 
5. To pan, press <Shift> and mouse scroll wheel. Or hold down <C> and move your 

mouse back and forth (do not click the mouse). 

Additional keyboard shortcuts and function key settings are documented on page 45 of 
this workbook. You cannot create your own custom keyboard shortcuts. 

Panning with the Right Mouse Button (Optional) 

1. Zoom into an area of the page. 

2. Click the middle-mouse-button once. A panning cursor appears.  
3. Now simply move your cursor slowly around on the page. The “cursor” will attempt 

to follow your mouse movement. When you are done, click the middle-mouse-
button again. 

Closing the Project 

1. To close the schematic page, select File > Close or press the “X” on the tab next to 
the schematic page name. 

2. To close the project, select File > Close. 

The Project Manager window closes, but the main session window remains open. 



 

 

Lab 1-2: Using the Help System 

Lab Objectives 

After you complete this lab you will be able to access and use: 

• Online Help 

• Online tutorials 

• Online manuals and product notes 

Online Help 

1. In the OrCAD Capture session window depending on the OrCAD Capture tool you 
opened, select either Help > OrCAD Capture Help  

2. The Cadence Help window appears displaying the topic OrCAD Capture. Click on the 
Documentation browser icon in the top toolbar to expand and display the contents 
found under the OrCAD Capture User Guide in a panel to the left of the original. 

 



OrCAD Capture Essentials Version 17.4       

June 2020 EMA Design Automation, Inc. ®   © 2020 All rights reserved                     34 

Online Tutorial 

1. In the OrCAD Capture Start Page, on the left side are icons, one of which is the 
Learning Resources icon. Click this and notice the other areas you can select, 
including the Capture Flow Tutorial. 

 

2. Click on Capture Flow Tutorial link. Once you do, notice the items that are 
presented, under the What’s New image, you will find tutorials Tutorials.  
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You will not be using the tutorials for this training class. For future reference you can 
access these as training aids once you have Capture installed in your own work 
environment. 

3. Close the Help windows. 
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File Structure 

Project Manager 

The Project Manager structures design resources into a ‘virtual’ hierarchy of folders and 
files. However, this hierarchy exists only within the Project Manager window (not on 
disk). 

The graphic that follows illustrates the directory structure of folders and files in the 
Project Manager. 

 

The Referenced Projects folder is typically used to reference timing and functionality 
data from an FPGA project. 

The Simulation Resources folder is present when the project type is Analog or Mixed 
A/D, and you plan to use the PSpice A/D simulator. 
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System Files 

Some of the structures shown in the Project Manager Window relate to OrCAD Capture 
system files. Although many project files map to system files, many do not. All files 
related to a project should be contained in a top-level project folder. 

  

File Extensions 

The table that follows lists OrCAD Capture files and extensions. 

File Type Extension 

OrCAD Capture project file * .OPJ 

OrCAD Capture design file * .DSN 

OrCAD Capture part library .OLB 

Property update file .UPD 

Design rule check file .DRC 

Bill of Materials file .BOM 
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Export properties file .EXP 

OrCAD and Allegro PCB Editor back 
annotation file 

.SWP 

OrCAD and Allegro PCB Editor netlist 
files 

.DAT (3 files) 

VHDL source file .VHD or .VHO 

EDIF netlist or back annotation file .EDF or EDN 

Cross-reference report .XRF 

Other netlist files .NET or .ASC 

 

In the above table, files with an asterisk are necessary when handing the design off to 
another person for archiving your design.  

NOTE: If you have a greater need to manage OrCAD files because you are working in a 
team environment that may share work-in-progress you may want to look into OrCAD 
EDM. OrCAD EDM (Engineering Data Management) is a collaborative design 
management tool that enables you to organize and manage designs from a project 
management level. With EDM you can:  Track the history of each change; Control who 
has access to projects: and control and store all of the related project files; and more. 
Visit EMA Design’s website to see how OrCAD EDM can assist you with project data 
management. 

Each time you save an OrCAD Capture design, a <design>.dbk backup file is created.  

Automatic backup enables you to specify the backup frequency of the DSN file. This 
feature also lets you specify the number of backup versions kept. You can save between 
one and ten backup versions.  
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Selecting and Deselecting Objects 

The selection and deselection of OrCAD Capture objects controls your ability to edit, 
move, copy, delete, or edit properties. The graphic that follows shows a selected part, 
wire, pin and text. 

 

When selecting parts, be sure you see the rectangular selection box around the entire 
symbol, not just one of its elements, such as a pin or text. 

Selection Filter 

Controlling the selection of objects on a schematic page during a block selection is done 
by using the Selection Filter dialog box. It provides check box options to select or 
exclude Parts, Nets, Power/Gnd, Title Blocks, etc. so that only specific objects are 
selected when you perform the window or block-select operation. 
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Editing Objects 

Frequently used editing commands are accessible from the right mouse pop-up menu.  

Although editing options may vary with the selection of different object types, the 
graphic that follows shows one example of options available through the pop-up menu. 



OrCAD Capture Essentials Version 17.4       

June 2020 EMA Design Automation, Inc. ®   © 2020 All rights reserved                     41 

  



 

 

Lab 1-3: Selecting Objects 

Lab Objectives 

After completing this lab you will be able to: 

• Start OrCAD Capture and open a project 

• Open a schematic 

• Select an object 

• Select multiple objects 

 

Starting OrCAD Capture 

1. If OrCAD Capture is still open from the previous labs move to step 2 in “Opening the 
Project”. If you closed Capture after the last labs then: Select Start > All 
Programs > Cadence PCB 17.4-2019 > Capture CIS 17.4.  Optionally you can double-
click the Capture icon located on the desktop. Choose Capture, then the OrCAD 
Capture session window appears. 

Opening the Project 

1. Select File > Open > Project. 
The Open Project window appears. 

2. Navigate to the C:\EMA_Training\Capture_Essentials\Designs\intro directory. 
3. Select intro.opj and click Open. 

Opening the Schematic 

1. In the Project Manager, double click on .\intro.dsn. 

2. Double click on Schematic or press the  next to the schematic folder. 
3. Double click on PAGE1. 

4. Enlarge the schematic window and click the Zoom to All icon.  
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Selecting Objects 

1. Select a part by clicking on it with the left mouse button. 
Observe the dashed boundary around the part. 

2. Click to select a wire. Observe that the wire segment highlights, and selection boxes 
appear at its endpoints. 

3. Zoom in and select a text string (for example, a net name or reference designator). 

Observe that the text string highlights, and selection boxes appear around it. 

Selecting Multiple Objects 

1. Click on capacitor C1. Hold the <Ctrl> key down and click on capacitor C2. 
Both caps are now selected. 

2. Hold the <Ctrl> key down and click on capacitor C2 again. 
Capacitor C2 is now deselected. 

3. Click left anywhere in the page (away from parts or wires). 
This deselects all objects in the page. 

4. Press and hold the left mouse button, and drag a rectangle around capacitors C1 and 
C2. (Be sure to include the power/gnd symbols and wires.) 
All parts, wires, and text within the rectangle are now selected. 

5. Press the <Esc> key to deselect all objects. 

Filter Selection 

1. There are three ways to get to the Selection Filter command.  

a. From the View pull-down menu, select Selection Filter. 
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b. Place your cursor in the schematic page window. From the right mouse 
button select Selection Filter. 

c. The third method is to simply use the hot-keys: <CTRL+I> 

2. When the Selection Filter dialog box appears, select Clear All. 
3. Now place a check mark in only the Nets box and click on OK. 
4. Draw a box around everything on the current page. Notice that only the wires or 

Nets are selected. 
5. Click once in an open area to deselect the items. 
6. Return to the Selection Filter dialog box and reset to Select All. 

The following table is included as a reference for selecting and deselecting objects. 

To select … Do this… 

A single object Left click on the object (the selected object will highlight). Tip: 

While selecting, press and hold the <Tab> key to toggle 
between overlapping objects. 
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Multiple objects Press and hold the <Ctrl> key while selecting individual objects. 

All objects in an 
area 

Click and drag to draw a selection rectangle around an area.  

All objects on a 
schematic page  

Select Edit > Select All from the pull-down menu. 

All objects of a 
specified type 

Choose Edit > Find, and specify search criteria for the type(s) of 
objects you want to select. 

 

To deselect … Do this… 

All selected 
object(s) 

Click anywhere else other than on the selected object(s). 

One of a group of 
selected objects 

Hold the <Ctrl> key and click over the desired object. Continue 
this procedure to deselect other objects individually. 

 



 

 

Lab 1-4: Editing Objects 

Lab Objectives 

After completing this lab you will be able to: 

• Move individual parts and wires 

• Move groups of parts and wires 

• Delete 

• Undo 

• Copy parts 

Moving Individual Parts and Wires 

1. Place your cursor on a part, press and hold the left mouse button, and drag the part 
to a new location. Observe that the attached wires stretch with the part. 

2. Place your cursor on a wire, press and hold the left mouse button, and drag the wire 
segment to a new location. Observe that the wire segment remains connected. 

3. Use the Undo/Redo toolbar icon to return the parts to their original locations. 
4. Hold the <ALT> key and drag C2 to the right. 

The part is disconnected from the wires. You can now move the parts without 
attached wires. 

Moving Groups of Parts and Wires 

1. Press and hold the left mouse button and drag a rectangle around capacitors C1 and 
C2. (Be sure to include the power/gnd symbols and wires.) 

2. Place your cursor on a part or wire, and notice that the cursor changes to a cross 
hair. 

3. When the cursor appears as a crosshair shape, press and hold the left mouse button, 
and drag the selected group to a new location. 

4. Press <Esc>. 

Delete 

1. Click to select a part or wire. 

 
a) Right-click and select Delete from the pop-up menu. 
b) Press the <Delete> or <Backspace> key. 
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2. Click on capacitor C1. Hold the <Ctrl> key down and click on capacitor C2. (This is 

referred to as the “control, select” or <CTRL+LMB> method). Both caps are now 

selected. 

  a)  Press the <Backspace> or <Delete> key to delete both capacitors at once. 

3. Press and hold the left mouse button and drag a rectangle around both capacitors 

(include the power/gnd symbols and wires). 

4. Delete the selected parts and wires, and then undo the deletion. 

5. Select and delete C1, then select and delete C2. 

6. Follow directions in the next section to undo both deletions. 

Undo 

You can undo the deletion of both C1 and C2 because of the “Multiple Un-do’s” in 
OrCAD Capture. 

1. Press <Ctrl+Z>  

2. Click the Undo icon in the main toolbar . 

Copying Parts 

1. Place your cursor on a part, press and hold the <Ctrl> key and left mouse button, 
and drag a copy of the part to a new location. 

2. Press <Ctrl+Z> to undo the copy. 
3. Click on the part again. 

a. Press <Ctrl+C> to copy. 

b. Press <Ctrl+V> to paste. 

c. Click to place a copy of the part. 

d. Press <Ctrl+Z> to undo the copy. 

You will also find Copy, Paste on your pop-up menus as well as the 3 icons on the tool 
bar for Cut, Copy, and Paste. 

4. Press and hold the left mouse button and drag a rectangle around a capacitor 
(include the power/gnd symbols and wires). 

5. Press and hold the <Ctrl> key and left mouse button and drag a copy of the circuit to 
a new location. 

6. Click left in a blank area to unselect all objects. 
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Move with Disconnect 

1. Select C1 (or C2) again. Attempt to drag it to another location to the right or left. 
Notice that wires WILL stay connected to the pins of a part. 

2. Move the part back to the previous location or use Undo. 
3. Select the part again. This time hold the ALT key down as you drag the part to a new 

location. 
Notice that this time the part is unconnected from the wires. 

4. Leave the design open to continue to the next lesson. 

Select File - Close and No to discard all changes if you wish to close the design at this 
time.  

The following table lists additional editing commands. 

To … Select the object and do this… 

Move an object Press and hold the left mouse button and drag the object to a 

new location. Tip: Hold the <Alt> key to split an object away 

(for example, to disconnect a part from existing wires). 

Delete an object Press <Del> or <Backspace> 

or 

Choose Edit > Delete. 

Copy an object Press and hold the <Ctrl> key and drag a copy of the selected 
part to a new location. 

or 

press <Ctrl+C> 

or 

Choose Edit > Copy. 

Cut an object Press <Ctrl+X> 

or 

Choose Edit > Cut. 

Paste an object Press <Ctrl+V> 

or 

Choose Edit > Paste. 
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Undo the last 
action Press the  button 

or 

press <Ctrl+Z> 

or  

Choose Edit > Undo 

Reverse an Undo 
Press the  button 

or  

Press <Ctrl+Y> 

or 

Choose Edit > Redo. 

Repeat the last 
command 

Press <F4> 

or 

Choose Edit > Repeat. 

Rotate an object(s) 
90 degrees 
counter-clockwise 

Press <R> 

or 

Choose Edit > Rotate. 

Mirror an object 
vertically and/or 
horizontally 

Choose Edit > Mirror. 

Resize an object Drag a resize handle on the highlighted object. 

Group selected 
objects so you can 
manipulate them 
as a set 

Choose Edit > Group. 

 

Observe that the main toolbar also contains Copy, Cut, and Paste icons. 
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Lesson 2: Setting up Your Environment 

Lesson Objectives 

• Set User Preferences 

• Create a Design Template 

Setting User Preferences 

OrCAD Capture, Version 17.2, has the following user preferences: 

• Theme 

• Color assignment 

• Grid display 

• Pan and zoom 

• Area selection 

• Line and fill style 

• Autobackup 
 

 

User preferences are workstation-specific. For example, if you copy a design from 
another person and open it on your machine, your user preferences (color assignments, 
grid display) are used. 

User preferences are stored in the Capture.ini file (not in the design database). Changes 
to user preferences take effect immediately.  



OrCAD Capture Essentials Version 17.4       

June 2020 EMA Design Automation, Inc. ®   © 2020 All rights reserved                     52 

Theme 

Use the Options > Preferences to set your preferred theme. Themes can be set to Light, 
dark, or Legacy. 

 

Below are examples of the dark theme and the light theme. 

 

Color Assignments 

Use the Colors/Print tab to assign colors to design objects and to control visibility of 
design objects on hard copy prints. 
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Variant Settings (Used in OrCAD Capture CIS only) 

 

The Default for Variant color setting is only used by OrCAD Capture CIS to display on the 
schematic page any part(s) that are marked in the Variant BOM section (green) and 
which parts are marked with a “Do not stuff” property (gray). 

Grid Display 

Use the Grid Display tab to turn the grid on or off, or to specify grid style.  

OrCAD Capture uses a 100-mil grid. The Pointer Snap to Grid option forces all parts, 
wires and text to snap to this grid. A Snap to Grid icon is also available on the main 
toolbar. 

When you are adding parts and wires, the Pointer Snap to Grid option should be on (the 
default). You should turn this option off when adjusting the location of text or 
properties only. 
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The View > Grid command can also be used to toggle the grid on or off. You can set 
preferences to display either a dot or line grid system. You can also specify whether you 
want placed objects to automatically snap to the grid. 

 

It is recommended that you set Fine for Drawing Elements such as text, lines, rectangles, 
etc. This will allow movement of objects at almost a “gridless” setting. Set Coarse for 
Connectivity Elements such as parts and wires to allow these objects to move using the 
grid spacing setting. The setting for Master will let both object types behave in the 
default manner. 
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Pan and Zoom 

When you use the Zoom In or Zoom Out icons in the main toolbar, OrCAD Capture refers 
to this setup menu to determine how far to zoom in or out. Similarly, the amount of 
zoom performed by the View > Zoom menu options or the <I> (Zoom In) and <O> (Zoom 
Out) keyboard shortcuts is also defined here. 

The Auto Scroll Percent option controls how fast the schematic page scrolls when you 
drag an object into the border area of the schematic window. It is an old feature has 
been replaced by the action of selecting the <C> key, holding it down, and moving the 
mouse. 

The zoom factor must be an integer between 2 and 10 (no fractions or decimals). 

 

The new function of the <C> key replaces the use of the Scroll settings. 
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Area Selection 

To select multiple objects, you can use your left mouse button to drag or draw a 
rectangle around the objects you want to select. All objects intersected by the rectangle 
are selected by default. However, if you prefer you can alter the settings in the Options 
> Preferences > Select window to select only objects fully enclosed.  

The graphic that follows shows a selection rectangle and objects selected when the 
Intersection object is activated as a preference as well as objects selected when the 
Fully > enclosed option is activated. Both of these settings now have an icon on the 
main tool bar to allow you to switch between the settings without the need to set them 
here. (Refer to Lesson 1and page 2-11 of this lesson.) 

Selection Preferences 

When you drag a rectangle to select multiple objects, all objects intersected by the 
rectangle are selected by default. As introduced in the previous sub-topic, you can 
modify preference settings so that only objects fully enclosed within the rectangle are 
selected.  

Use the Select tab to set your area selection preference. After selecting multiple objects 
within an area, you may plan to move them. Use the options on this tab to specify the 
maximum number of objects that are visible at high resolution while moving the 
selected group. When you drag a number of objects greater than this value, a simple 
box replaces the symbol graphic for each part. 
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The “Maximum Number of Objects to display.” message is an older setting that, with 
the advent of the high resolution graphics cards, is no longer a setting worth using. 
Simply leave it set as is. 
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Miscellaneous Preferences  

 

Use the Miscellaneous tab to define the characteristics of non-electrical graphics such 
as polygons and lines. You can also choose to render text as small line strokes rather 
than text fonts. 

Schematic Page Editor 

Set the default line draw mode for the schematic page by selecting Schematic Page 
Editor > Line Fill and Line Style and Width. 
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Junction Dot Size will let you set the size of the Junction Dot to Small (Default), 
Medium, Large, and Extra Large. 

Docking will allow you to open and dock the Place Part command box and leave it open 
as you find and place parts on the schematic page. 

Enabling the Search Toolbar 

Find will allow you to open and dock the find command or Search Toolbar. 

Auto Recovery 

The Auto Recovery option protects you from loss of work due to system crash or power 
failure. OrCAD Capture automatically saves design changes at the end of each Auto 
Recovery interval (in minutes). These backup files are saved to the “current working 
directory”, and are automatically deleted when you exit normally. If no changes have 
occurred since the last save, no auto recovery (backup) is performed. 

Auto Referencing 

The Auto Reference option will automatically give you the next reference designator in a 
sequence. If you wish to use the Annotate command, do not use this function. 

Enable part references to be preserved while pasting a part to a schematic page. When 
you copy a part and paste it on a schematic page, the part will retain the same reference 
designator as that of the copied part. But, if you place a new part on a schematic page, 
OrCAD Capture will assign the reference designator found in the library. For example: 
U?A or J?P. 

Intertool Communication 

The Intertool Communication option lets OrCAD Capture interact with the OrCAD and 
Allegro PCB Editor tools. For example, you can cross-probe parts and nets in the 
schematic and correspond them to parts and nets in the PCB design. 
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Wire Drag 

The Wire Drag option (ON) allows you to drag and place the selected part or wire 
on the schematic, even if it results in connectivity changes. Also, OrCAD Capture flags a 
warning with a changed cursor and will show the temporary markers. 

(OFF)  then the selected part or wire attaches to the cursor and does not get placed 
on the schematic, if it results in connectivity changes. Also, OrCAD Capture flags only a 
warning with a changed cursor and does not show the temporary markers. 

IREF Display Property 

The IREF Display Property setting will display the Intersheet Reference text after it is 
generated. 

Extended Preferences 

Clicking on More Preferences (located at the bottom of the Preferences window) will 
launch a subsequent window where you can select from the list provided to set specific 
preferences. For example, in the sample below, if you select Schematic you can choose 
from the options provided.  
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Text Editor 

The Text Editor Tab is used to set up color, font, and highlighting for Verilog or VHDL 
keywords, comments, and quoted strings. These settings are applied to a text editor 
window that is used to create behavioral models. The Tab Setting option in the Text 
Editor tab can also be used to align the columns or data in the Bill or Materials report. 
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Board Simulation  

The Board Simulation tab is used to specify which hardware description language will be 
used for simulation. 
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Lab 2-1: Setting up Preferences 

Lab Objectives 

After completing this lab you will be able to: 

• Define a theme 

• Set color assignments 

• Set the grid display 

• Pan and zoom 

• Select an area 

• Set selection preferences 

• Set miscellaneous preferences 

• Explore extended preferences 

Choosing Theme 

Capture can be used in legacy light theme or the newly introduced dark theme. 

1. In the main toolbar choose Options > Preferences 

2. In the top of the Preferences window you will see application theme; here you can 
choose which theme you would like to continue the class in.  

 

*Note you must restart your capture program to change the theme 

On the next page examples of the dark and light theme are shown. 
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Assigning Colors 

If you closed the design in the last lab, reopen intro.dsn. 

1. In the Project Manager window of the, double click PAGE1. 
2. Enlarge the schematic window and zoom in to capacitors C1 and C2. 

Observe the current color settings.  

3. Select Options  > Preferences  
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4. The Colors/Print tab is the first to be displayed. 
5. Click the color box next to Part Body, click a different color from the color palette, 

and then click OK.  
6. Next change the color assignments for Part Reference, Part Value, and Wire also.  
7. Change the Grid color to black so you can see it easily on the screen. 
8. Click OK. 

The color assignments take effect immediately. These preferences are machine specific 
(any design opened on your system will use these color settings). 

If your grid is not visible, use the View > Grid command to turn  
it on. 

Using Default Colors (Optional) 

1. Select Options > Preferences. 
2. Click the Use Defaults button in the lower right corner of the Colors/Print tab and 

click OK.  
3. The schematic displays the original color assignments. 
4. Try several more color assignments (for example, Alias, Background, Junction, No 

Connect, Pin, Power, Power Text, and Title Block). 

Assigning colors to some of these objects helps you prepare for the design entry tasks 
covered in the next lesson. 

The Select Tab 

1. Select Options > Preferences again. 
2. Click the Select tab. 
3. Change the Area Select setting for the Schematic Page Editor to Fully Enclosed and 

click OK. 
4. Return to the Project manager window and open Page2 of the design. 
5. Zoom in to U2A (74LS00). 
6. Drag a selection rectangle across (but do not fully enclose) U2A. 
7. Observe that the part is not selected. 
8. Drag a larger selection rectangle and fully enclose U2A (including  

pin stubs). 
9. Observe that the part is now selected. 
10. Click left in a blank area to deselect all objects. 
11. Select Options > Preferences and click the Select tab. 
12. Change the Area Select setting back to Intersecting and click OK. 
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13. Drag a rectangle across a portion of U2A to select it. 

One Icon on the OrCAD Capture main tool bar also performs the same task without 
having to go to the User Preferences. 

    

Fully Enclosed  Intersecting 

Miscellaneous Tab 

1. Select Options > Preferences. 
2. Click the Miscellaneous tab and do the following settings. 

a. For the Schematic Page Editor set the Line Style to dashed. 

b. Set Auto Recovery on and for 15 minutes. 

c. Remove the “check” for Auto Reference, for now. This will enable us to use 
the Annotate command later in the labs. 

d. Make sure there is a “check” in the Wire Drag option. 

3. Make sure all your settings reflect what is displayed in the following image. 

  

4. Click OK. 
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Exploring Extended Preferences 

1. At the bottom of the Preferences window, select the More Preferences button. 

  

2. When the Extended Preferences Setup window opens, explore the options by 
selecting an item in the left pane, then observe the options that are available on the 
right. See the example below. 

  

3. Close the window when you are finished browsing the options. 

Set AutoBackup Preferences 

1. Select Options > Autobackup. 
2. When the “Multi-level Backup settings” window opens, select the Browse button. 
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3. Find the C:\EMA_Training\Capture_Essentials\Designs.  
4. Using the Create Dir button, enter the directory name for Backup. 
5. In the Select Directory window, make sure you select the Backup directory under 

C:\EMA_Training\Capture_Essentials\Designs. 
6. Select OK. 
7. Enter the time interval you wish backup to occur and the number of backups you 

wish to save. Click OK. 

Saving Copy of Project 

1. Select File > Close. 

The schematic window closes. 

2. Select File > Save Project As. 
3. The Save Project As dialog will appear. With the Home tab active, enter the 

directory location.  
4. Enter the Project Name and click OK. 

The Project Manager window closes. The main session window is still running.  
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The Design Template 

  

The design template is a collection of settings that are used whenever you create a new 
design. These settings are design specific and are retained even when the design is 
transferred to another workstation.  

When you define settings of your design template, you define the following: 

• Font type and size 

• Title block 

• Page size 

• Grid settings 

Design template settings are stored in the Capture.ini file. When you create a new 
design, the current settings are copied into the design file. When you change the design 
template, existing designs are not affected.  

You can override text font settings at the design level using the 
Options > Design Properties menu item, or override page size and border settings using 
the Options > Schematic Page Properties command. 
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Fonts Tab 

  

You can use the Fonts tab to control the appearance of various kinds of schematic text 
(for example, net names, reference designators, properties, and so on). 

 

Title Block Tab 

  

You can use the Title Block tab to specify which title block symbol you want 
automatically added to each new schematic page. You can also fill in your company 
name and address. 

If you also supply design name and revision information, remember to change these 
settings before starting a new design. 
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Page Size Tab 

  

You can use the Page Size tab to set the default page size for new schematic pages. Also 
use this menu to specify the units of measure and the page dimensions.  

OrCAD Capture always maintains one grid space between pins. The default grid spacing 
is 100 mils. The Pin-to-Pin Spacing field changes the distance between grid points 
(which changes the distance between pins).  

Do not change the Pin-to-Pin Spacing field (always use a 100-mil spacing or “tenth of an 
inch”). 

For example, a Pin-to-Pin Spacing of 200 mils causes the size of parts to increase by a 
factor of 2 to 1, because the distance between adjacent pins is 200 mils. Thus, the Pin-
to-Pin Spacing field scales the schematic. 
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Grid Reference Tab 

  

You can use the Grid Reference tab to define the grid zones across the top and left 
edges of schematic pages. Also use this menu to control visibility of the title block. 

Hierarchy Tab 

This tab lets you set the default setting for Hierarchical block symbols. We will cover 
more on Hierarchical designs in a later chapter. 
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Lab 2-2: Setting Up the Design 

Template 

Lab Objectives 

After completing this lab you will be able to: 

• Set up default options for your designs 

• Add a title into the title block 

• Add a name and address to the title  

• Add a document number and revision number to the title block 

Setting up Default template settings 

1. Select Options > Design Template. 
2. Select the Page Size tab at the top of the window that opens. Make sure the Page 

Size is set to A for this exercise. 
3. Select the Grid Reference tab. The settings should match the following picture. 

  

4. Leave all the other tab settings as is except for the Title Block tab. See the following 
instructions for this. 
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Adding a Title Line to the Title Block 

1. Click on the Title Block tab. 
2. In the Title field, enter: 

Lesson6 

Adding a Name and Address 

1. In the Organization Name field, enter your company name. 
2. In the Organization Address1 field, enter your company street address. 
3. In the Organization Address2 field, enter city, state, and zip code. 
4. Use the Address3 and 4 fields ONLY if necessary. 

Adding a Document Number/Revision Number  

1. In the Document Number field, enter: 

EMA-12345678 
2. In the Revision field, enter: 

A 
3. OPTIONAL - Add a Cage Code IF you need the information on your design pages. 

US987654 

4. Click the browser button to the right of the Library Name field, and navigate to your 
training directory, C:\EMA_Training\Capture_Essentials\Libraries. 

5. Click on Training_lib.olb and click Open. 

The above path may vary, depending upon your training site and where the Cadence 
software has been installed. 

6. In the Title Block Name field, enter: 

TitleBlock0 
7. Compare your settings to the following example and click OK. (The following is an 

example only.) 
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This design template will take effect when you create a new schematic in Lesson 6. The 
default settings for page size, grid reference, and fonts will also be applied.  

8. With the Project Manager active choose File > Save. Then choose File > Close to 
close the project. 
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Lesson 3: Creating Part Libraries 

Lesson Objectives 

After you complete this lesson you will be able to: 

• Create a new part library 

• Copy from one library to another 

Starting a New Part Library 

You can use the File > New > Library command to create a new Part Library. This creates 
a library “shell”. Once the library is created, use the Save As command to rename the 
default library name and save it to the desired directory. 

Location of Library Files 

When you create a new library, its location defaults to a directory within the Cadence 
software hierarchy. 

If you use the File > New > Library command while a project is open, the new library 
location defaults to the current project directory. This ‘project’ library will appear in the 
Library folder in the Project Manager window, and will be automatically accessible 
whenever you open the project. 

The OrCAD Capture libraries supplied by Cadence are organized by part function (such 
as OPAmp, Discrete, Gate, and so forth). It is strongly recommended that you organize 
your new libraries in a similar fashion. 

Never create or save your own libraries in the same directory where the OrCAD Capture 
libraries are loaded. Make sure you keep them in an entirely different location. 
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Renaming a Library 

You can modify the name and/or location of a library by clicking on the library with the 
right mouse button and then selecting the Save As option from the pull-down menu. 
This will open a new form that will allow you to modify the name and/or location of the 
library. 

As we begin the creation of libraries and designs, remember: 

Field Name Length Acceptable Characters 

Package Name 255 A to Z, 0 to 9, Dash(-) Underscore( _ ) 

Device Type 30 All except ! And ‘ 

Function Designator 255 All except ! And ‘ 

Reference Designator 30 All except ! And ‘ 

Pin Number 30 All except ! And ‘ 

Pin Name 255 All except ! And ‘ 

Net Name 255 All except ! And ‘ 

Property Value 79 All except ! And ‘ 

Tolerance 1023 All except ! And ‘ 

User Part Number 1023 All except ! And ‘ 

Value 1023 All except ! And ‘ 
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Lab 3-1: Creating a New Library 

Lab Objectives 

After you complete this lab you will be able to: 

• Create a library 

• Rename the library 

Starting OrCAD Capture 

1. If Capture is still open on the start page, move to step 2, named “Creating a Library”. 
If Capture was exited in the last lab, choose Start > All Programs > Cadence PCB 
17.4-2019 > Capture CIS 17.4. Optionally you can double-click the Capture icon 
located on the desktop. Choose Capture from the selection window. 

Creating a Library 

2. In the main session window, select File > New > Library. 

The Project Manager window appears. A new library file is listed under the Design 
Resources folder. 
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Renaming the Library 

1. In the Project Manager window, click on the library file libraryn.olb.  
2. (The letter n will be the number 1 or greater.) 
3. Select File > Save As. (Trng.olb). See the figure above on how to save and rename 

the library. 
4. To set the Save in field, navigate to the 

C:\EMA_Training\Capture_Essentials_17.4\Libraries directory.  
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Copying and Renaming Parts and Symbols 

 

It is common to copy parts from a Cadence/OrCAD-supplied library and modify them for 
use in your own library.  

NOTE: Never modify the default libraries supplied with the OrCAD Capture software. 
Instead, use them as source libraries. 

To copy and paste a part from one library to another, both libraries must be open. Once 
you have selected the part or parts you want to copy in the source library, be sure to 
click on the name of the target library before using the Edit > Paste command. 

You can also open a part in one library, and use the File > Save As command to save the 
part into another library. 

To copy and rename a part in the same library, first select the part and use the 
Edit > Copy command. Then use the Design > Rename command to change the name of 
the original part. Next, paste the copied part back into the library. Last, open the 
renamed part and modify it.  
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Lab 3-2: Copying and Renaming Parts 

and Symbols 

Lab Objectives 

After you complete this lab you will be able to: 

• Open an OrCAD Capture supplied libraries 

• Copy parts from one library and add them to another 

Opening an OrCAD Supplied Library 

1. Select File > Open > Library.  
2. Navigate to the C:\Cadence\SPB_17.4\tools\capture\library directory, as shown 

below. 

The above path may vary with different installation locations of the OrCAD software. 

 

3. Click on capsym.olb and click Open. 
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4. Align the two Project Manager windows side by side. 

 
 

The library opens. You will copy parts from this source library into your TRNG library. 
When you open a new library it may open in a tab next to your other library. To 
separate this tab press the arrow in the top left of the project manager and choose 
Tabbed Document.  
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5. In the CAPSYM library window, use <Ctrl+LMB> to select both the GND_POWER and 
TITLEBLOCK0 symbols. 

6. Select Edit > Copy (or CTRL+C). 
7. In the other library window, click on TRNG.OLB and select Edit > Paste (or CTRL+V). 
8. The two selected symbols now appear in the TRNG library. 
9. Close the CAPSYM library window. 
10. In the TRNG library, select the GND_POWER symbol and then select Design > 

Rename or LMB and select Rename from the pop-up menu in the Library window. 

The Rename Power Symbol window appears. 

 

11. Change the symbol name to GND and click OK to close the form.  
12. You no longer need the Capsym.olb library. Close the Capsym.olb 
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Lesson 4: Creating Homogeneous Parts 

Lesson Objectives 

After you complete this lesson you will be able to: 

• Create a Homogeneous part 

Homogeneous Parts 

A homogeneous part is a part that has only one part graphic. If you define the part as 
having two or more parts per package, this means the package holds two or more 
identical logic parts, each with its own unique physical pin numbers. 

 

 

 

 

 

 

When you create a homogeneous part, you create one part graphic only. If the part 
graphic represents the entire package (called single-section), then Parts per Pkg is set to 
1. If the part graphic represents just a portion of the entire package (called multi-
section), then Parts per Pkg is set to 2 or more. 

 
 4
7 

 
 3
6 
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What is a Package? 

 

A package is a grouping of one or more circuit elements.  

If a symbol represents the entire package, the part is said to be single- section. If the 
symbol represents only a portion of the physical package, the part is called multi-section 
(other terms are multi-gate or multi-slot). 

A part has both logical and packaging related characteristics. For example, the symbol 
defines the part graphics and pin names. But packaging information is required to define 
the number of times the symbol fits into a package, and the logical-to-physical pin 
mapping required to annotate and netlist a schematic design. A package contains 
power, ground, and no-connect pins that also need to be considered during part 
building. 
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Creating a New Part 

 

Highlighting the Library name, right click and choose the New Part command from the 
popup menu.  Use the New Part Property dialog box to create a new part in a current or 
active library. The table that follows lists and describes each option and field within the 
New Part Properties dialog box. The following are some of the acceptable characters 
and character limits. 

Pins Length Illegal Characters 

Pin number 30 ! : “ ‘ , ~ * < > space 

Pin name 255 Same as above 
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Dialog Box Option Use Description 

Name Specifies the part’s name. This is used as the default part 
value when the part is placed on a schematic page. Part 
names can be up to 31 characters long (for example, 
R1206, RN55). 

Part Reference Prefix Specifies the first letter of the reference designator (“C” 
for capacitor or “R” for resistor).  

PCB Footprint Specifies the name of the footprint pattern used during 
the PCB layout process (for example, SM_1206). 

Create Convert View Controls the creation of an alternate version. You might 
use the convert option to define a DeMorgan equivalent. 
A part with this option specified will have two views (a 
normal and a convert) that you can switch between once 
the part has been placed in the schematic. 

Parts per Pkg Specifies whether or not there are multiple parts in the 
package (for example, gates). 

Package Type If the part is a multi-gate package, specifies whether all 
the parts in the package are symmetrical (homogeneous) 
or asymmetrical (heterogeneous). 

This setting cannot be changed once the part has been 
created. 

Part Numbering If the part is a multiple-part package, specifies whether 
parts in the package are identified by letter or number. 
For example: U?A (alphabetic) or U?-1 (numeric). 

Part Aliases Add technology-specific aliases for the current part (such 
as 5400, 7400, 74LS00 and so on). 

Attach Implementation Specifies a behavioral model for simulation, or an 
underlying schematic view for a hierarchical block. 

 

Once the Package Type has been set to either Homogeneous or Heterogeneous, it 
cannot be changed. 
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To access the Part Aliases button, highlight the trng.olb and select Options > 
Package Properties. Examples of different technologies are 75F00, 74LS00, 74ACT00, 
and 74HCT00. Some aliases indicate the use of a military style package versus one for 
commercial applications such as 5400. 

These are parts that can use the same symbol graphics, logical pin names, physical pin 
mapping, and PCB footprint. Part aliases appear in the Project Manager window with a 
dashed line in the center of the symbol icon. When a part is copied from one library to 
another, its aliases are copied also. 

The Parts in the OrCAD Capture Libraries were created using Part Aliases. If you require 
individual information in each part, i.e. Part Number, do not use Part Aliases if you have 
specific data, i.e. Part Numbers, to add to each part. DO NOT use Part Aliases if you are 
using OrCAD Capture CIS. 

When you OK the New Part Properties dialog box, the OrCAD Capture tool opens the 
Part Editor.  

The Draw toolbar is usually located on the right side of the OrCAD Capture window but 
can be moved to any desired location. The Part Editor activates only those tools used to 
create and edit part bodies. Those commands that are not used at this time are grayed 
out. You can also access the same commands from the Place pull-down menu. 
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The Place Pull-down Menu 
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The following table describes each Draw toolbar buttons used in the Part Editor. 

Toolbar Icon Comments 

 

Selects objects. Default mode. 

 

Adds an IEEE symbol. 

 

Place Pin - Adds a single pin to the part. 

 

Place Pin Array - Adds a pin array to the part with a defined 
range. 

 

Place Line - Draws a line. 

 

Place Polyline - Draws a multiple segment line. 

 

Place Rectangle - Draws a rectangle. Hold <SHIFT> key to 
create a square. 

 

Place Ellipse - Draws an ellipse. Hold <SHIFT> key to create 
a circle. 

 

Place Arc - Draws an arc (1st edge, 2nd edge, radius). 

 

Place Elliptical Arc - Draws an Elliptical Arc. 

 

Place Bezier - Draws a Bezier curve. 

 
Place Text - Adds comment text. (non-intelligent) 

 

 

These commands are also located in the Place pull-down menu. 



OrCAD Capture Essentials Version 17.4       

June 2020 EMA Design Automation, Inc. ®   © 2020 All rights reserved                     96 

The following are the illegal pin characters: 

 Pins Length Illegal Characters 

pin number 30 ! : “ ‘ , ~ * <> Space 

pin name 255 same as above 

 

Adding Graphics 

 

 

Initially, the Part Editor contains a dotted-line part boundary box and placeholder 
properties for the reference designator and part value.  
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Editing Part Graphics 

All graphics that make up the part must fit within the dotted-line boundary box (with 
the exception of pins and pin graphics).  

The boundary box also defines the selection area for the part when used in the 
schematic. 

The dotted boundary box automatically enlarges to surround the part graphics you 
create. If the part graphics are smaller than the boundary box, the box size must be 
reduced manually. 

All part graphics snap to a 100-mil grid in the Part Editor window. If you do not want to 
use the snap feature, click the Snap-to-Grid icon in the main toolbar to create off-grid 
graphics. This is also helpful when adding or relocating text and properties. DO NOT, 
however, turn off the Snap-to-Grid when placing the pin of the part. They MUST fall on 
a grid. 

Adding Pins 

 

To access the Place Pin dialog box, click the Place pin icon  in the Part Editor tool 
palette. Pins must be placed on the boundary box edges only and must be placed on a 
100-mil grid. 
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The table that follows lists and describes each option and field within the Place Pin 
dialog box. 

The following are the illegal pin characters: 

 Pins Length Illegal Characters 

pin number 30 ! : “ ‘ , ~ * <> Space 

pin name 255 same as above 

 

Dialog Box Option Use Description 

Name Specifies the pin name. If the name ends with a digit (0 
- 9), each pin is incremented by one every time you 
place a pin. You can create a pin name with an overbar 
by adding a back-slash (\) after every letter in the pin 
name.  

You will get errors if you create duplicate pin names on 
the same symbol. The only duplicate pin names on a 

symbol should be power pins (see Adding Power 
Pins later in this lesson). 

By default, all pin names (except power) are visible. Pin 
name text cannot be moved. 

Number Specifies the pin number. The pin number can be 
alphanumeric. If it ends in a number, it is incremented 
by one after each pin is placed.  

If the Pin Number field is left blank, no error occurs. 
During annotation, no pin number data is added to the 
schematic. A pin number is required by the OrCAD and 
Allegro PCB Editor netlister. 

OrCAD Capture will flag duplicate pin number 
assignments on the same section only. For example, in 
a multi-section part, you can map a shared enable pin 
to the same pin number as long as it is in a different 
section. 

By default, all pin numbers (except power) are visible. 
Pin number text cannot be moved except in the Edit 
Part command at the schematic page level. 
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Width Specifies whether the pin connects to a bus or a wire. If 
bus is specified, the pin must connect to a bus; 
otherwise, it must connect to a wire. Bus pins cannot 
be used directly as netlisting pins. Their main purpose 
is to make it possible to use non-primitive parts more 
easily by connecting large numbers of signals to a child 
schematic folder. 

Shape Select the pin shape from the list of six pin shapes.  

Type Select the pin type from the list of eight pin types: 3 
State, Bidirectional, Input, Open Collector, Open 
Emitter, Output, Passive, and Power. Be careful to 
enter the correct pin type, as this will affect design rule 
checking and simulation. If a part has no voltage pins, 
then its pins should be defined as Passive. 

Pin Visible Specifies the pin visibility on the schematic page. All 
pins (except power pins) are visible (the Pin Visible 
toggle is greyed out). Power pins are invisible by 
default, but can be visible if you choose. (The Pin 
Visible toggle is accessible for power pins only.) 

User Properties Displays the User Properties dialog box so you can add 
and edit the pin’s properties. 

 

Pins cannot be added to the corner of the part boundary box. If you need to place a pin 
on a corner, enlarge the boundary box before adding the pin, and then shrink the box so 
the pin is on the corner. 
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Editing a Single Pin 

 

You can edit properties such as the pin name, pin number, shape, or pin type of a single 
pin from the Property Sheet menu after the pin has been selected. 

Editing Multiple Pins 

 

When multiple pins are selected; you can access the Edit Pins area from the Property 
Sheet menu. The Edit Pins area enables you change pin name, number, type, or specify 
pin graphics (for example, clock wedge or inversion dot) for multiple pins.  
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Editing Pins at Package Level 

 

When no pins are selected, you can access the Edit Pins area of the Property Sheet 
menu that enables you change pin name, number, type, or specify pin graphics (for 
example, clock wedge or inversion dot) of all sections of the package.  You can also 
access the Edit Properties window by RMB edit pins or <Shift+H>. 

Adding Power Pins 

 

To add a power pin, in the Place Pin window set the Type field to Power. The name of 
the power pin is used as the name of the power net. 

When you set the pin type to Power, the Pin Visible field is activated (normally greyed 
out for all other pin types). You now have the option available, by default the option is 
checked. When the box is unchecked the pins are no longer visible in the schematic 
however, they are automatically added to the netlist.  

If you want to override this default signal defined for a power pin, edit the part 
properties in the design and make its power pin visible. Then connect it to an 
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appropriate voltage symbol in the schematic. If you check the Pin Visible option when 
building the part, then the power pin is always visible in the schematic and will always 
need to be explicitly tied to a voltage symbol or wire in order to appear in the netlist. 

It is not a good idea to use overbars above power pin names. If you do, any netlists that 
you create will have invalid power pin names.  

It is common to add power pins using the Zero Length pin shape. 

Multiple power pins tied to the same voltage should be added with duplicate pin names 
(for example, pin name +5V) because the pin name is used as the net name. As long as 
the Pin Type is Power, no duplicate pin errors will occur when you save the part. 

  

The Ignore field causes a pin to be ignored during design rules check. 

Pin Swapping 

Use the PinGroup column to define pin swapping. This field must contain an integer. For 
example, INA and INB are equivalent inputs. Assigning the same pin group value to each 
of these pins lets them pin swap during PCB layout. 
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Adding User Properties  

In the Part Properties area you can make Pin names and numbers visible, or rotate pin 
names. You can also add new properties by clicking on the plus sign just below the Part 
Properties area. 

  

Once you have added a new property you can choose to make it visible by clicking the 
Display Property icon next to the new property entry.  

  

NOTE: The property known as CLASS is a required property for OrCAD and Allegro PCB 
Editor, which gets used in netlisting and the setup of rules. 
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The Part Properties section enables you to add new properties and edit existing ones. It 
also contains some default part properties. For example, various implementation 
properties let you define relationships between the symbol and a behavioral simulation 
model or lower level schematic in a hierarchical design. There are also pin properties to 
control visibility and rotation of pin names and numbers. The table that follows 
identifies and describes each option and field within the Part Properties section of the 
Property Sheet menu. Deleting a visible property in the Part Editor only makes it 
invisible again. 

 

Default Part Property Use Description 

Pin Names Rotate When True, pin names will be horizontal on 
left and right edges, and vertical on top and 
bottom edges. 

 

Pin Names Visible Some parts do not need logical pin names 
visible (for example, simple gates or 
discretes). 

Pin Numbers Visible Some parts do not need pin numbers visible 
(for example, discrete resistors and bypass 
capacitors). 

 

For parts with Passive pin types, you can select the part in the schematic, edit its 
properties, and control visibility for pin names and numbers. For all other pin types, 
visibility of names and numbers must be set at the library level. 

Adding Properties for OrCAD and Allegro PCB Editor 

When applicable, NC_PINS (no connect) pins may be added as a user property for the 
OrCAD and Allegro PCB Editor. 



OrCAD Capture Essentials Version 17.4       

June 2020 EMA Design Automation, Inc. ®   © 2020 All rights reserved                     105 

 

No connect pins are not added to the symbol, but are defined with the NC_PINS user 
property. The value of the NC property is a comma-separated list of physical pin 
numbers. 

When transferring the design to the OrCAD and Allegro PCB Editor, the NC_PINS 
property is required to account for all package pins not present on the schematic 
symbol.  

Yet another way to handle package pins such as connector mounting holes is to create 
these pins as “mechanical” pins when creating the footprint in the OrCAD and Allegro 
PCB Editor tools. This is covered in the OrCAD PCB Editor training class. 

All parts, for the advanced features of the OrCAD and Allegro PCB Editor, MUST have a 
property assigned to them, called CLASS. The value for this Property is one of three: IC, 
IO, of DISCRETE. This property is used by the OrCAD and Allegro PCB Editor to group 
types of components for placement. 

  



 

 

Lab 4-1: Creating a Homogeneous Part 

Lab Objectives 

After you complete this lab you will be able to: 

• Open the New Part Properties window 

• Create part graphics 

• Add pins and power pins 

• Modify pin properties 

• Assign pin numbers to all gates in a package 

• Set up pin swapping for the OrCAD and Allegro PCB Editor 

• Add user properties 

• Control property display 

• Add part aliases (optional) 

Open the New Part Properties Window 

1. In the Project Manager, click (highlight) TRNG.OLB. 
2. From the RMB pop-up menu select New Part. 

 

3. The New Part Properties dialog box appears. 
4. Complete the form as shown in the graphic that follows.  
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5. Click OK.  

When finished, the TRNG library window would look like the example below if you 
copied the 2 symbols in the previous lab. 

 

Creating the Part Graphics 

The Part Editor automatically displays a part boundary box five grid spaces square. All 
part graphics must fit within the dotted boundary, but the boundary can be expanded 
by selecting it and sliding the corners to the desired size for the symbol graphic.  

1. Maximize the Part Editor window, then select View > Zoom > All (or click the Zoom 

to all icon in the toolbar ). 
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2. Next, adjust the boundary to encompass 4 grids by 4 grids. Do this by selecting the 
dotted line boundary and dragging the corner(s) to be a 4X4 square. This will 
accommodate the size of the gate you are drawing. 

Drawing Line Segments 

Next you will begin placing the line segments.  

1. Select Place > line (or click the Place line icon ) and add lines to complete the 
polygon, as shown in the next figure. 

 

2. Right-click and select End Mode from the pop-up menu or press the <ESC> key to 
exit polyline mode. 

Placing an Arc 

Next you will draw the arc to complete the symbol graphic. Arcs are generally drawn 
using the following method:   
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Step 1- click the first “edge”  
Step 2 - click the next outer “edge” 
Step 3 - expand the circle to meet the desired size of the arc;  
Step 4 - finally – drag the arc to the desired shape.  

Follow the steps outlined below. 

1. Select the Place Arc command from the Place pull-down menu or the icon  in 
the Draw Toolbar. 

2. Examine the “dots” on the screen. Your first click should be what would be the 
“below edge” of an imaginary “circle, indicated by the ‘1’ in the figure below. 

3. Now move the cursor up four grids and click to designate the top edge of the circle 
(indicated by the ‘2’ in the figure below) and click a second time. 

4. Now, move your cursor two grid points to the right in the center and notice a circle 
appears that you can stretch as you move the cursor (indicated by the ‘3’ in the 
figure below).  Click on the 3rd point indicated in the graphic below to mark the 
circle. 
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5. Finally, as you move your cursor you can see the arc forming from bottom to top. 
Double click the final point to complete the arc. 

6. Once your arc has been completed it will still be highlighted. Right click (RMB) in 
an area away from the symbol and choose End Mode to end ‘Place Arc’ mode. 

  

Adding Pins 

Next you will be placing pins on the part. 

1. Click the Place pin icon  (or select the Place > Pin command from the pull-down 
menu). 

2. Enter the information shown in the following picture.  
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3. Click OK. 

The pin image attaches to the boundary box. As you move your cursor, the pin 
snaps to 100 mil grid points along the boundary edges. 

4. Position it as shown in the following picture, and click to place it.  

Do not double click when adding a pin, as this places two pins at the same 
location. 

  

5. Move the cursor and notice that a second pin is now attached and ready for 
placement.  

6. Click to add a second pin two grids below the first pin. 

Notice that the pin number automatically increments. You will change the pin 
name later.  

7. Place a third pin on the right side, as shown in the graphic that follows. 
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8. Press the <ESC> key twice. 

Modifying Pin Properties 

Next you will edit the pin properties of 2 of the placed pins. You can edit each pin 
individually or you can select both pins to edit. When editing a single pin – after you 
select it notice the Pin Properties area appears in the Property Sheet menu (to the 
right of the work area). In this way you could edit each pin. Optionally, you can select 
multiple pins and then use the Edit Pins area to make the desired changes. You will be 
using the multiple-pin select method in the following steps. 

1. Use <Ctrl+LMB> to select both pins 2 and 3.  
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2. RMB somewhere on the screen and select Edit Pins or press <Shift+H>. This will 
open the Edit Pins window. Here you can edit the pin properties. 

 

3. Click in the Name field for pin 2 and change the pin name to INB. 
4. Change the Name for pin 3 to OUT, set the Type to OUTPUT, and check the Short 

Dot checkbox. 
 

5. Click Apply. 
6. Press <ESC> to deselect all pins.  

Your part should now resemble the following picture:  

 

Adding Power Pins 

You will now add power pins, as shown in the following example. 
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1. Click on the Place pin icon , and enter the values shown in the following 
picture. 

 

2. Uncheck the Pin Visible setting. 

Whether power pins are made visible or not visible they still are interpreted as global 
nets during netlisting. With power pins visible it may be easier to see the power if you 
wanted to tie it to a different voltage, such as 3V.  

If you choose to keep power pins visible, the text can be adjusted for size as well as 
rotated to make it fit better within the symbol graphic. You will experiment with 
editing text size and rotation in a later step. 
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3. Click OK. 
4. Place the GND pin on the bottom of the graphic.  
5. Remain in pin placement mode and place another power pin at the top of the 

graphic. Then press <ESC>.  
6. If necessary, select and drag the Part Reference U?A, and <VALUE> so they do not 

overlap the power pins.  
7. Select the power pin you placed at the top of the graphic and change the Name to 

VCC in the Pin Properties area of the Property Sheet menu. 

Note that the pin number was automatically incremented to 8.  

8. Change the Number to 14.  

 

Assigning Pin Numbers to All Package Gates 

As this is a homogeneous part with four parts per package, the part graphic represents 
one of four identical sections. The easiest way to assign pins to the remaining sections 
is to use the Edit All Pins dialog. You will use this method in the following steps. 

1. Scroll down in the Property Sheet menu and click on the Edit Pins button (make 
sure you do not have any pins selected.  
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The Edit All Pins dialog appears. Towards the top are the names of the items you 
can edit: Pin Number; Pin Group; Pin Ignore; Order; Pin Type; Pin Shape. The first 
column shows the Normal View: Pin Name and then you can see the rest of the 
columns as they pertain to each section of the part. In this case the part has 4 
sections: A, B, C, and D. 

Notice the scroll bar towards the bottom of the window enables you to scroll to 
the right to see more available information. 

 

 

 

2. Assign pin numbers to sections B, C, and D as shown in the next picture. 

The GND and VCC pins map to pins 7 and 14 respectively, for all sections in the 
package. Choose ignore and leave the pin number 
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3. Click Apply. Do not close the dialog yet. 

Setting Up Pin Swapping for the OrCAD and Allegro PCB Editor 
(Optional) 

In order to perform pin swapping in the OrCAD and Allegro PCB Editor you must set 
pin swap properties in the OrCAD Capture library. 

1. In the Edit All Pins dialog (should still be open) use the scrollbar at the bottom to 
scroll to the right to locate the Pin Group column and the rest of the available 
information.. 

2. In the Pin Group column - for the input pins (INA and INB), assign the number 1.  
3. In the Pin Group column - for the output pins (OUT) assign the number 0. (zero) 
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Using a ‘1’ indicates that the input pins are swappable within each gate. Using a zero 
indicates that the pin is not swappable. Leave the PinGroup field empty for pins GND, 
and VCC. 

4. Click OK to apply the settings. 
5. Select File > Save to save the part. 

Adding User Properties & Controlling Display 

1. From the Property sheet menu, expand the part Properties area and select the 
Add New Property button at the bottom.  

  

2. Add 2 new properties (CLASS, and Part_Number) as shown in the Part Properties 
area below. 
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3. Next, for each new property select the display icon and choose to display the 
Value Only.  

  

Notice that the part now displays those 2 values. While they are set to display at the 
symbol level they can be made invisible on the schematic if desired. You can also 
move the text to a more desirable location away from pins. 

4. Save and Close the part. 
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Lesson 5: Creating Heterogeneous 

Parts 

Lesson Objectives 

After you complete this lesson you will be able to: 

• Create a Heterogeneous part 

Heterogeneous Parts 

A heterogeneous part is a part that has two or more unique part graphics or pin count. 
It could have a different number of pins in each “gate” or part. Any part with a pin 
common to all the other gates must also be defined as a ‘Heterogeneous” part. 

The following part displays each gate with a different number of pins in the gates as 
Power & GND are displayed on only the first gate. 
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A heterogeneous part must be defined as multi-section (Parts per Pkg is set to two or 
more). Each part graphic represents a different portion of the entire package. 

For example, an OPAMP may have 4 gates but only the first gate contains the Power 
and/or Ground pins. You define this heterogeneous part as having four parts per 
package. In the Part Editor, use the View > Next Part command to create three unique 
part graphics, as shown in the previous graphic. 

Annotation 

Auto Annotating Parts 

You can have Capture preferences set to automatically assign the next available 
reference designator in that category by making sure the auto-annotate option is 
check on. By so doing, you will not have to be concerned about managing reference 
designators manually. See the graphic below. 
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Lab 5-1: Creating a Heterogeneous 

Part 

Lesson Objectives 

After you complete this lab you will be able to: 

• Create an heterogeneous part 

 

1. If a library is not still open in OrCAD Capture, select and open the TRNG.OLB library 
you were working with. 

2. Highlight the library name and from the right-mouse button pop-up menu select 
New Part. 

  

3. Enter the information as shown above. Be sure and select Heterogeneous for 
Package Type. 

4. Click OK. 
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Creating the Symbol for the first gate 

1. Set your window to full, then select View > Zoom > All (or click the button in the 
toolbar) to adjust the view. 

2. Using the Place Polyline command  ; and draw a triangular graphic as shown 
in the next image. To draw diagonal lines press <Shift> then draw line.  

3. After the triangle is drawn adjust the boundary to the edges of the triangle.  
 

 

Adding Pins for the first gate 

1. Click the Place > Pin button. 
2. Enter the information shown in the following picture, then click OK. 

 

3. The pin image appears, attached to the cursor. Position it as shown in the 
following picture and click to place it. 
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4. Place the two additional pins. Next you will edit the additional pins. 

Editing the Placed Pins 

1. To edit the other pins press <Shift+H> or RMB and select Edit Pins 
 

 

  
 
2. Using the Edit Pin area, edit the newly added pins to achieve the follow image.  

Next pin: Name ( - )   Next pin: Name ( OUT ) 
    Number ( 2 )     Number ( 1 ) 
    Type  ( Input )    Type  ( Output ) 
 
3. When you have finished editing the pins compare it to the graphic provided below. 

The pins names, types, and numbers should match the graphic. 
4. If you have not yet adjusted the part boundary, be sure and do so at this time. See 

the graphic below. 
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Place the Power pins 

1. Make sure Snap to Grid is on.  Pins should always be placed on a part using Snap 
to Grid to ensure accurate connections to wires on the schematic.  

  

2. Select Place > Pin. Use the Place Pin window to add the following properties for 
the first power pin (see the following graphic) 

 

  
 
3. Once you click okay the pin will attach to the cursor. Adjust it to be placed on the 

top of the symbol as shown in the graphic below. 
4. Follow the same steps (as in Step 2 & 3 above) to add another power pin (pin 

number = 11, name = V-) and add it to the bottom of the symbol as shown in the 
graphic below. In steps later on you will learn how to adjust and rotate the text. 
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Drawing a Stub Line on the Graphic  

Because the gate is a triangle the power pins would not be able to be placed directly 
against the body of the gate. Instead, you can use a graphic line to connect from 
where the pin would connect to the image body. For this step you’ll be drawing a line. 

You will also want to turn off the Snap to Grid in order to place the line accurately. 
But – when you have completed drawing the line be sure and turn Snap to Grid back 
on. 

1. Use the line graphics command, or Place > Line, to draw a short “stub” from the 
edge of the triangle graphics to the edge of the bounding box. See the following 
graphic.  

2. Make sure you turn off Snap to Grid to do this. Turn it back on when you finish 
drawing the line stubs. 
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Place the Power pins 

1. Be sure to turn Snap to Grid back on - Pins should always be placed on a part 
using Snap to Grid to ensure accurate connections to wires on the schematic.  

2. Select Place > Pin. Use the Place Pin window to add the following properties for 
the first power pin (see the following graphic) 

 

 
 
3. Once you click okay the pin will attach to the cursor. Adjust it to be placed on the 

top of the symbol as shown in the graphic below. 
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4. Follow the same steps (as in Step 2 & 3 above) to add another power pin (pin 
number = 11, name = V-) and add it to the bottom of the symbol as shown in the 
graphic below. In the next steps you will learn how to adjust and rotate the text. 

 

Adjusting the Text Size and Placement 

 
1. Select the pin name text (V+) for Pin 4. Notice that there is now a section of the 

Property Sheet menu called Basic Attributes. Here you could change attributes 
like font and font size. 

2. With pin name V+ still selected, RMB  and choose Rotate > Rotate 270. 
3. Follow the same step to rotate the pin name text (V-) for Pin 11. 
4. Next, use the same method to rotate the power pin numbers (4 & 11). 
5. Next, you may wish to resize the pin name text to be smaller so that it fits within 

the part. Select the pin name V+ and, using the Basic Attribute area, select the 
Font Size dropdown and change the font to size 5. See the graphic below. 
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6. Now you can grab the pin name and move it within the body of the part so that it 
fits without colliding into other text. You may want to turn off Snap to Grid to 
maneuver the text more easily inside the symbol body. Be sure to turn Snap to 
Grid back on when you are finished. 

7. Do the same for the power pin named V-. 
 

The part should look like the following picture. 

 

 

Creating the Symbol for Section Two, Three, and Four  

1. Choose View > Next Part. The next symbol window will appear. 
2. Follow the steps you used to create the first symbol graphic, only this gate will 

NOT have the power pins. 
3. Edit the pins to match the following graphic. 
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4. Choose View > Next Part. The next symbol window will appear. 
5. Edit the pins to match the following graphic. 
 

 
 
6. Choose View > Next Part. The next symbol window will appear. 
7. Edit the pins to match the following graphic. 
 

 
 
8. Save the library part, then Close the part window. 
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9. You can also edit all pins at once by RMB and select Edit Pins to edit all numbers at 
once 

 

 
 
10. File > Close the library.   
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Lesson 6: Building a Simple Schematic 

Lesson Objectives 

As you create a single-page schematic in this lesson, you will: 

• Create a new Project 

• Find and Place parts 

• Add and name wires 

Creating a New Project  

In OrCAD Capture, you can create four different types of projects using a Project 
Wizard. When you open the Project Wizard from the File > New > Project menu, the 
first dialog box that displays presents the different options you can choose.  

   

If you plan to use PSpice A/D to simulate the schematic, you must check Enable Pspice 
Simulation when you create a new project 

The project name you specify is used to name both the project and design files. For 
example, if you name the project mydesign, the project filename will be mydesign.opj 
and the design filename will be mydesign.dsn.  

It is important to create a design directory for each new project. This structure keeps 
all the files for each design together in one place. Name the design directory after the 
project name. 
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OrCAD Capture includes the option to change the project type of any existing OrCAD 
Capture project to a different one. 

You can change a capture project into a pspice simulation by creating a simulation. 
Once you create the simulation, capture will prompt you to select a pspice license. 

 

Enabling a Simulation Project 

Select the Enable PSpice Simulation checkbox if you intend to have simulation 
capabilities in your design.  
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The New Design Project 

  

 

Once project setup is complete, OrCAD Capture opens the new project and displays 
the design resources in a Project Manager window. A default schematic folder named 
SCHEMATIC1 is added to the design file. OrCAD Capture also adds a default schematic 
page named PAGE1 and opens it for edit. 

Notice that the Title block displays the setting you added in a previous lab when you 
set up the Design Template. 
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Placing Parts 

 

To open the place part menu, press the icon  in the schematic toolbar or open 
through the main menu place>part. 

Before you can add a part to your design, you need access to the library where it 
resides. If this library was not configured during initial project setup, then you need to 
press the Add Library button to add it to the Place Part window before you can select 
it for use in the design. 
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Once the library has been added, you can select it in the Libraries list. The parts in the 
selected library are listed in the Part List. When you select a part in the Part List, you 
can view a graphic of the selected part. 

Rather than scroll through the Part List, you can type the name of the part you want 
to use into the Part field. As you enter each character, the data is matched against the 
parts in the selected library, and the Part List automatically scrolls to show the current 
matches. 

More Information 

Once a library has been added to the Place Part window, this setup is stored in the 
Capture.ini file located in the <install_dir>\tools\Capture directory. It will auto load 
into the Place Parts window during subsequent OrCAD Capture sessions. Press the 
Remove Library button to delete the library name from the Place Part window and the 
Capture.ini file. 

Cadence supplies many libraries for use with OrCAD Capture. These libraries are 
located at <install_dir>\tools\capture\library, where <install_dir> is the location of the 
OrCAD software. 

If you are planning to perform a PSpice A/D simulation, you must place parts from 
special PSpice A/D libraries. The PSpice A/D libraries are located at 
<install_dir>\tools\capture\library\pspice. 

You can automatically assign a part reference designator to each part you add. If there 
is more than one part in the package (see the Parts per Pkg field in the previous 
graphic), this option should be turned off. Select the 
Options > Preferences > Miscellaneous command to set this user preference. 

When more than one library is selected in the Libraries list, the Part List displays both 
the part and library name for each part in the selected libraries (for example, 
COUNTER/74160). 
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The Place Part Menu 
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Searching OrCAD Capture Libraries 

 

If you want to add a part but don’t know which library it is in, you can locate the part 
by searching all OrCAD Capture libraries. The Search for Part area on the Place Part 
window lets you use wildcard characters (*, ?). Once a part has been located, its 
associated library is automatically added to the Place Part window, and you are ready 
to select the part for use in the design. 

Use the Library Path field in the Search for Part section of the window to specify the 
path to a directory containing the OrCAD Capture library files. 
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Adding and Naming Wires 

 

You can use wires and net names (known as aliases) to define connectivity in the 
design. 

When you place a wire, it is assigned a system-generated net name (for example, 

N12345). You can replace the default net name with a net alias . 

Two wires with the same alias on the same page are connected by name, even though 
the two wires may not be physically connected to each other. 

More Information 

If the last character of a net alias is a number (for example, DATA7), after the net alias 
has been placed on the schematic, OrCAD Capture automatically increments the last 
character of the net alias (for example, to DATA8) so you can easily place successive 
aliases in sequence. If the last character is not a number, then the same net name is 
assigned with each mouse click. 
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Net aliases can contain any alphanumeric character, including dashes and 
underscores. The use of periods, slashes, and spaces in net names is not 
recommended. The percent sign (%) is a reserved PSpice A/D character. The asterisk 
(*) is considered a wildcard character by some downstream tools (for example, try not 
to use asterisks when sending a netlist to the OrCAD and Allegro PCB Editor). 

It is possible to add two or more unlike aliases to the same wire, or to connect two 
wires with unlike aliases together. Such errors can be found later during a design rules 
check, but will not be flagged by OrCAD Capture when they occur (more on design 
rules checking later in the course). 

Here are some things to remember when adding wires. 

• Leave Grid Snap enabled (located on the main toolbar above the work area).  

• When you are drawing a wire, OrCAD Capture alerts you with a red warning dot 

 whenever the wire endpoint comes into contact with another wire or pin 
(indicating that if you click, you will create a connection). If the proposed wire path 
will create a problem (for example, short two pins together), OrCAD Capture adds 

a triangular warning symbol . 

• Wire junctions are marked with junction dot symbols . The absence of the 
junction dot means the wires are not connected. To remove a junction dot, use the 
Junction icon in the schematic toolbar to place another junction dot on top of it. 

• When you connect a wire to a pin, the connection square  on the end of the 
unconnected pin disappears. If not, the pin is not connected. 
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Design Cache 

As you begin to add components to the schematic page, the Design Cache will record 
each part, as shown in the sample graphic below. 

 

When you add a part to a design, OrCAD Capture automatically stores a copy of the 
part in the Design Cache folder. This makes the OrCAD Capture design completely self-
contained (not dependent on any supporting libraries), because copies of all the parts 
are included in the design file. 

More Information 

Once a part has been copied into the Design Cache folder, it is used as a comparison 
tool. For example, you place a part in a design, and later that part is modified in the 
library. If you return to the library and try to place another instance of the same part, 
OrCAD Capture will compare that part to the original copy stored in Design Cache, and 
issue a warning saying the part you are adding is different from the one currently in 
your design.  

You can use the Design > Update Cache menu item to update the part in the Design 
Cache to match the edited version in the library, or you can decide against this, and 
instead place a copy of the part from the Design Cache (using the MRU list box). 

When you delete a part from the design, a copy of that part remains in the Design 
Cache. Use the Design > Cleanup Cache menu item to remove parts from the Design 
Cache folder that no longer exist in the design. You can also use the Design > Replace 
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Cache menu item to replace a part in the cache with a completely different part (such 
as a global part replacement). 

Saving and Closing the Schematic 

Use the File pull-down menu to save the design and close the schematic window. 

 

You may also close and save a schematic page by selecting the X in the upper right 
corner of the schematic page or selecting the Save icon on the tool bar. 
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Closing the Project and Exiting OrCAD Capture 

 

Use the File pull-down menu to close the project.  

You can also close the project by clicking the X in the corner of the Project Manager 
Window. If you click in the Project Manager window while a schematic window is 
open and close the project, the Project Manager records the window arrangement. 
The next time you open the project, the schematic window is restored to its previous 
size and location. 



 

 

Lab 6-1: Creating a New Project 

Lab Objectives 

After completing this lab you will be able to: 

• Identify the project location 

• Name a project 

• Identify a project type 

• View the title block 

Create the Project Directory 

1. On your computer, navigate to C:\EMA_Training\Capture_Essentials\Designs  
2. If the \Designs directory does not exist go ahead and create it. 
3. Next, create a new directory named LESSON6. This is where you will store your 

LESSON6 files in the upcoming lab. 
 

 

Project Name 

In the next steps you will create a new project that resides in the new design directory 
you just created, located at:  C:\EMA_Training\Capture_Essentials\Designs\LESSON6 

1.  In the OrCAD Capture session window, select File > New > Project. 

The New Project window appears. 

2. In the Name field, enter: LESSON6 



OrCAD Capture Essentials Version 17.4       

June 2020 EMA Design Automation, Inc. ®   © 2020 All rights reserved                     150 

3. In the location field, browse to the directory you created earlier:  
C:\EMA_Training\Capture_Essentials\Designs\LESSON6 

 

Making the Schematic Page Active 

1. Click on the schematic page tab to make it active.  

 

Observe the schematic toolbar – it will be either along the top or along the right edge of 
the OrCAD Capture session window. Also observe the main toolbar and pull-down 
menus across the top of the OrCAD Capture session window. 

2. Click in the Project Manager tab to make the LESSON6 Project Manager active.  

 

Observe that some icons in the schematic toolbar are greyed out when in the project 
manager and vice versa in the schematic page. The main toolbar and pull-down 
menus change as well. 
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3. Click in the schematic window to make it active again. Resize this window (make it 
larger) if necessary. 

4. Click the Zoom to all icon. This fits the contents of the schematic in the window. 
All you currently have in this design is a title block. 

Observe that the data in the title block reflects the information you entered into the 
design template  

 

5. Click the Zoom out icon. 

You are ready to begin your first design. 

 



 

 

Lab 6-2: Find and Place Parts 

Lab Objectives 

After completing this lab you will be able to: 

• View the reference schematic 

• Find and place parts from a library 

Viewing the Reference Schematic 

1. Take a moment to examine the following schematic. Please use this example as a 
guide. 

  

Adding a 74F162 

1. Make sure the schematic window is active.  
2. Select Place > Part from the pull-down menu on the menu bar. 

The Place Part window appears to the right of the Icon toolbar. 
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3. Click the Add Library button.  

 

The Browse File window appears.  

4. Set the Look in field to C:\Cadence\SPB_17.4\tools\capture\library. 

 

This is where all the OrCAD Capture libraries are stored. The above path may vary, 
based upon your training site and where the Cadence software is installed on your 
system. 

5. Select the Counter.olb library file and click Open. 

The COUNTER library is added to the Libraries list in the Place Part window, and all 
the parts in this library are listed in the Part List above. 

6. In the Part field, enter: 
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74F162 

Observe how each character you enter is used to search the Part List for all matching 
entries. A picture of the 74F162 part is shown in the lower right corner of the Place Part 
window. 

 

7. At the top right of the Place Part window, click on the Place Part Icon.  

The part silhouette attaches to the cursor. 

8. With the part “floating” on the cursor, select a location on the schematic page and 
click (LMB) to place the part on the page. 

The part silhouette remains attached to the cursor, ready to place more instances of 
it.  

9. Right-click and select End Mode from the pop-up menu or press <Esc>. 
10. Left-click anywhere in the page to deselect the newly added part. 
11. Select File > Save. 

The 74F162 part was in the COUNTER library. This library was added to the Libraries list. 
This library list is stored in the Capture.ini file. 
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Adding a 74LS00 

1. Make sure the schematic window is active and return to the Place part window.  

If the window is not open press the <P> key on the keyboard. 

2. In the Place Part window click on the plus sign (+) to the left of Search for Part.  
3. In the Search For field, enter: 

74LS00 
4. The library Path field (at bottom) should already be set to  

C:\Cadence\SPB_17.4\tools\capture\library 
If necessary, use the Browse button to set it. See the following example. 

 

Depending on your software installation, the above path to the library may differ. 

If the filter gets set, enter the * symbol into the Place Part box and then press the 
<Enter> key. This resets the setting. 

5. Click the Part Search icon. 

 

The search results are shown in the Libraries list (for example, 74LS00/Gate.olb). 
This means that the 74LS00 part was found in the GATE library. 

6. Double-click on the 74LS00/Gate.olb entry in the Libraries list. 

The GATE library is added to the Libraries list in the Place Part window, and the 
74LS00 part is automatically selected and “floating” on the cursor. 
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7. Add this part to the schematic. 
8. To exit from Place Part mode, press <Esc>. 
9. Click left anywhere in the page to deselect the newly added part. 
10. Select File > Save. 
11. At this point the schematic page should look something like the following picture. 

 

The 74LS00 part was in the Gate library. Since you did not know which library this part 
was in, you searched all OrCAD Capture libraries before adding the part. Once the 
74LS00 was found, the Gate library was added to the Libraries list. 

Add the PCB Footprint Names to the Parts 

This property will be required to correctly netlist the design. Each schematic symbol 
must have an accompanying pc board footprint in order to correctly establish the pcb 
layout.  

1. Select both of the parts on the current page. Use the <CTRL> LMB (left mouse 
button) to select both parts. 

2. RMB (right mouse button) click, and from the pop-up menu select Edit Properties. 
3. When the Property Editor appears, find the column or row for PCB Footprint and 

enter the following values: 

For the 74LS00 make it SOIC14 

For the 74F162 make it SOIC16 
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If you get an Undo Warning select Yes. This warning is letting you know that this action 
will change information on the schematic and once completed you cannot undo 
previous actions using undo button. 

4. If your Property Editor does not show the properties in columns, try clicking on the 
Pivot button, which should alter the view as shown in the graphic below. 

 

5. Close the Property Editor by clicking X at the edge of the tab. 

 

We will go into much more detail on using the Property Editor in a later lesson of this 
manual. 



 

 

 Lab 6-3: Adding and Naming Wires 

Lab Objectives 

After completing this lab you will be able to: 

• Add wires 

• Name wires 

• Complete the schematic 

Adding Wires 

1. Make sure that the schematic window is active and select Place > Wire.  

You can also use the Place > Wire   icon in the schematic toolbar (or press the 
<W> key on the keyboard). 

2. Click pin 14 of part 74F162. Move the cursor to the right a short distance, then 
double click to end the wire. Notice that the wire is still highlighted but that you are 
no longer in Draw Wire mode. 

3. With the new wire still selected, press the <F4> key three times.  

The wire segment is repeated each time, one grid down from the original.  

4. Press the <Esc> key twice. 

 

Naming Wires 

1. Select Place > Net Alias. 

You can also click the Place > net alias icon , or type <N> on your keyboard.  
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2. In the Place Net Alias window, enter Q0 and click OK. 

 

A net name box is attached to the cursor. 

3. Click the wire attached to pin 14 of the 74F162 part.  

Net name Q0 is assigned to the selected wire. You are still in Place Net Alias mode. 

 

4. Successively click on the wires attached to pins 13, 12, and 11.  

OrCAD Capture automatically increments the net names to Q1, Q2 and Q3, 
respectively.  

 

5. Press the <Esc> key twice to exit Place Net Alias mode. 
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Pressing <F4> to repeat the prior action does not work in Place > Net Alias mode. Also, 
if the net alias ends in a non-numeric character, the name remains the same when you 
place successive aliases. 

 

Completing the Schematic 

1. Use the Place > Wire  and Place > Net Alias icons to complete the schematic and 
connect the 74LS00 gate. (Please refer to the example shown at the beginning of this 
lab.) 

2. Use Place > No Connect or the icon   to add No Connect symbols to all 
unconnected pins of the 74F162 part (except pin 15). The schematic page should 
look something like the picture below. 

3. Save the design. 

To remove a “No Connect” symbol, click the Place > No Connect icon, and click over any 
existing “No Connect” symbol already set on a pin in the schematic. 
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Auto-Wire (Between 2 points) (Optional) 

1. In another part of the page, add 2 more 74F162 parts. 

2. From the Place pull-down menu Auto>Wire > Two Points or using the icon . 

 

 

3. Select 2 pins to connect and from the pop-up menu  
4. A wire will automatically connect between the pins selected. Notice the following 

example. 

 

5. When you have finished experimenting with this new command, delete the 2 new 
74F162 parts and wires. They will not be used in the upcoming design. 

6. Save the design. 
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Lesson 7: Processing a Schematic Design 

Lesson Objectives 

After you complete this lab you will be able to: 

• Assign reference designators 

• Check the design for errors 

• Create a netlist for OrCAD and Allegro PCB Editor or other board layout tools 

• Generate a Bill of Material (BOM) 

Assigning Part References 

Each part in your design must have a unique reference designator. In OrCAD Capture 
you can assign a reference designator manually or automatically. 

Each part requires a unique part reference. Part references must be assigned before you 
can check the design for errors or create a netlist for PCB design.  

The following graphic shows reference designators on 74F162 and 74LS00 set with “?”. 
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Manual Assignment after Placement 

 

If the part has already been added, and it currently has no assigned part reference, 
double-click on its temporary part reference and edit its value (as shown in the above 
illustration). You can also use this technique to change an existing part reference. 

Here are some things to remember about manual part reference assignments: 

• All parts come into a design with pin outs assigned. 

• All parts come into a design with a temporary part reference (for example, U? is 
single-section, or U?A is multi-section). You can override this temporary part 
reference before or after placing the part (as previously described). 
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Single-Section versus Multi-Section Parts 

 

A single-section part is a part that represents the entire physical package. A multi-
section part is a part that represents only a portion of the physical package. The 
Packaging section of the Place Part form reflects the number of sections (or slots) in the 
physical package. 

For a multi-section (gate-level) part: 

• If the Packaging section of the Place Part form was not used, the temporary part 
reference and pin outs will default to section A (repetitively).  

• If the Packaging section of the Place Part form was used, then the temporary part 
reference and pin outs will coincide with the selected section. Pinots always match 
the section.  
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• If the part is homogeneous, you can manually change the section once the part is 
placed (for example, from U?A to U?B). This causes the pin outs to change 
automatically. You cannot manually assign a section that does not exist. 

• If the part is heterogeneous, all you can do is change the question mark (?) to show 
grouping into a specific package. The pin out is locked at placement based on the 
section you selected in the Place Part form. 

• When you manually edit a multi-section part reference, OrCAD Capture does not let 
you remove the section indicator. 

• When you use the Packaging section of the Place Part form to select a specific 
section, the Annotate program does not maintain the selected section (even in 
Incremental mode) unless you also supply a part reference. 

Automatic Assignment during Placement 

 

 

You can set your user Preferences to automatically assign a part reference as each part 
is placed in the design. This is set in the Auto Reference option.  
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This works well for single-section parts (for example, capacitors, discrete resistors, and 
most digital logic devices), as well as for multi-section parts. See the example above. 

For multi-section parts, OrCAD Capture does not assign part references in a way that 
optimizes physical package counts in the design, only the next number available in the 
sequence. For this example, U2A, U2B, U2C, U2D represent parts or gates of the same 
physical package. These less-than-optimal part reference assignments could be 
manually edited, or automatically overwritten (see the next section, Automatic 
Assignment after Placement). 

Automatic Annotation 

 

NOTE: When Annotating Heterogeneous parts, use the option labeled: Auto-package 
Heterogeneous Part Using First Match. This will be the most efficient way of packaging 
the heterogeneous symbol. 

To automatically assign part references after placing parts, use the Annotate icon in the 

main toolbar , or the Tools > Annotate command.  
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In Incremental mode, the Annotate program will not change a manually or auto 
assigned part reference, even if duplicate part references exist. Incremental mode only 
processes parts that have no assigned part references. Incremental mode starts with the 
next highest part reference. (For example, if the design already has a U100, then the 
next part reference will be U101.) 

In Unconditional mode, the Annotate program overwrites all existing part references, 
regardless of how they were assigned. Unconditional mode optimizes all multi-section 
parts into a minimum number of physical packages. Unconditional mode starts with U1, 
R1, C1, and so forth, and works its way through the sequence, processing parts in the 
order they appear in the schematic page (left to right, top to bottom). This mode 
eliminates all duplicate part references in the design.  

The option Annotation Type allows you to select the general direction on the schematic 
pages for Annotation. 

To automatically annotate heterogeneous parts, these parts must have an attached user 
property to show package grouping (for example, PARTGROUP). This property must be 
entered in the Combined Property String box at the bottom of the Annotate window. 

Cadence Allegro Reuse 

(This option is NOT currently available for OrCAD PCB Editor.) The options in this tab are 
related to the OrCAD Capture/Cadence Allegro design flow. You can create and reuse 
modules in both the OrCAD Capture and Allegro environments. This means you can 
store physical placement and signal routing data created in Allegro together with the 
OrCAD Capture schematic information and reuse it in another design. This can be very 
helpful when different designs share functional logic blocks or when a design contains 
redundant circuitry. 
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Design Rules Check (DRC) 

 

To check the design for errors, use the DRC icon in the main toolbar, or the Tools > 
Design Rules Check command. You must use the DRC program to flag the connectivity 
errors in your design. 

OrCAD Capture does not prevent you from assigning more than one signal name to the 
same wire, or physically shorting two different nets together. 

The DRC program flags nets with no driving source, and nets with fewer than two 
connections. When two nets have been shorted together, OrCAD Capture simply uses 
the net that has the lowest alphanumeric value. No error or warning message is 
generated by the DRC program. However, to find shorted nets, look at the list of net 
names created by the Report All Net Names option. OrCAD Capture does not prevent 
you from manually assigning duplicate or invalid part references. The Annotate program 
ignores these errors in Incremental mode (or resolves them in Unconditional mode). 
You must use the DRC program to flag manual annotation errors.  

For example, the DRC program flags invalid packaging (such as unlike device types 
assigned to the same physical package), as well as duplicate part references. 
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The design needs to be annotated before you can run Design Rules Check. 

When the Design Rules Check window opens there a series of tabs across the top of the 
window for all the settings that are available to run with a DRC check. 

 

Design Rules Options 

The first tab is shown in the window above. Here you decide if you want to: 

• Add DRC markers for warnings besides the errors 

• Run this DRC against a “flat” design (Instance), or a hierarchical design (Occurrences) 

• Choose to preserve waived DRCs 

• You can also flag it to show you the output of the report as soon as it finished. (View 
Output). 
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Rules Setup 

 

The Electrical Rules drop down allows you to set checks for: 

• Single node nets 

• Pin conflicts and net with no driving source 

• matching off-page connections and hierarchical ports 

• unconnected bus nets 

• off grid objects 

• misleading tap (bus) connections 
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The Physical Rules drop down allows you to set checks for: 

• Power pin visibility 

• missing PCB Footprint 

• missing pin numbers 

• unused part packages 

• identical part references 

• invalid packaging 

The Custom Rules drop down allows you to set checks for: 

• Device Pin mismatch 

• Hanging wires 

• Overlapping wires 

• Part reference mismatch 

• Port pin mismatch 

• invalid packaging 
 

ERC Matrix 
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The Electrical Rules Check flags invalid pin-to-pin function connections found in the 
design. The ERC Matrix tab shows a matrix of all possible pin-to-pin combinations. Each 
pin-to-pin combination can be defined as valid (no error or warning), or invalid (error or 
warning flag generated). 

In addition, the matrix includes a row used to define the error condition for various 
types of unconnected pins. 

The matrix buttons have three toggle positions as identified in the following table. 

Icon Meaning 

  
The pin combination represented by this matrix position will 
not be flagged (the pin-to-pin connection is logically 
acceptable). 

  
The pin combination represented by this matrix position will be 

flagged as a warning. Turn on the Create DRC Markers for 
Warnings option in the DRC window to see these flags in the 

schematic. 

 
The pin combination represented by this matrix position will be 
flagged as an error. 

 

The severity of the ERC Matrix settings has no effect on your ability to create a netlist. 
The ERC Matrix settings are stored in the Capture.ini file. Use the Restore Defaults 
button to reset the matrix. 

At this point in time, anytime you see Occurrences or Instances in any of the windowed 
selections use the following as a guideline: 

•  Instances = “flat” designs 

•  Occurrences = hierarchical designs 
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The DRC Report  

 

The Design Rules Check generates a report listing all the objects checked, and any 
violations encountered. This report is listed in the Outputs folder of the Project Manager 
window. (Double click on the file name to view the report in a new tab.) 

The results of a DRC check are also displayed in the OrCAD Capture Session Log. 

Error Markers 
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The Design Rules Check marks schematic pages with warning and error markers. You 
can double click on a DRC error marker to see a description of the problem. 

If you save the design, the DRC markers are also saved. Each time you start the DRC 
program, it automatically clears existing error markers and creates new flags. (The 
design must be saved to retain the new markers.) 

You can delete the DRC markers interactively or delete them automatically by using the 
Delete Existing DRC Markers option in the DRC setup window. 

OrCAD and Allegro PCB Editor Netlist 
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OrCAD Capture uses a configuration file to control part association with net properties. 
This configuration information which is included in the OrCAD and Allegro PCB Editor 
netlist is stored in the application installation directory by default. However, you may 
use the Setup button located in the Tool > Create Netlist > PCB Editor tab of the dialog 
box to specify an alternate path to this file.  

As you create an OrCAD and Allegro PCB Editor netlist, three netlist files are created and 
stored in the directory location you specify in the Netlist Files Directory field. In the 
above illustration, the netlist files are created in the allegro subdirectory within the 
current project.  

The OrCAD and Allegro PCB Editor routing process creates a SPECCTRA.dsn file that 
should be stored separately from the <design>.dsn file associated to the OrCAD Capture 
schematic. It is important to take note of the separate directory locations.  

The three files created when you create an OrCAD and Allegro PCB Editor netlist are 
listed in the Project Manager window within the Outputs folder. 

• pstchip.dat: This file contains the library definitions of all the devices in the OrCAD 
Capture design.  

• pstxnet.dat: This file defines all the connections in the design. This file also contains 
net properties. 

• pstxprt.dat: This file is a parts list. All part properties are sent to the OrCAD and 
Allegro PCB Editor in this file. 

The Create Netlist window also lets you load the three netlist files into an OrCAD and 
Allegro PCB Editor design. 

You can use an alias in the configuration file to map an old Allegro PCB Editor property 
into a new one. If you have a previous Allegro design that uses the DELAY_RULE 
property, you can map this property to another property name (for example, 
DELAY_RULE = PROPAGATION_DELAY). 

Common Issues and Errors 

The netlister has an Allegro PCB Editor-specific error checking mechanism that 
generates a list of Allegro PCB Editor formatting errors and halts the netlist generation. 
The error messages are written to the session log. A netlist.log file is also written to the 
current working directory.  
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The following table identifies and describes common problems associated with creating 
or loading an OrCAD and Allegro PCB Editor netlist. For additional information, please 
see Help > Known Problems and Solutions within the OrCAD Capture application. 

Error Message Description 

Missing PCB Footprint Every part in the design must have an assigned PCB Footprint property to 
ensure operation of the netlister. If you attempt to run the netlister before 
PCB footprints are assigned, the process will abort.  

The footprint property can be defined through either the library or parts in 
the design. 

No Connect Pins A pin with a No Connect symbol placed on it will be tied to net name NC in 
the netlist. These are unconnected pins, as opposed to No Connect pins. 

No Connect pins are non-electrical pins on the physical package. No Connect 
pins are usually not present on the OrCAD Capture symbol. However, these 
pins must be defined, or else errors occur when you load the netlist into the 
OrCAD and Allegro PCB Editor. Use the NC property to supply a list of No 
Connect pin numbers for a part. 

No connect pins can be added to the OrCAD Capture symbol, but they must 
have unique pin names (for example, NC1, NC2, and so on). Pins that appear 
on the symbol should not be included in any NC property. 

OrCAD and Allegro PCB Editor package symbols can contain mechanical pins, 
or pins without numbers (for example, the mounting holes on a connector). 
A part in the OrCAD Capture library would not need an NC property to 
account for these mounting holes. 

Duplicate Pin Names If two or more visible pins have the same pin name, the netlister will abort. 
However, if the pin type is POWER, the netlister will automatically alter the 
duplicated pin names to make them unique. 

Illegal Characters The netlist does not allow the use of single quotes or exclamation marks in 
any pin, part, or net names. It is best to use A-Z, 0-9, and the underscore 
character as the only punctuation. 

Missing Pin Number Every pin must have an assigned pin number. The netlister will abort if you 
attempt to use it before completing pin number assignments. 
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Creating an OrCAD and Allegro PCB Editor Netlist 

You can create an OrCAD and Allegro PCB Editor netlist using the OrCAD Capture 

commands Tools > Create Netlist > PCB Editor or by using the icon . Then import the 
three default OrCAD and Allegro PCB Editor net files into OrCAD and Allegro PCB Editor. 

In your <install directory>, in the OrCAD Capture directory, is a configuration file that 
lists the properties that the Netlister will extract from the OrCAD Capture Schematic for 
both Parts and Nets. This file is the Allegro.cfg file. These are also the properties that 
you will find listed under the Cadence-Allegro property filter in the OrCAD Capture 
schematic editor. (See how to edit or create property filters in Lesson 9 of this manual.) 

General Rules for Netlisting 

The OrCAD and Allegro PCB Editor netlister extracts 3 ASCII files: PSTCHIP, PSTXNET, and 
PSTXPRT. 

• Make sure that ALL parts have a PCB Footprint value. 

• Pin counts of the OrCAD Capture part must match the physical symbol (footprint). 

• ALL pins must have a pin name and number in the OrCAD Capture part. 

• To account for UNUSED pins (such as component mounting holes) use the NC part 
property to list them or make the pins in the physical symbol (footprint) mechanical 
pins. 

• There are attribute length limits and character limits for the OrCAD and Allegro PCB 
Editor. See the following chart. 
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* In the OrCAD and Allegro PCB Editor the default maximum number of characters is 30. 
You can set the initial length for new designs to a maximum length of 255 by using the 
allegro_long_name_size environment variable (Choose Setup > User Preferences). You 
can change the size in existing designs by choosing Set > design Parameters and 
specifying a new maximum for the Long Name Size in the Design Tab. 

Remember, it is recommended that you avoid the use of spaces in directory names, 
design names and net names. 

Common Errors 

View these error messages in the OrCAD Capture Session Log. 

• PCB Footprint missing in OrCAD Capture 

• Footprint does not match library (symbol) name 

• Cannot find symbol - psm or pad path incorrect 

• Pin mismatch - pin numbers or total pin counts do not march from Footprint to 
component symbol 

• Pin name not allowed 

• Pin Number missing in OrCAD Capture part. 
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Lab 7-1: Assigning Reference 

Designators 

Automatic Assignment 

1. In the Project Manager window, highlight .\LESSON6.dsn. 

2. Select Tools > Annotate (or click the  icon in the main toolbar). 
3. In the Scope choose Update Entire Design 
4. In Action, select “Incremental Reference Update”. 
5. In Mode, make sure it is set to “Update Instances (Preferred)”. 
 

 
 

6. Click OK. When prompted with the Undo Warning window, click OK again to 
continue. 

7. Your design is annotated and saved. 
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NOTE: If you had heterogeneous type parts in your schematic, it is recommended that 
you choose the option towards the bottom of the annotate window to: Auto-package 
Heterogeneous Part Using First Match. This option will utilize the most efficient 
packaging method for all the gates in a heterogeneous part. 

View the auto-assigned reference designator (U2A). Observe that the manually assigned 
reference designator was not changed. This is because you ran the annotation program 
in Incremental mode.  

The Options > Preferences > Miscellaneous tab contains an Auto Reference checkbox (If 
checked, this option auto-assigns reference designators as you place parts). Design 
Rules Check 



 

 

Lab 7-2:  Design Rules Check 

Lab Objectives 

After completing this lab you will be able to: 

• Verify design compliance to design rules 

• Correct warning on unconnected pins 

Running the Design Rules Check 

1. In the Project Manager window, click .\LESSON6.dsn. 

2. Select Tools > Design Rules Check (or click the   icon in the main toolbar). 

The Design Rules Check window appears.  

3. In Design Rules Options make sure the following are selected: 

 

• DRC Action: Run on Design 

• Use Properties (Mode): Instance (preferred) (for Flat-designs) 

• Warning: Create DRC markers for warnings 

• Waived DRC: Do not Preserve 

• Show DRC Outputs: DRC Window 

• Report saved in your EMA_training directory 
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4. Select the Rules Setup tab and set the following: 

 

• Check single node nets 

• Check no driving source and Pin type conflicts 

• Check duplicate net names 

• Check Power pin visibility 

• Check missing/illegal PCB Footprint property 

• Check missing pin numbers 

• Check Power Ground short 

 

Under Report Setup set: 
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5. Click the ERC Matrix tab at the top of the window.  
6. Set the matrix buttons along the bottom row to W, as shown below. 

 

This causes all unconnected pins to be flagged as warnings. 

7. Click OK to check the schematic.  
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The DRC report is created. The report contains warnings for an unconnected pin, 
nets with no driving source, and nets with fewer than two pins (one-pin signals) and 
missing Footprint names (if you forgot to set). 

 

8. View the DRC report window. 

These errors are also flagged with DRC markers on the schematic page. 

9. To get information about an error, double click on the DRC marker. 
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Alternate Method to Locate DRC Markers 

1. Select the Project Manager window and highlight the design name. 
2. From the Edit pull-down menu, select Browse > DRC Markers. 

A “Browse” window will open with a list of all the DRC markers, their locations, and 
the error. 

3. Double click on the error message in the left-hand column for “Unconnected Pin”. 

The page with the error marker will open and the error marker will be highlighted 
for you. 

Fixing the Unconnected Pin Warning 

1. Click the Place no connect icon and add a “no connect” symbol on pin 15 of the 
74F162. 

2. Save the design. 
3. Check the design again (the design file must be selected in the Project Manager 

window). 
4. Review the new DRC report and observe that the unconnected pin warning is gone.  

Use the No Connect symbol to notify the error checker when pins are intentionally 
left unconnected. 

5. Close the report. 
6. In the schematic, observe that the error marker on pin 15 of U1 has been cleared. 

Please do not fix the remaining errors. These problems are addressed in the next 
lesson:  Netlist for PCB Editor 



 

 

Lab 7-3:  Netlist for PCB Editor 

Lab Objectives 

After completing this lab you will be able to: 

• Create a netlist 

• View the netlist 

• Close the schematic and project 

• View the system files 

Creating a Netlist 

1. With the design file highlighted in the Project Manager window, select Tools > 

Create Netlist (or click the icon in the main toolbar ). 

The Create Netlist window appears. 

2. Explore the multiple choices available by selection some of the tabs in this window. 
3. Click the tab for PCB Editor. The following window opens. 
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4. You do not need to change anything. The defaults are acceptable for this design. 
Click OK. 

5. If asked, click OK when prompted about the design being saved prior to netlisting. 
6. If prompted to create the “Allegro” directory, click yes. 

OrCAD Capture creates a netlist for the OrCAD and Allegro PCB Editor in the 
“Allegro” sub-directory which consists of 3 files referred to as “.DAT” files. 

 pstxnet.dat 

 pstxchip.dat 

 patxprt.dat 

Viewing the Netlist 

1. In the Project Manager window, double click on one of the “.dat” files (under the 
Outputs folder). 

 

2. When you are finished, close the netlist window. 
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Closing the Schematic 

1. Click in the schematic window to make it active, and select File > Close or click the X 
next tot the schematic page tab. 

2. If it asks you to save, do so. 

Closing the Project 

1. Select File > Close. 

The main session window is still running. 

2. A project can also be closed by clicking the X in the top right of the Project Manager 
Window 

Viewing the System Files 

1. Use Windows Explorer to navigate to the 
C:\EMA_Training\Capture_Essentials\Designs\LESSON6 directory. 

2. Notice the files stored in your project folder, and their various extensions. 



 

 

Lab 7-4: Creating Bill of Materials 

After completing this lab you will be able to: 

• Create a Bill of Materials 

Create a Bill of Materials 

1. Highlight the design name in the Project Manager window. 
2. Select Tools – Bill of Materials or press the icon. 

 

 

The Bill of Materials window appears. 

3. Click Place each part entry on a separate line (checkbox ON). 
4. Click View Output (checkbox ON). 
5. (Alternate) Instead of selecting View Output, select the Open in Excel to have the 

BOM output open directly in Excel. 
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6. Click OK. 

The Bill of Materials report is displayed. Observe that the report contains four 
columns of data; Item, Quantity, Reference, Part. 

Close the report. 
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Lesson 8: Building a Multi-Sheet 

Schematic 

Lesson Objectives 

After you complete this lesson you will be able to: 

• Create a new project 

• Create a Bus and use off-page connectors 

• Copy from one design to another 

Multi-Sheet Connectivity 

Two wires with the same net alias are automatically connected by name when they 
appear on the same page. But when two such wires appear on different pages, you must 
add off-page connectors to each page to establish connectivity between the two wires. 

Off-Page Connectors do not connect nets from one hierarchical folder to the next. You 
must use a Hierarchical Port for this. 
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Each off-page connector you add must be named. This name identifies the net that 
needs to be connected to another page in the design. (“Any wire attached to a symbol, 
assumes the name of the symbol...”) 

The name of the off-page connector overrides the net alias of the wire to which it is 
attached. When an off-page connector is tied to an unlabeled wire, the wire will inherit 
the off-page connector name. 

Off-Page Connectors 

 

You must use the Place off-page connector icon in the schematic toolbar to add off-
page connectors to the design. There are two off-page connector symbols located in the 
CAPSYM.OLB library. 

When placing an off-page connector, you need to consider two things: 

• The direction in which you want the off-page connector to point  

• The location of the pin (connection point) on the off-page connector 
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The name of the off-page connector symbol embodies both direction and pin location 
information. 

For example, the OFFPAGELEFT_R symbol in the CAPSYM.olb library is an off-page 
connector that points to the left, with a pin on the right. The other off-page connector in 
the CAPSYM library is called OFFPAGELEFT-L (it points to the left, and its pin is also on 
the left). 

By default, both of the off-page connector symbols point to the left. If you draw a 
schematic with input signals on the left side of the page and output signals on the right 
side, you will probably rotate both these off-page connector symbols before placing 
them in the design (as demonstrated in the previous illustration). 

From a logic standpoint, off-page connectors do not define any directional information 
about the nets to which they are attached; they just specify the net name only. 

Power/Ground Symbols 
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You can use the Place power and Place ground icons in the schematic toolbar to add 
power and ground symbols to the design. These symbols are contained in the 
CAPSYM.OLB library. All symbols in the CAPSYM.OLB library can be added using the 
schematic toolbar icons. 

When you click on the Place power and Place ground icons, a dialog appears in which to 
enter parameters. Use the Name field in the dialog to specify the voltage name.  

All power and ground symbol connections represent global nets. This means that any 
wires tied to voltage symbols having the same name will be connected together, 
regardless of which schematic page they are on, or in which schematic folder they 
appear in the hierarchy. (Hierarchical designs are further discussed later in this course.) 

Another source of global net connections is the hidden voltage pins defined for a part in 
the library. 

When you connect two voltage symbols together, the voltage symbol with the 
alphanumerically lowest net name takes precedence. For example, if you connect an 
AGND symbol to a GND symbol, all GND connections will appear in the netlist as AGND. 

Use the PSpice A/D library, Source.olb, to properly designate a high or low signal during 
simulation. Alternately, set the net name on the CAPSYM library symbol to 0 (zero). 
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Buses and Bus Entries 

 

A bus entry is a short diagonal symbol used to connect wires to buses. Use the Place Bus 
Entry icon in the schematic toolbar to add bus entries. (You may need to rotate the bus 
entry symbol to the proper position before placing it.) 

A bus wire is a vectored (multiple bit) wire used to bundle a group of scalar (single bit) 
wires together. A bus wire is graphically thicker than a regular wire. Use the Place Bus 
icon in the schematic toolbar to add bus wire connections. 

A bus wire must be labeled to reflect the scalar nets contained within it (otherwise, it 
will be assigned a default system-generated net name like any other unlabeled wire in 
the design). If a bus wire is mislabeled, the DRC program will flag any connectivity errors 
that may result. (For example, Q[0-3] has no driving source, or has fewer than two 
connections, and so on.) 

Use the Place Net Alias icon  in the schematic toolbar to assign a net alias. 
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Use the following special syntax when labeling bus wires. 

BASENAME[n-m]  i.e. BA[0-7] 
or 
BASENAME[n..m] i.e. BA[0..7] 
or 
BASENAME[n:m] i.e. BA[0:7] 

The variable [n-m] represents the range of signals carried by the bus (n can be greater or 
less than m). The brackets must be square brackets; otherwise, OrCAD Capture does not 
let you attach the alias to the bus wire. Whichever convention you choose, use it 
consistently. 

You can use a bus entry symbol to merge or split like-named buses. When a bus entry is 
used in this way, it appears thicker than a normal (single bit) bus entry.  
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Manual Assignment during Placement (Option) 

 

You can specify a part reference while adding a part to the design. After you select the 
part from the library, right-click and select Edit > Properties before you place it. This 
opens the Edit Part Properties window as shown above. 

Use the Part Reference field to assign a reference designator manually. 

Use the Part Value field to assign a value to the Part. 

Use the PCB Footprint field to assign a Footprint pattern to the Part. 

Select User Properties to assign any other Property you wish to the Part. 
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Lab 8-1: Creating a New Project  

Lab Objectives  

After completing this lab you will be able to: 

• Edit a design template 

• Assign a name to a project 

• Assign a project “type” to a project 

• View the title block 

• View the system files and design resources 

Create the Project Directory 

1. On your computer, navigate to C:\EMA_Training\Capture_Essentials17.4\Designs  
2. If the \Designs directory does not exist go ahead and create it. 
3. Next, create a new directory named LESSON8. This is where you will store your 

LESSON8 files in the upcoming lab. 

Editing the Design Template 

1. Select Options > Design Template. 
2. Click the Title Block tab, and in the Title field enter: 

Lesson8 
3. Click OK. 

Project Name 

1. In the OrCAD Capture session window, select File > New > Project. 

The New Project window appears. 

2. In the Name field, enter: 
Lesson8 

Opening a New Project 

1. If the start page is still open you can open New Project there, if not go to File > New 
> Project…  
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2. Name project and choose the LESSON8 directory that you created 
3. Leave the Enable Project Simulation box unchecked and click OK.  

Viewing the Title Block 

1. Click in the schematic window to make it active. Resize this window (make it larger) 
if necessary. 

2. Click the Zoom to All icon.  

Observe that the data in the title block reflects the change you made to the design 
template. 

3. Click the Zoom Out icon. 

Viewing the System Files 

1. Using Windows Explorer, navigate to the directory:  

C:\EMA_Training\Capture_Essentials\Designs\Lesson8 

2. Observe the following files in the project directory: 
Lesson8.dsn - binary design file. 
Lesson8.opj - ASCII project file. 

3. Close the Windows Explorer. 

Viewing the Design Resources 

1. Click in the Project Manager window to make it active. 
2. Click on the plus sign (+) to the left of .\Lesson8.dsn. 

The display expands to show the contents of the design file. 
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3. Click on the plus sign to the left of SCHEMATIC1. 

The display expands to show PAGE1 of the schematic. 

4. Click on the plus sign to the left of Design Cache. 

The display expands to show the parts that have been added to the design. The only 
symbol currently in the design is a title block.  

Files within the Design Cache folder are binary files, which can only be viewed from the 
Project Manager window. 



 

 

Lab 8-2: Create a Bus and use Off-Page 

Connectors  

Lab Objectives 

After completing this lab you will be able to: 

• View a reference schematic 

• Add a header connector 

• Mirror the connector 

• Add and copy decoupling capacitors 

• Add wires and net aliases 

• Add no connect and power/ground symbols 

• Add bus entries and wires 

• Add off page connectors 

• View the design cache 

Viewing the Reference Schematic 

1. Take a moment to examine the following schematic. Please use this example as a 
guide as you complete the steps in this lab. 
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Adding a 12-Pin Header Connector 

1. Make sure the schematic window is active, and click the Place Part icon   in the 
schematic toolbar (or press the <P> key on the keyboard). 

2. In the Place Part window, click on plus sign (+) to the left of Search for Part. 

The Part Search portion of the Place Part tab opens. 

3. The library Path field (located at the bottom of the dialog box) should already show 
the installation path and library directory: 

C:\Cadence\SPB_17.4\tools\capture\library 

If not, use the Browse button to set this path. 

4. In the Search For field, enter: 
header* 

OrCAD Capture searches all libraries for any parts that begin with the word 
“header”. 

5. Click the Part Search icon. 
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OrCAD Capture locates many different headers in a CONNECTOR library. 

6. Scroll down and double-click on the HEADER 12/Connector.olb entry in the Libraries 
list, then click the ADD button to add the library to your list. 

The CONNECTOR library is added to the Libraries list in the Place Part window, and 
the HEADER 12 part is automatically selected and “floating” on your cursor. 

 

7. Do not add the part to your schematic yet. 

Mirroring the Connector 

1. If the part did not automatically attach to your cursor, select it now and go to Step 2.  
2. With the connector still attached to your cursor, right-click, and select 

Mirror Horizontally from the pop-up menu. 

The connector pins should now be facing to the left. 

3. Right-click again and select Edit Properties from the pop-up menu. 
4. In the Edit Part Properties window, enter J1 into the Part Reference field. 
5. In the PCB Footprint field enter CONN12 and click OK. 
6. Click to place the connector in the design. 
7. Press <Esc> to exit Place Part mode. 
8. Press <Esc> again to deselect the connector. 
9. Select File > Save. 

You mirrored the connector horizontally and assigned a reference designator to it 
before placing it in the design. You could also have done this after the part was 
placed. 

Adding Decoupling Capacitors 

1. If the Part Place tab is closed, click the Place Part   icon in the schematic toolbar. 
2. In the area of the Place Part window where it says Libraries, there are two icons. 

Hover over them with your cursor until you see Add Libraries. Click on the Add 
Library button.  
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The Browse File window appears.  

3. In the Look in field, navigate to the library directory: 

C:\Cadence\SPB_17.4\tools\capture\library 

This path will vary depending on your directory location of the Cadence software. 

4. Select the DISCRETE.olb library file and click Open. 

The DISCRETE.OLB library is added to the Libraries list in the Place Part window, and 
all the parts in this library are listed in the Part List. 

5. In the Part field, enter: 
cap 

Observe that each character you enter is used to search the Part List for all matching 
entries. 

6. At the top right of the Place Part tab, click on the Place Part icon, but Do Not place it 
yet. 

7. Right-click and select Edit Properties from the pop-up menu. 
 

 
 

8. In the Part Value field, enter 0.1uF. 
9. In the PCB Footprint field enter SM_1206. 
10. Click OK. 
11. Click to place the capacitor in the design. (You might want to place both capacitors 

or do the next step to copy. See “Copying the Capacitor on the next page.) 
12. Press <Esc> to end the command, and <Esc> again to deselect all parts. 
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13. Select File > Save. 

You assigned capacitance before placing the bypass cap in the design. You could also 
have done this after the part was placed. 

 

Copying the Capacitor 

1. If you have already placed 2 capacitors move to the next section titled “Draw BUS 
Using Auto Wire > Bus” 

2. Place the cursor on the capacitor, click to select, and press and hold <Ctrl+LMB>, 
and drag a copy of the capacitor to a new location. 

(LMB stands for Left Mouse Button.) 

3. Press <Esc>. 

Draw the BUS Using Auto Wire > BUS 

1. The bus line will be connecting to pins 1 thru 4 of the Header, so make sure it 

extends down far enough to use a bus entry to pin 4. Choose Place > Bus   
2. Before you begin drawing the bus line, hold down the Shift key. This will enable you 

to make the angled line in the bus. Draw the line using the following graphic as a 
guide. 
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3. Using the image above, draw a bus line to the left of the connector. Leave about 10-
12 grid spaces for this example. 

Connecting the Bus to the Header Pins 

 

4. Select the Auto Wire > Connect to Bus command from the Place pull-down menu or 

the Auto Connect to Bus icon  on the schematic toolbar. The “route” cursor will 
appear. 
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5. Click on pins 1-4 of the connector then click on the bus you drew to the left of the 
connector. The wires and bus entries will be drawn to the bus for you. See image 
above. 

6. A small label window will appear. Enter the name of the bus as it includes all the bits 
of the bus...Q[0-3]. 

 

7. Select OK. The bus will be annotated with the bit numbers you entered. See 
following image. 
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Alternate Method to Draw Bus Connections 

An alternate method of drawing a bus would be to do it manually using the following 
commands: 

• Place Bus 

• Place Bus Entry 

• Place Wire 

• F4 (to easily repeat wires) 

• Place Net Alias 

In this case you have placed a bus wire on a schematic page that is not very dense, but if 
the schematic page were dense you may need to leverage the manual method in order 
to properly add the bus wire. 

Adding No Connect Symbols 

1. Use the Place No Connect  icon  to place No Connect symbols on all 
unconnected pins of the HEADER 12 part. 

2. Press <Esc> to exit the command. 
3. Save the design. 

Adding Power/Ground Symbols 

1. Click the Place Power icon . 

The Place Power window appears. 

2. In the Libraries field, click CAPSYM. 
3. Scroll down, select the VCC symbol, and click OK. 
4. Add the VCC symbol to the schematic. You may place as many VCC symbols as 

required (or you can copy them later). 

5. Click the Place Ground icon . 
6. Select the GND symbol, click OK, and place as required. 
7. Press <Esc> to exit the command, and <Esc> again to deselect all parts. Your caps 

should now look like the following once you’ve added the power symbols: 
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8. To move a power or ground symbol, press and hold the left mouse button and drag 
the symbol to a new location. 

9. Add or adjust wiring to connect the power and ground symbols. 
10. Save the design. 

Making GND Symbols Names Visible (Optional) 

1. Select the GND symbol, then RMB, and from the RMB pop-up menu select Edit 
Properties. 

2. When the Property Editor window opens look for the Property called Name and 
select the column as shown below. 

 

3. Just above the Property line you will see a “button” for Display. Click on it. 
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4. The Display Properties window will open. Select Value Only and click OK. 

 

The Display Properties window will close. 

 

 

5. Close the Property Editor window to apply the change. View the following picture. 

 

Adding Off-Page Connectors 

Off page connectors must be used if a signal travels between pages. They tell Capture 
that there is more than one instance of a connection that resides on another schematic 
sheet. 

1. Click the Place Off-page Connector  icon.  
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The Place Off-Page Connector window appears. 

2. In the Libraries list, click on CAPSYM.OLB, then select OFFPAGELEFT - L from the list 
above. 

3. In the Name field (at the bottom), enter: Q[0-3] 
4. Click OK. 

The off-page connector attaches to your cursor. 

5. Press the <R> key to rotate the symbol. Do this twice to spin it 180 degrees. 
6. Click to attach the off-page connector to the end of the bus wire (as shown in the 

next graphic).  

 

7. Press <Esc> to exit the command, and <Esc> again to deselect the  
off-page connector. 

8. Click the Place Off-page Connector  icon , and repeat this process to add off-
page connectors to the LOAD, CLEAR, and CLOCK nets also (refer to the next graphic 
illustration). 

An easy way to change the name of the next off-page connector you want to add is to 
right-click and select Edit Properties from the pop-up menu. 

Save and Close the Design 

1. Click the Zoom to All icon . Your finished page should resemble the following 
image. 
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2. Select File > Save. 
3. Select File > Close, and No to close the window. 

Viewing Design Cache 

1. In the Project Manager window, look at the list of parts under the Design Cache 
folder. 

This list represents all the parts that were added to page one of this design. 
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2. Click the minus sign (-) to the left of the Design Cache folder to collapse the display.  



 

 



OrCAD Capture Essentials Version 17.4       

June 2020 EMA Design Automation, Inc. ®   © 2020 All rights reserved                     217 

Lesson 9: Property Editor 

Lesson Objectives 

After completing this lesson, you will be able to: 

• Work with Property Filters in the Property Editor 

• Add part and net properties using the Property Editor 

• Using other Property Editor Techniques 

Part Properties  

 

Each part in the design has special characteristics that need to be defined as properties. 
For example, every part needs a PCB footprint and a company part number. Depending 
upon the type of device (discrete, analog, digital IC), some parts may require more 
properties than others. 
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The Property Editor 

 

The Property Editor Window lets you add, delete, or modify the properties of parts, 
wires, and text. To access the Property Editor, click on an object (part, wire, or text), 
click the right mouse button, and select the Edit Properties command from the pop-up 
menu. You can also double click on the part, wire, or text. 

Pivoting the Spreadsheet 

The Property Editor displays a spreadsheet with selected object(s) along the left side, 
and a list of properties across the top. You can pivot the spreadsheet to display the 
property list along the left, and a list of selected objects across the top (as shown in the 
accompanying illustration). 

When the spreadsheet is pivoted with property names on the left, the New Column 
button becomes the New Row button (see illustration). 
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Filtering the Spreadsheet 

The Property Editor lets you filter the contents of the spreadsheet. Use the tabs along 
the bottom of the window to filter the contents by object type. For example, when you 
select a part, the Parts tab is selected by default, and the part properties appear in the 
property table. Click the Pins tab, and the spreadsheet displays the pin properties for all 
the pins on the part. 

Use the Filter by field at the top of the Property Editor window to filter the spreadsheet 
using a property list. (Think of Property Filters as a list of specific properties that you 
wish to see at a given time.) Each property list is given a name and is known as a filter. 
All filter names are displayed in the Filter By field. Select a filter name to switch from 
one property list to another.  

The properties in the Cadence-supplied filters target specific design tools. For example, 
there is a property list for the OrCAD and Allegro PCB Editor. The <Current properties> 
filter lists all properties currently assigned to the selected object(s). 

You can create your own filters. For example, you can create a filter that just contains 
manufacturing-related part properties. When you select a part (or all parts), you can 
load, view, and edit these parts using a special property filter. Or you can create a list of 
high-speed routing properties to use when you’re working with special nets.  

The filter names and property lists are stored in the 
<install_dir>\tools\capture\prefprops.txt file.  

It is strongly recommended that the prefprops.txt file not be edited. Also, copy it to 
another directory before you begin editing in the Property Editor. The only way to 
restore the original is to re-load OrCAD Capture.  



 

 

Lab 9-1: Property Filters in the 

Property Editor 

Lab Objectives 

After completing this lab you will be able to: 

• Open an existing project 

• Filtering by object type 

• View and select available property filters 

• Pivot the editor spreadsheet 

• Assign a PCB footprint 

• Add a new property 

• View and edit net properties 

Opening an Existing Project 

1. Select File > Open > Project. 
2. Navigate to the C:\EMA_Training\Capture_Essentials\Designs\Intro directory. 
3. Select the Intro.opj file, and click Open. 
4. In the Project Manager window, click the plus signs (+) to display the contents of the 

design file, and double click on PAGE1. 

Page one of the schematic is opened. 

5. Resize the schematic window, and zoom to fit. 
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Selecting a Property Filter 

1. Click the 74F162 part to select it, right-click, and select Edit Properties from the pop-
up menu. 

The Edit Properties menu appears. 

2. At the top of the Edit Properties window, click in the Filter by field. 
3. Scroll through the list of filter names, and select the OrCAD PCB Designer Standard 

entry. 
4. Close the Property Editor window. 

 

Viewing Available Property Filters 

1. Double click the 74F162 part, again, to select it. 
2. At the top of the Edit Properties window, click in the Filter by field. 
3. Now set the Filter by field to Capture. 
4. Set the Filter by field to <Current Properties>. 

All properties currently assigned to the part are displayed (regardless of which tool 
the property is targeting). 

Filtering By Object Type 

Another way to control the contents of the Property Editor window is by object type. 

1. Observe the tabs along the bottom edge of the Property Editor window.  
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2. Click the Pins tab or entity filter at the bottom of the window. 

All the pin properties for the 74F162 part are displayed. 

3. Click the Parts tab or entity filter at the bottom of the window. 

 

Pivoting the Editor Spreadsheet 

1. Right click in the empty cell in the top left position of the spreadsheet, and select 
Pivot button 

 

Observe that the spreadsheet now lists property names at the left (as shown below) 
instead of across the top. If you double click again in the top left cell, the property 
names will pivot back across the top of the spreadsheet (the default format).  
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Printing the Property Editor Spreadsheet 

If you want to print out the Property Editor spreadsheet, do the following: 

• Highlight all the Properties. 

• Go to the main OrCAD Capture menu and do Edit > Copy. 

• Open a text editor, such as Word or Notepad, and Paste into the editor 

• Optionally you could do a File > Export > PDF 

 



 

 

Lab 9-2: Using the Property Editor to 

add Part and Net Properties 

Lab Objectives 

After completing this lab you will understand how to edit properties for both parts and 
nets. 

Assigning a PCB Footprint 

1. With the property list pivoted along the left (as shown in the last view), click in the 
PCB Footprint field and enter: 

SOIC16 

2. Click Apply and close the Property Editor window. 
3. Press <Esc> to deselect the 74F162 part. 
4. If the PCB Footprint has already been applied move to the next step. 

Controlling Property Visibility (Optional) 

1. Double click on the 74F162 part. 

The Property Editor window is displayed. Observe that the PCB Footprint property 
value is set to SOIC16. 

2. Click on the SOIC16 property value, and click the Display button at the top of the 
spreadsheet. 

The Display Properties window appears. 

3. In the Display Format section of the window, click the Value Only option, and click 
OK. 

 

4. Close the Property Editor window. 

The PCB Footprint property value SOIC16 is now visible in the schematic. 
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5. Press <Esc> to deselect the 74F162 part. 
6. Select File > Save. 

Adding a New Property 

1. Double click on the 74F162 part. 
2. In the Property Editor, click New Row. 

The Add New Row window appears. 

3. In the Name field, enter: 
PART_NUMBER 

4. In the Value field, enter: 
20-67890 

5. Click OK. 

Notice the property name and value in the Property Editor window. 

6. Close the Property Editor window. 
7. Press <Esc> to deselect the 74F162 part. 
8. Save the design. 

Viewing and adding Net Properties 

1. Double click on a wire with the name of LOAD to select it. 

Observe the net name in the Property Editor window. Also observe that the 
Schematic Nets tab is automatically selected based on the type of object you picked. 

2. Toggle the Filter by field to Cadence-Allegro. 

This filter list the net properties you can use for the OrCAD and Allegro PCB Editor 
tool. 

3. Using the above mentioned Filter, set the future trace width to 20. 

(In the Cadence-Allegro filter, look for MIN_LINE_WIDTH.) 

4. Reset the Filter by field to <Current Properties>, and close the Property Editor 
window. 

5. Press <Esc> to deselect the wire. 

You can change a net name by editing the properties of a wire using the Aliases entity 
filter at the bottom of the Property Editor. Or you can double click on the net alias text, 
and use the Edit Net Alias window.  
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Lab 9-3: Using Other Property Editor 

Techniques 

Lab Objectives 

After completing this lab you will be able to: 

• Edit multiple objects 

• Add new properties 

• Search a current page 

• Browse a design 

Multiple Object Editing 

1. Press <Ctrl+LMB> to select both the 74F162 and 74LS00 parts. 

Remember, throughout this manual “LMB” refers to your “Left-Mouse-Button”. 

2. Right-click and select Edit Properties from the pop-up menu. 

Observe that the properties for both parts are displayed in the Property Editor 
window. 

3. Click in the PCB Footprint field for the 74LS00 part and enter: 
SOIC14 

a. Click Apply to set the value. 

b. Click the Display button. 

c. Set the Display Format to Value Only and click OK. 

This makes the value of the PCB Footprint property visible in the schematic. 

4. Click in the PART_NUMBER field for the 74LS00 part and enter: 
20-12345 
Click Apply to set the value. 

5. Click in the PCB Footprint field for the 74F162 part and enter: 
SOIC16 
Click Apply to set the value. 

6. Close the Property Editor window. 
7. Press <Esc> to deselect both parts. 
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Multiple Object Property Display 

1. Reselect both the 74F162 and 74LS00 parts. 
2. Press <Ctrl+E> to display the Property Editor. (Or select Edit Properties from the 

pop-up menu.) 
3. Click on the PCB Footprint property name box on the left (as shown in the following 

graphic). 

 

All PCB Footprint property values are highlighted. 

4. Click Display. 

a. In the Display Properties window, click Do Not Display. 

b. Click OK. 

5. Close the Property Editor window and press <Esc> to deselect all parts. 

Observe that all PCB Footprint properties are now invisible. 

Adding New Properties 

1. Reselect both the 74F162 and 74LS00 parts. 
2. Right-click and select Edit Properties (or press <Ctrl+E>). 
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3. At the top of the Property Editor window, click New Row. 

The Add New Row window appears. 

4. In the Name field, enter: 
VENDOR 

5. Click OK. 

The VENDOR property is added to the Property Editor window. 

6. Click on the VENDOR property name box (on the left). 
7. Right-click and select Edit from the pop-up menu. 

The Edit Property Values window displays. 

a. Click in the VENDOR field and enter: 

Digi-Key 

b. Click OK. 

The VENDOR name is applied to both parts. 

8. Close the Property Editor window and press <Esc> to deselect all parts. 

You can also use the <Ctrl+C> and <Ctrl+V> keys to copy and paste property values 
between cells in the Property Editor window. 

Searching the Current Page 

1. With the schematic page active, select Find or Search toolbar. It looks like the 
following figure. 

 

2. To the right of the Search icon, there is a down-arrow. Select that. When the list 
appears, make sure you do Deselect All first. Then select it again and highlight Nets. 
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3. In the Find box, enter a * . This means “all”. Then click on the Search icon. 
4. A list of all the Nets present on the open page will be displayed in a Browse window 

at the bottom of your design window. 

 

All nets on the current page are selected. This provides a convenient way to search 
for all objects of a desired type, without selecting everything else on the page. 

5. Select a Net or group of Nets. (Use the CTRL+LMB technique.) 
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6. With your cursor within the browse page, right-click and select Edit Properties. 
7. When the Browse Spreadsheet appears, select the New button and enter the 

information as shown. 

 

This illustrates adding a property to a wire(s). The Property for width in the OrCAD and 
Allegro PCB Editor is MIN_LINE_WIDTH. Although the MIN_LINE_WIDTH property is 
listed in the Cadence-Allegro property filter, we add it here as an example for adding a 
property to a wire “on-the-fly”. 

 

8. Click OK to apply the new property and its value. 

 

More detail for using the Find and Browse commands are covered in Lesson 16. 

Saving the Page 

1. Select File > Save and OK to save all pages of the design. 
2. Close the schematic page. 
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Custom Property Filters  

In this lesson, we discussed the Property Editor, and the default property filters that 
come with OrCAD Capture. These included the OrCAD and Allegro PCB Editor filter that 
let you work with a list of part or net properties specific to that PCB tool, without having 
to view other unrelated properties at the same time. There are also several vendor-
specific filters that apply to FPGA design. 

The Property Editor lets you create custom property filters for different purposes. For 
example, you may want to view only a handful of properties required for your Bill of 
Materials report. Or you may want to check all parts for a valid footprint, and don’t 
want to scan through a long list of properties to find just the PCB Footprint property 
name. In this case, you can create a custom filter that displays only a specific set of 
properties and associated values.  

More Filter Commands 

The Filter command pop-up menu contains several other useful commands. For 
example, you can use the Hide option to remove a property from the spreadsheet, but 
not from the filter itself.  

Use the Invert Filter command to toggle the display between properties defined in the 
current filter or properties on the selected object that are not defined in the current 
filter (including hidden and optional properties).  

The Show Undefined option toggles the display between properties defined in the 
current filter or properties defined in the filter plus any properties on the selected 
object not defined in the current filter. When you create a new filter, by default, the 
Show Undefined option is enabled. This causes all current properties on the selected 
object to display in the spreadsheet (because they are not yet defined as part of the 
current filter). 

Use the Show option to add a current property to the current filter, or to re-display a 
hidden property. 

Use the Undefined option to remove the selected property from the current filter. 
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Setting the status of a property to Optional causes a user-defined property to disappear 
from the spreadsheet if no value exists on the selected object. The Optional setting has 
no effect on reserved property names. 

Null versus Blank Property Values 

To set a property value to <null>, select the property value cell in the spreadsheet and 
click the Delete Property button. For user-defined properties, the cell then displays a 
pattern of diagonal lines to indicate a null value. 

If you use the <Delete> or <Backspace> keys to clear a property value from a cell, the 
selected property will have a blank value also. 
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Lesson 10: Navigating the 

Schematic Design 

Lesson Objectives 

After completing this lesson you will be able to: 

• Use the Search/Find toolbar 

• Use the alternate Find command 

• Use the Browse command 

• Using Intelligent PDF 

The Find Toolbar provides shortcuts for locating things in a schematic or on a schematic 
page(s). 

Use the Search/Find toolbar  
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Search functions include ways to narrow down or expand your search to the types of 
objects on a given page, the schematic folder or the entire design. 

Once the search is complete the Find window groups the search results by object type 
making it easy to find specific entities. You also have the option of saving the results to 
an HTML. 

The Find Window is also “dockable” allowing you to conveniently position the window. 
By default it will appear at the bottom of your screen. Depending on what is highlighted 
from the Project Manager window, you can search at the design, folder or page level. 
You can also search the current open page.  

 

While the search results display in the find window, the Session Log window also shows 
the details of the search like the total number of objects found and the resulting page 
the object(s) were found. 

 

 

 

 



 

 

Lab 10-1: Using the Search/Find 

Toolbar 

Lab Objectives 

After completing this lab you will be able to: 

• Activating the Search Toolbar 

• Use the Search toolbar 

 

Activating the Search toolbar 

The following lab can be done ONLY if the Search Toolbar is NOT already active. If the 
Toolbar is active go to step 4. 

1. A current method for search is to activate the Search Toolbar. From the Tools > 
Customize. 

2. When the Customize window opens select the Search toolbar to enable it. See the 
following figure. 
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3. Select OK to close the Toolbar window and you should see the Toolbar now active 
along the top where other Toolbars are shown. Move it where it will be convenient 
for you. It will look like the figure below. 
 

 

 

When this Toolbar is active the original method for search is disabled. 

4. If a design is not still open, open either LESSON8 or the INTRO design. Do not open 
any pages yet. 

5. There is also a Selection Filter as part of the Search Toolbar. To the right of the 
Search icon (binoculars) there is a small “down” arrow. Select it. A pull-down menu 
appears. All items on it are currently selected. Click on the Deselect All command. 

6. In the Search Toolbar, again select the down-arrow to the left of the Search icon and 
enable only Parts. 
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7. In the white search window enter C1 and then select, the Search icon  . 

The Session window should now open displaying information about C1 and the page 
containing the part will also open and be highlighted. Notice the next example figure. 
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8. Select File > Save. 
9. Click on the small  ”X“ in the upper left of the Browse window to close the Browse 

Parts window. 
10. Select File > Save to save the design 

 

...another search... 

1. Go back to the down-arrow again and select Nets.  
2. Now in the Search box on the Search Toolbar enter C* and all nets that begin with 

“C” are displayed in the Session Window. 
3. Select one of the nets such as CLEAR and the net will be highlighted wherever it is 

connected on the open page. See the following figure. 
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4. If you wish, experiment with these search options on your own. 
5. When you have finished, close all pages and the design with “no Save”. 

The Schematic “Edit Find” Command (Alternate) 

 

This Method was the original command to “Find” or “Browse” for items in the 
schematic. It is still present in the software but you must disable the new Search 
Toolbar before it will work. 
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When a schematic window is selected, the Edit pull-down menu contains the same 
editing commands as those available in the right mouse pop-up menu (for example, Cut, 
Copy, Paste, Delete, Mirror, and Rotate). However, the Edit pull-down menu contains 
commands such as the Find and Global Replace commands that are not available 
elsewhere.  

The Edit > Find command can be used to select parts, nets, text, and other types of 
objects in the current page. When using this command, you can use wildcards to search 
for an object, or use the Find What field to select objects with specific properties. Once 
these objects are selected, you can open the Property Editor to edit them. 

Use the Edit > Global Replace command to change the name of a net in the design. This 
command will not process off-page connectors. You cannot use this command to 
replace a part with another part. Wildcards are not supported in this menu. 

The Project Manager “Edit Browse” Command 
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When the Project Manager window is active, the Edit pull-down menu contains some 
commands not available elsewhere. For example, the Edit > Browse command lets you 
search by object type (for example, parts, nets, and so on). You can select specific 
schematic pages in the Project Manager to limit the search.  

The results are displayed in a browser window. Use the browser window to select and 
locate any part or net in the list. (The Project Manager will automatically open the 
applicable page for you.) If you make multiple selections in the browser window, you 
can edit them all at once from the Browse Spreadsheet window. 

With the Project Manager window active, you can also use the Edit pull-down menu to 
rename or delete a user-defined property in the design. 



 

 

Lab 10-2: Using the Edit Find Command  

Lab Objectives 

• Using the Edit Find command 

Setting up the Find method 

Before you can use this method, you must de-activate the Search Toolbar. 

1. From the Tools pull-down menu select Customize. 
2. When the Customize window opens, remove the check-mark for the Search. Then 

click on OK. 

 

3. Now go the Options > Preferences, and select the Miscellaneous tab. When that 
opens, look on the lower left and remove the check-mark form Find/Search Toolbar. 
Select the OK to apply the setting. 
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Searching the Current Page 

1. With the schematic page active, select Edit > Find or <Ctrl+F>. 

2. In the “Find What” box, make sure there is an “ * “. This means “all”. 

3. Set the Scope to Nets and click OK. 
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All nets on the current page are selected. This provides a convenient way to select all 
objects of a desired type, without selecting everything else on the page. 

4. In the Find Results section select all nets. 
5. RMB Edit properties or use keyboard command <Ctrl+Shift+E> 
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The Browse Spreadsheet will appear, from this window you can edit add or remove 
properties. The following exercise illustrates adding a property to a wire. The Property 
for width in the OrCAD and Allegro PCB Editor is MIN_LINE_WIDTH. 
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6. Give the New Property a Name and a Value. Although the MIN_LINE_WIDTH 
property is listed in the Cadence-Allegro property filter, we will add it here as an 
example for adding a property to a wire on the “fly”. 

 

 
 
7. Press OK to close the Browse Spreadsheet window. 

Saving the Page 

1. Select File > Save and OK to save all pages of the design. 
2. Close the schematic page. 

 



 

 

Lab 10-3: Using the Browse command 

Lab Objectives 

• Using the Browse Command 

The Browse command 

1. In the Project Manager window, click on .\Lesson8.dsn. 
2. Select Edit > Browse >Parts and OK to list all parts in the design. 
3. Double click part J1. 

 

Page two of the schematic is automatically opened, and the HEADER12 connector 
selected. 

4. Place your cursor in the schematic window, right-click, and select Edit Properties. 
5. In the Property Editor window, pivot the property names so that they appear in a list 

on the left. 
6. Assign a PART_NUMBER and PCB Footprint, as shown in the following graphic. 
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.  

 

7. Close the Property Editor window and press <Esc> to deselect all parts. 
8. Close and Save the design. 



 

 

Lesson 11: Preparing the Schematic for 

the OrCAD and Allegro PCB 

Editor 

Lesson Objectives  

After completing this lesson, you will be able to: 

• Add an OrCAD and Allegro PCB Editor part or net property to your design 

Part Properties for OrCAD and Allegro PCB Editor 

There many OrCAD and Allegro PCB Editor part properties you can add to your design. 
These are some of these properties are listed and described in the table that follows. 

OrCAD and Allegro PCB 
Editor Part Properties 

Description 

* PCB Footprint Defines the OrCAD and Allegro PCB Editor footprint pattern. All OrCAD 
and Allegro PCB Editor parts are required to have this property. The 
name of this property can be up to 255 characters long and may include 
the characters A-Z, 0-9, as well as the dash (hyphen) and underscore 
characters. Blank spaces within the name are not permitted.  

ALT_SYMBOLS Lists of alternate footprint patterns you can use apply to your part 
during PCB layout. Each alternate footprint must have the same pin 
count. 

* CLASS Classify the part as an IC, IO, or a Discrete device. This property is 
required in the OrCAD and Allegro PCB Editor to assist in the component 
type selection during part placement and is required if you are exporting 
your design to SPECCTRAQuest. The Discrete and IO part classes affect 
the model assignment process in SPECCTRAQuest. 

ROOM Assigns the part to a specific area or room of the PCB.  



OrCAD Capture Essentials Version 17.4       

June 2020 EMA Design Automation, Inc. ®   © 2020 All rights reserved                     252 

POWER_GROUP Used to assign alternate voltages to parts. This property overrides the 
voltages specified by invisible power pins with the names of alternate 
voltages you want the part to use. 

 

In the previous table, the * symbol before a Part Property indicates a required property. 

To associate any of the properties shown in the above table to a part, select one or 
more parts, and set the Filter by field to Cadence-Allegro in the OrCAD Capture 
Property Editor. 

Grouping Parts for PCB Design 

 

The above graphic illustrates how the ROOM property can be used to define areas in 
advance within the schematic. Next, when the PCB board is ready for component 
placement, the ROOMS property will make it easier to allocate the designated 
components into their respective areas on the board. 
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Net Properties for the ORCAD and Allegro PCB Editor 

There are many different ORCAD and Allegro PCB Editor net properties you can add to 
your design. The table that follows describes five commonly used OrCAD Capture to 
OrCAD and Allegro PCB Editor net properties.  

OrCAD and Allegro PCB Editor Net 
Properties 

Description 

MIN_LINE_WIDTH This property attaches to a net and sets the minimum width of a 
net or connect line. Use this property to override the Min line 
width rule in a physical constraint set. It also overrides the line 
Width electrical constraint for a differential pair, if set. The value of 
this property is in design units. 

MAX_LINE_WIDTH This property attaches to a net and sets the maximum width of a 
net or connect line. Use this property to override the Max line 
width rule in a physical constraint set. 

NET_PHYSICAL_TYPE This property attaches to a net. This translates to the name of the 
Physical > Net Class to be applied in the OrCAD and Allegro PCB 
Editor. 

NET_SPACING_TYPE This property attaches to a net. This translates to the name of the 
Spacing > Net Class to be applied in the OrCAD and Allegro PCB 
Editor.  

PROPAGATION_DELAY This property defines the minimum and maximum propagation 
delay constraint between any pair of pins or rat-Ts in a net or an 
extended net (Xnet). 

RELATIVE_PROPAGATION_DELAY This property replaces MATCHED_DELAY in Allegro PCB Editor 
version 14.0. It is an electrical constraint attached to pin-pairs on a 
net. It specifies a group of pin-pairs that are required to have 
interconnect propagation delays matching a specified delta (offset) 
and tolerance. A RELATIVE_PROPAGATION_DELAY group has one 
or more reference pin-pairs against which all other pin-pairs in the 
group are compared.  

To attach the properties shown in the list, select one or more nets, and set the Filter by 
field to Cadence-Allegro in the Property Editor. Then choose the corresponding net 
property from the list that displays.  
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Create Differential Pairs between flat nets 

OrCAD Capture has the ability to allow you to create Differential Pairs between flat nets 
in your design for the Allegro PCB Editor. You can set the DIFFERENTIAL_PAIR property 
on selected nets using the Property Editor. See the Property filter for Cadence-Allegro. 

There is also a command Create Differential Pair located on the Tools pull-down menu. 
In the Create Differential Pair dialog box you can view the nets defined in your design 
and create a Differentials Pair between selected nets. 
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Back Annotating the Schematic  

 

OrCAD Capture lets you backannotate schematics with design changes made in the 
OrCAD and Allegro PCB Editor. The OrCAD Capture Back Annotate command lets you: 

• Change part references 
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• Change net properties 

• Change part properties 

• Swap gates and pins 

When you use the OrCAD Capture back annotation command, you no longer need to 
export the net files from the OrCAD and Allegro PCB Editor.  

In the OrCAD and Allegro PCB Editor, when you use the File > Export Logic command to 
send information back to the OrCAD Capture schematic, the OrCAD and Allegro PCB 
Editor produces four backannotation files: 

• pinView.dat:   Contains all pins and net connections 

• netView.dat:   Contains all net properties 

• compView.dat:   Contains all part properties 

• funcView.dat:  Contains all gate properties 

These files can also be produced in OrCAD Capture using the Tools > Back Annotate 
command, and selecting the Generate Feedback Files option. 

In OrCAD Capture, when you use the Tools > Back Annotate command, these four files 
are processed into a single backannotation file, called a swap file. The swap file is then 
used to update the OrCAD Capture schematic with new part references, as well as part 
and net properties. 

All gate and pin swapping data is automatically included in the swap file. The 
backannotation of part and net properties is controlled by the Allegro.cfg file. 

The Export > Logic files for the Back Annotation process must be in the same “Allegro” 
subdirectory as the original Net List files. 



 

 

Lab 11-1: Adding OrCAD and Allegro 

PCB Editor Properties 

Lab Objectives  

After completing this lab you will be able to: 

• Browse parts 

• Add a PCB Footprint property 

• Add a ROOM property 

An alternate method for doing some of the following labs is to use the Property Editor 
and the Edit Object Properties method from the Project Manager window. 

Browsing Parts 

1. Choose File > Open > Design and navigate to 
C:/EMA_Training/Capture_Essentials/Designs/part_manager_training and select the 
Part_Manager_Training.dsn 

2. In the Project Manager window, select .\Part_Manager_Training.dsn, then RMB click 
and select Edit > Object Properties. The Property Editor window opens displaying 
the current properties of all of the parts in the design. 

3. Set Filter by to: OrCAD PCB Designer Standard. 
4. Close the Property Editor window. 
5. Select Edit > Browse > Parts from the main menu. 
6. Click OK to continue. 

The Browse Parts window lists all the parts in the design. 

Adding the PCB Footprint Property 

1. Scroll down and double click on part reference U2. 
2. When the schematic page opens note that U2 will be highlighted. Double click on U2 

to open the Properties window. 

The Browse Spreadsheet displays properties currently attached to U5. 

3. Locate the PCB Footprint column to verify a cell value of SOIC32-600.  
4. If necessary, click in the cell, and enter: 

SOIC32-600  

5. Click Apply to make the necessary change. 
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6. RMB on the Property Editor tab and close the window. 
7. Close the Browse Parts window, and save the design. 

Browsing Nets 

1. In the Project Manager window, click on .\Part_Manager_Training.dsn and select 
Edit > Browse > Nets. 

2. Click OK to continue. 

The Browse Nets window lists all the nets in the design. You can also select the 
ObjectID column header to sort the nets. 

Adding the MIN_LINE_WIDTH Property 

The following is one method you can use to add net properties to wires. 

1. You may wish to click in the Object ID field name to sort the net names for easier 
searching. Scroll down and locate VCC.  

 

2. Double click on the VCC line to open the schematic. Notice that the schematic page 
shows the highlighted net VCC. 

3. RMB click and choose Edit > Properties from the pull-down menu (or CTRL+E). 
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The Property Editor opens and displays properties currently attached to the VCC net. 
Add the following values if they have not already been added. 

4. In the MIN_NECK_WIDTH field enter 8 
5. In the MIN_LINE_WIDTH field enter 15 
6. Click Apply to continue. 

 

7. Close the Browse Nets window, and save the design. 

Adding a ROOM Property  

1. In the Project Manager window, double click on PAGE1 to open it.  

2. When PAGE1 opens select the components as shown in the following graphic: C1, 

C2, C3, C4, C5, C6, and U5. You may wish to use the View > Selection Filter to 

choose only Parts for selection. 

 

3. Next, RMB and choose Edit – Properties 

4. Scroll down in the Property Editor and notice that there are no settings for the 
ROOM property for the selected parts. 

5. In the ROOM field under C1 enter the value ROOM1. 
6. Do this for each of the parts. Optionally you can select the first ROOM1 cell and drag 

(from the lower right corner of the selected cell) across the rest of the ROOM cells 
for all of the parts. This will copy the ROOM1 entry across all those cells. 
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7. Click Apply to activate the change. 
8. Close the Property Editor page. 
9. Save the design. 
 

Closing the Part_Manager_Training Project 

1. Select File > Close. 

 

This completes Capture Essentials training. 
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Appendix A:  Working with 

Hierarchy in Capture 

Hierarchical Design 

 

When you embed a schematic folder inside another schematic folder, you have created 
a hierarchical design. The process requires a block symbol, which represents a schematic 
or functional model. When the block symbol is used once in a schematic, the result is 
called a simple hierarchy (shown in the accompanying diagram). When the block symbol 
is used two or more times, the design is called a complex hierarchy. 
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More Information 

The root schematic represents the top of the hierarchy and is displayed in the Project 
Manager window with a slash on the folder icon. 

A hierarchical design has several advantages. Its block diagram structure clearly shows 
how the functional units interact, and each block can be reused in the same or future 
designs. When you edit a block, all instances of the replicated block are changed 
throughout the hierarchical design. 

Complex Hierarchical Designs 

 

In a complex hierarchical design, OrCAD Capture automatically maintains multiple 
copies of the schematic in its database, one for each time it is referenced. 



OrCAD Capture Essentials   Version17.4 

April 2020 EMA Design Automation, Inc. ®   © 2020 All rights reserved                     265 

Connectivity in Hierarchical Designs 

 

In flat designs, all the schematic pages are at the same level. You establish inter-page 
connectivity by terminating nets with off-page connectors.  

By contrast, hierarchical designs have what might be called nested functionality 
embedded in schematic pages. Hierarchical block symbols on one schematic page 
reference more detailed design descriptions (other schematics or VHDL models). 

More Information 

The hierarchical pins on the block symbol and the hierarchical ports in the schematic (or 
VHDL file) are used to establish connectivity between the schematic folders in a 
hierarchical design. 
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Hierarchical Pins and Port Types 

 

There are eight types of hierarchical ports, each with its own corresponding hierarchical 
pin type (as shown in the accompanying illustration). 

To establish connectivity, a hierarchical pin must have a matching hierarchical port with 
the same Name and Type.  

Adding a Port Symbol 
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In OrCAD Capture, there are eight port symbols to choose from. The symbol names relay 
information to the user about the direction in which the port is pointing (graphically), 
and the location of the pin (connection point). For example, PORTLEFT-R is a port 
symbol that points to the left, with a pin on the right. You may need to rotate port 
symbols before you place them. 

More Information 

You need to name the port to establish connectivity between the wire on the port, and 
the hierarchical pin on the block symbol. You can enter the name while placing the port, 
or change the name after you have placed it. 

When adding a port, you must specify the port type. The port type provides a logical 
description of the net it represents (for example, input, output, or bidirectional). 

Each of the eight symbols has a default type setting. You can select the port type while 
placing it, or change it after it has been added. 

Port symbols Default type 

PORTBOTH-L 

PORTBOTH-R 

Bidirectional 

PORTLEFT-L 

PORTLEFT-R 

Output 

PORTNO-L 

PORTNO-R 

Passive 

PORTRIGHT-L 

PORTRIGHT-R 

Input 
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Hierarchical Design Methods 

 

 
Some degree of automated design supports either a bottom-up or top-down design 
flow. If you create additional hierarchical ports in the schematic or additional pins in a 
hierarchical block symbol, use the Synchronize Up or Synchronize Down command to 
re-link the data. 

Drawing a Hierarchical Block 

The following steps are used to generate a Hierarchical Block: 

• Blocks may be drawn by using the Place > Hierarchical Block command from the 
Place menu, or by using the command icon.  

• When the dialog opens give the block a Reference name, an Implementation name, 
and choose Schematic View for the Implementation Type, then click OK.  

• Drag a rectangle to indicate the block area.  
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• Add hierarchical pins to the block by making sure that the block is selected, then 
choose Place >> Hierarchical Pin from the Place menu. 

 

Since a Hierarchical Block represents a schematic page, the block must be synchronized 
with the schematic page it will be representing.  

• Therefore you will need to “push” into the block to add the schematic page and 
complete the synchronization between the block and its schematic page. Do this by 
double-clicking on the block. 
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The new schematic page will open, and the Hierarchical Ports will appear in the upper 
left corner of the schematic. These may be moved to a preferred location on the page. 

 

When making changes to either a hierarchical block, or to the schematic it represents, 
the changes must be synchronized so that both the page and the block connectivity 
aligns. This alignment process must occur at the block level, where the block is selected, 
then RMB and choose either Synchronize Up -or- Synchronize Down. 

Synchronizing Up is when you have made changes at the schematic level, (for instance 
adding new hierarchical ports). The new ports must be made visible on the block to 
complete the connectivity between schematic page and block. 

Synchronizing Down is when you have made changes at the block level (for instance 
adding H-pins). The new h-pins must be made visible on the schematic page to complete 
the connectivity between the block and the schematic page. 


