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Early Die bump planning using SiP Layout with EDIS

Purpose

The purpose of this Application Note is to describe the process for early IC bump
planning and data exchange based on DEF and die abstract using the SiP Layout and
Encounter Digital Implementation System (EDIS) environments.

Audience

This application note is intended for Package designers and IC bump array designers
responsible for the IC/package bump planning process. A method to intelligently define,
manipulate and exchange the bump plan data between the SiP Layout and Encounter
Digital Implementation System (EDIS) environment is demonstrated.

Overview

Given today’s large Die bump counts, multiple power domains, small pin pitches and
high speed interfaces, early die bump planning has become a critical part of the IC and
package design process. In the past, the IC designers were typically responsible for the
die bump process, and it was often done in the late stages of the IC physical design
process due to IC designers’ focus on RTL, timing, IP resourcing, IP/PHY/macro
integration, and many other factors. However, there has been a shift in the recent years,
and it is now a critical component that must be included in the early stages of the IC
design process. To ensure a proper bump plan meeting the ultimate goals of the IC
design requirements, and start the process of sizing Die, mocking up hard macros, io’s,
PHY, and core logic requirements, it is done even as RTL is being developed.

This is an extremely long and complicated process that requires the knowledge of IC
and Package technologies. Currently, Pkg designers undertake this by using their
packaging tools of choice to exchange data with the IC designers throughout the
process.

The high-level key areas in the bump planning process should address the following
minimum requirements:

e Consuming and managing the IC LEF information being used for the IC design

e Flexibility in designing and managing both UBM (flip chip passivation opening)
and die pin requirements

e Integration of early IC top-level details (LEF technology) and Substrate materials

e Die Shrink planning and Pkg CTE bump pins for assembly planning

¢ Intelligent data exchange from the Pkg environment (SiP Layout) to IC (EDIS;
Encounter Digital Implementation System)

o Mustinclude ECO as die bump refinement process
o Must leverage either IC netlist information or netlist generated on the fly at
the Pkg level
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Early Die bump planning using SiP Layout with EDIS

Before commencing with the actual bump plan flow process, it is important to

understand the proposed top-level bump planning flow and introduce the die abstract

data concept.

The following image shows the proposed flow solution covered in this document:

Flow Solution: Early SiP-driven bump planning

SiP Driven Die Bump Planning
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In the flow, notice the key bump plan bidirectional data exchange process is based on
the die_abstract.xda. The SiP Layout and EDIS environment have had this capability for
many years. Furthermore, this flow assumes starting from a “ground up design flow”,
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meaning there is no IC die information available to the user. If an EDIS design is
available with pre-planned bumps, the DEF process can be omitted, and the die
abstract flow process is used as outlined in this application note.

A brief description and comparison with a simple SiP Layout footprint symbol instance
model and that of the abstract.xda is described in the following image:

« Anatomy of a dra symbol vs. die abstract for co-design and co-analysis:

— Dra symbol has no intelligence, only pins and footprint dimension, and text

labels.
— .xda embeds top-level IC data details for design, optimization and
analysis.
Regular symbol (.dra) r Die Abstract (.xda)
A T r > DIE Boundaly\r T T ‘ | L
N % ekl e W T 4
i RN N SR 45/ PR Scribe Lines, i 3

A Y Optical shrink

o IO cell, padring

£ “::‘:,:::.
% 7 :;ﬁ L

\ IC-10 signal

Names (bump
vs. internal net)

Now that the baseline information has been described for both the bump plan flow and
the abstract exchange mechanism, you can proceed to how the entire process works
with the SiP Layout and EDIS.

Note: The SPB 16.6x release does not support the creation of a die abstract
(abstract.xda) from a start from nothing flow. Only a die abstract initially generated from
EDIS is supported as the bidirectional data exchange mechanism today. However, SiP
Layout does provide the capabilities of generating the bump plan based on DEF. As
such, we can employ the DEF bump plan pin out for a start from nothing flow, pass that
initial DEF based bump plan to EDIS, and then use the abstract.xda process for the
remainder bump planning process.
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An alternative option is to start with a mockup bump array or a predefined bump array in
EDIS, export EDIS die abstract, and load that abstract to the SiP Layout.

SiP Layout: Initial data setup using LEF

You can use the following options to set up the design information into the SiP Layout
for early bump planning:

1. There are currently two options from available in SiP Layout to create a start from
nothing flow for the initial bump plan and exporting that data to EDIS:

a. LEF/DEF (Def out) based
b. GDSII (stream_out)

2. You will use LEF/DEF out for this flow (only needed once, afterwards all based
on die abstract):

Load LEF file(s).

Create/open your <design_name>.sip design.

Select Setup—>LEF Libraries.

Add file name under library definition file.

Add Library name under Library Settings

Select Add and load LEF file(s).

Select Auto Create under CML settings.

Set the SiP Layout to Symbol Editor Application mode.

S@ e a0oTp
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The following image shows the sample setup using the IC Library Manager:

=3 - x

Library Definition Filz
Current directory: . ork_data/customer_data/QC0OMASD Ao _trair

[

File name: |m_l,J_Iefs.Idf Browse...

Library settings

Current library from Library Definition file

Sll_lef »| [ add. | [ Remove
LEF files
*
+*
Remave
Usze LEF file path relative to LDF file
CHL settings
File name:  all.cml
Statug: Up to date.

See the command line for details.

SiP Layout: Creating die and bump cells
3. Create Die outline.

a. Select Setup—~>Application Mode—->Symbol Edit.
b. RMB->Add Component.

e Set up all the parameters in Options Form.
e Select Create Component.

c. Select Component (make sure find filter is set to Comps).
d. RMB->Add pins (add pin dynamically).
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SiP Layout: Exporting initial bump plan to EDIS

4. After initial bump plan, export Die bumps to EDIS. You will use DEF OUT in this
flow.

5. Select Export->DEF (Die pins only).

a. Configure the Physical pin Layer and Layer name for bump cell.
b. Map the SiP Layout die bump padstack to LEF bump macro.

The following images show a typical setup process:

[ LEF Pin Parameter; i

MHurber of Unassigned ping. 236

Ping

Padstack:  [[RlSSEE0

| Fin Use: e ]
GROUMD
POWER
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Diie to expaort: [DIE V] WMacro Data
Output file name: |test Browse... Macro List:
. burmp_cell_110
DEF versior: [5.? v] bump_cell 160
burnp_cell_apB0_ubmd3
Tiles Export
Tile Inztances Flattened Tiles * = multiple macra associations
PFin Use:
Physical pin layer PinSize:  0.003 0.00 microns
LEF Library: [ Library Manager... ] Lef Litrary:
Layer Mame: [ ap - ] [ LEF library Manager...
Allow Reaszsign ] ian Al Fi
[ Ok J [ Cancel ] [ Help ] D e MESIE e
[ QK. ] [ Cancel ] [ Apply ] [ Help
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EDIS: Load initial bump plan

6. Load DEF or areaio file (<design_name>.fp).

a. Toload DEF (via GUI), select File>Load->DEF.

The following image shows an example of the DEF-based bump array in EDIS:
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EDIS: Creating die abstract to exchange with SiP
Layout

Once the bumps are in EDIS, it is simple to create a die abstract:

7. Launch EDIS to create die abstract.

8. Open Linux terminal window.

9. cd <your_design_inst_dir>.

10.Encounter and open/restore encounter design <my_design.enc>.
11.To write die abstract from encounter command line:

a. encounter>write_codesign_abstract <abstract_name>.xda , which is
write_codesign_die_abstract my_abstract_name.xda
b. Use command line “write_codesign_die_abstract —help” to see options.

EDIS<SIP: Creating die abstract to exchange with SiP Layout

12.Set db resolution to 3 decimal places, enable Symbol Editor app mode.

a. Go to Setup—>Design Preferences—>Design Parameters Editor->Design
Tab.
b. Set Accuracy to 3.

13.Go to Setup—~>Application Mode—->Symbol Edit.
14.Load Abstract File.

Add->Co-Design Die.

Select <abstract_name>.xda, then click OK.

Set parameters for the Place Co-Design Die Form.
Set Select Show IC details after import and Shrink.

aoop
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The following image shows a setup form to add Co-design Die:

E Place Co-Design Die = XN

Die Logic
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Import net assignments

Die Attachment
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EDIS<SIiP: Additional die abstract options for UBM and die pin
configuration

With abstract, we can intelligently handle both UBM and die pin.

15.UBM (passivation opening) is treated as octagon cell as defined in LEF macro.
16.Die Pins is treated at Circular padstacks as Selected or defined by user, and can
be configured taking the following steps:

With Symbol Editor, enable the app mode.
Set Find filter to Pins.

Use LMB and Select Die pins (all or partial).
RMB->Change attributes.

aoop

The following image shows an example setup form to add Co-design Die:
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EDIS<SIP: Generating SiP Layout data to export to EDIS (as ECO
update)

After abstract optimization and other changes, Export the new abstract to EDIS.

17.Go to File>Export->Die Abstract File.
18. Set Abstract writer parameters, and click OK.

EDIS<SIP; EDIS importing die abstract (as ECO update)
19.EDIS can import Die Abstract ECOs in two modes:

a. Mode 1: Graphical mode with abstract design differences checking (you will
use this option for the promoted flow):

I.  This mode lets the user to see all the related ECO changes

graphically.
[I.  EDIS must be running in graphics mode.

b. Mode 2: Non-graphics mode and bypassing the abstract differences checker:

I.  Abstract ECO will be processed and directly imported into
EDIS (unless a checking only is performed).
[I.  EDIS will be running in non-graphics mode.

EDIS<SIP; EDIS importing die abstract (as ECO update)

For the purposes of this application note, you will only run the die abstract import
process using Mode 1, graphical mode with abstract design differences checking.

20.To import die abstract using encounter command line:
a. Launch encounter on <your_design.enc> or restore design if necessary.
b. Encounter > read_codesign_die_abstract <abstract_name_eco>.xda.
i. Use read_codesign_die_abstract —help to see options.

The following image shows the abstract difference viewer after EDIS has processed
the abstract ECO information coming from the SiP Layout:
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Summary

This Application Note explains the Pkg and IC design with the concept of early bump
planning using the SiP Layout and EDIS environments. Additionally, the die abstract
data concept and using DEF as an early bump planning solution is explained as a viable
bump plan data exchange mechanism between the SiP Layout and EDIS environment.
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Support

Cadence Online Support provides access to support resources, including an extensive
knowledge base, access to software updates for Cadence products, and the ability to
interact with Cadence Customer Support. Visit https://support.cadence.com.

Feedback

Email comments, questions, and suggestions to content_feedback@cadence.com.
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