
 
How to Convert a UPD Package Substrate for Use with 
APD and SiP Layout 
Product Version SPB16.6 
March 6, 2013 
 

 

 

 

 

 

 

 

 

 

Copyright Statement 

© 2013 Cadence Design Systems, Inc. All rights reserved worldwide. Cadence and the 
Cadence logo are registered trademarks of Cadence Design Systems, Inc. All others are the 
property of their respective holders. 

 



 
How to Convert a UPD Package Substrate for Use with APD and SiP Layout 

Contents 

Purpose ....................................................................................................................... 3 
Audience ...................................................................................................................... 3 
Procedure 1: Importing a Package Substrate Design .................................................. 5 
Procedure 2: Identifying Data Requiring Manual Conversion or Import ....................... 7 
Procedure 3: Building up your APD / SiP Layout Libraries .......................................... 9 

Physical Library Data ............................................................................................. 10 
Technology Data .................................................................................................... 10 
User Preference Data ............................................................................................ 10 

Did You Know... ......................................................................................................... 10 
Coming Soon… ......................................................................................................... 11 

 



 
How to Convert a UPD Package Substrate for Use with APD and SiP Layout 

Purpose 
This document describes the procedure to import UPD spd2 format files in Cadence 
APD or SiP Layout tools and creating your APD/SiP Layout libraries based on imported 
data. 
 

Audience 
This document is intended for users who would like to migrate from UPD package 
layout tool to Cadence APD or SiP Layout Design tools. 

. 
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How to Convert a UPD Package Substrate for Use with 
APD and SiP Layout 
 
If you are a user migrating from the UPD package layout tool to the Cadence APD or 
SiP Layout design tools, you will need to convert your existing designs into the new 
database format. You may also need to create libraries of symbols, padstacks, device 
files, and technology files.  
 
One important thing to understand before continuing is that only NA2 and SPD2 formats 
from UPD – the ASCII text versions of a UPD design database – are supported for 
import. If your UPD design is currently saved in binary UPD (*.upd) format, you will need 
to open the design in UPD and save it to the SPD2 format. Also understand that SPD2 
and SPD file formats are completely different. Importing an SPD file is not supported. 
In this document, we will cover the import of a UPD “SPD2” database into APD or SiP 
Layout. The process in either tool is identical. So, any command menu locations, forms, 
log files, and other items mentioned should be the same in your APD tool as in the SiP 
Layout screenshots shown. The primary difference being any reference to die stacks, 
which are present only in the more advanced SiP Layout tool.  
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Procedure 1: Importing a Package Substrate Design 
Before beginning, check the format of the database file you are importing. NA2 files may 
be imported with the default configuration of APD or SiP Layout. If you have a more 
recent SPD2 format file, you will want to enable this format’s support in Setup -> User 
Preferences… (“enved”) as highlighted below. After setting this variable, restart the tool. 
 

 
 

Secondly, if you are new to APD and SiP Layout and have not configured your library of 
materials, you should do so now. This information is not stored in the design databases 
themselves, but instead resides in the “mcmmat.dat” file, which you can find in the 
share/pcb/text subdirectory of your Cadence software installation. 
  
Instructions and file format information for the materials file are located at the top of the 
file itself, which can be opened in any text editor. Since this one file is used to store all 
material information for all your designs, you should update it with all materials that you 
use in your designs. This assumes that you have a listing of these from your 
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manufacturing partners. If you do not, when you import a UPD database, you will get 
warning messages for materials that are not found in this file and that you will need to 
add. In order to avoid overwriting materials information referenced by other designs you 
may have, the library materials information is never directly updated based on the UPD 
database being converted. 
 
You are now ready to begin. Run the File -> Import -> SPD2 / NA2… (“na2 import”) 
command. This will bring up the import configuration form, below, where you can 
choose what specific data you want to import. The image shown illustrates the default 
settings that Cadence recommends for your database conversion. 
 

 
 

After browsing to your source UPD database file and specifying the default file name for 
the converted database (this will always default to the same file name and location as 
the UPD database, but with the new file extension), set the data to import.  
 
Note: Because of the large differences in how plating bars are defined in terms of 
database structures between UPD and APD / SiP Layout, Cadence does not advise 
importing the plating bar through this process. Commands are available inside of the 
tools to generate the plating bar after import is complete and verified. 
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Procedure 2: Identifying Data Requiring Manual 
Conversion or Import 
Once you have finished importing your design file, it is time to make any necessary 
updates for information that is not 1:1 compatible between the two environments, that 
may not be available in the SPD2/NA2 file itself, or that may be exclusive to the APD 
and SiP Layout environments. 
  
The first step in doing this is to check the import log. This provides detailed information 
on any data that could not be read, data which may be missing, and any advisories that 
you should be aware of. It also includes a complete listing of the constraints which have 
been mapped from the UPD database to the APD / SiP Layout database.  
 
Note: If you feel a constraint mapping is not present that should be, please contact your 
customer support representative with what you feel that mapping should be.  
 
Should you see any errors or warnings in the log file, they will almost always include a 
reference line number inside the source file. From that line number, you can get highly 
specific information about the affected object, as the SPD2 and NA2 files are both 
ASCII text files which you can open in any text file editor of your choice. It is 
recommended that you deal with these warnings and error messages as a very first 
step. They may indicate common issues that will arise in future design conversions and 
therefore will warrant a note for future reference.  
 
After processing any logged issues, it is time to move on to information specific to your 
designs. The following is a list of common items to check. It is not exhaustive as your 
designs may differ in structure and definition of other users. This is a guide only, and it 
is advisable that you create your own checklist based on your specific flow and data. 
Common items requiring manual data entry, object creation, and setting verification: 
 

• Plating Bar – As stated in procedure 1, it is not recommended that you import the plating bar 
from the UPD design, as the two design environments handle the plating bar in very different 
manners. Instead, after conversion, run the Manufacture -> Create Plating Bar… (“pbar create”) 
command. This will generate the plating bar automatically based on clines extending beyond 
the package edge.  

• DRC Constraints – Only constraints with a clear 1:1 mapping between the two environments are 
translated. Some items exist in UPD which are not present in the APD/SiP tools and vice versa. 
Others may exist in both environments but be applied differently (e.g. an object type constraint 
versus a global database constraint). Use the Cadence Constraint Manager to configure any 
constraints which have not yet been set up.  

• Net Shorts – If you design contains nets that are shorted together (typically done using UPD’s 
“super nets” capability), these nets must be manually shorted together inside of APD / SiP 
Layout. Use the Route -> Define Short… (“define shorting scheme”) and Route -> Create Short… 
(“create short”) to configure the legal net shorting schemes for your design. 
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• Static vs. Dynamic Shapes – In order to preserve their exact boundaries, all shapes imported 
from a UPD database are initially created as static shapes. This means that any changes to their 
boundaries, including voids around objects on other nets, must be done manually. Consider 
converting shapes to dynamic mode to allow real-time voiding as you continue to work on the 
design.  

• Artwork Films – If you use Artwork films for generating manufacturing outputs, you will need to 
define your films using the Manufacture -> Artwork… (“artwork”) command. These film 
definitions are used by select other commands, including PDF file generation and film area 
reports. If you will be using any of these tools, you will also need to configure films at this point.  

•  (SiP Layout Only) Cavity, Die Stack, and Die Physical Properties – If you are using SiP Layout, 
use the Edit -> Die Stack… (“diestack editor”) to verify cavity settings as well as die ordering 
within the stack. Finally, for any flip-chip die components, configure the solder bump 
geometries for the pins.  

 
Once you are happy that your design represents a 100% accurate conversion, consider 
whether any of the objects should be turned into library objects for future design reuse. 
If this applies to you, carry on to procedure 3. If not, skip ahead. 
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Procedure 3: Building up your APD / SiP Layout 
Libraries 
Now that you have finished importing your design, you may wish to export specific 
information to build up your library of reusable design elements. This will give you a 
quick jump start when beginning similar new designs. There are many different aspects 
of your design which can be converted into library elements. The specific commands 
that you use to do this, however, are all found in the same menu of the tool: The File -> 
Export menu, as shown below: 
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Physical Library Data 

Physical information, whether it be a library symbol, padstack definition (and 
corresponding custom pad shapes), mechanical symbols, or even component device 
files, are all exported with a common command. The File -> Export -> Libraries… (“dlib”) 
command manages this for you.  
The only exception to this is a choice that you have. Do you want your library objects for 
BGA and Die components stored in binary database format (*.dra) or in a readable 
spreadsheet format that you can look at and modify in any spreadsheet or text file 
editor? If you prefer the text spreadsheet format, use the File -> Export BGA / Die Text-
Out Wizard… commands (“bga text out” and “die text out”, respectively) to write these 
files out. DRA files may contain more customized information such as logos and non-
rectangular component outlines, while TXT files are easier to read and need no 
uprev/downrev as you change Cadence software releases. 

Technology Data 

Design rules are stored in technology files. To export the tech file for your design, use 
the File -> Export -> Techfile… (“techfile out”) command. This simple command requires 
only that you provide a file name and location for the exported techfile. Later on, you 
can read this techfile’s information into a different design using the File -> Import -> 
Techfile… (“techfile in”) command. If you want a quick report of the differences between 
a library techfile and your current design, use the Tools -> Technology File Compare… 
(“techfile compare”) tool.  

User Preference Data 

The final types of data you can export for library or personal reuse are the various 
design parameter settings. From color palette values and preferred layer/wire 
profile/component color assignments to text sizes and default behaviors and settings for 
certain commands, these settings are managed with the File -> Export -> Parameters… 
(“param out”) command.  
 
With this command, you need only specify the file name along with what parameters 
you want the file to contain. Import this into another design file with the File -> Import -> 
Parameters… (“param in”) command to quickly make any design conform to your ideal 
look and behavioral feel. 

Did You Know... 
Performing these tasks all at once, by one person (or by following the flow documented 
by a single expert in your company) can make the process efficient and minimize errors. 
This one expert will understand any additional data which may need to be manually 
imported after translating the core design. As every company’s designs have their own 
unique characteristics, the specific things to look for and manually update will vary.  
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For additional assistance in converting your designs, contact your Cadence customer 
support expert. They are there to help keep you working as fast, smart, and efficiently 
as possible.  

Coming Soon… 
The UPD package design product is being phased out. It is no longer for sale. Support 
of the product – including bug fixes – is scheduled to end at the end of the 2014 
calendar year. Start converting your designs and gaining expertise with the APD and 
SiP Layout products to ensure you maintain the highest possible level of design 
efficiency.  
 
Another advantage of migrating to the new products early is that, by learning the new 
tools now, you will be able to request specific functional enhancements to your new 
layout tools that will make your transition as seamless and pleasurable as possible. 
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